Remove arcfour (RC4) cipher no longer available in newer OpenSSH
[chef.git] / cookbooks / osqa / metadata.rb
1 name              "osqa"
2 maintainer        "OpenStreetMap Administrators"
3 maintainer_email  "admins@openstreetmap.org"
4 license           "Apache 2.0"
5 description       "Installs and configures OSQA"
6 long_description  IO.read(File.join(File.dirname(__FILE__), "README.md"))
7 version           "1.0.0"
8 depends           "apache"
9 depends           "memcached"
10 depends           "tools"
11
12 attribute "osqa",
13   :display_name => "OSQA",
14   :description => "Hash of OSQA attributes",
15   :type => "hash"
16
17 attribute "osqa/revision",
18   :display_name => "OSQA Revision",
19   :description => "Default revision of OSQA to use",
20   :default => "703"
21
22 attribute "osqa/user",
23   :display_name => "User",
24   :description => "Default user to run OSQA as",
25   :default => "osqa"
26
27 attribute "osqa/group",
28   :display_name => "Group",
29   :description => "Default group to run OSQA ad",
30   :default => nil
31
32 attribute "osqa/database_name",
33   :display_name => "Database Name",
34   :description => "Default database to run OSQA against",
35   :default => "osqa"
36
37 attribute "osqa/database_user",
38   :display_name => "Database User",
39   :description => "Default user for OSQA to connect to the database as",
40   :default => "osqa"
41
42 attribute "osqa/database_password",
43   :display_name => "Database Password",
44   :description => "Default password for OSQA to authenticate to the database with",
45   :default => ""
46
47 attribute "osqa/sites",
48   :display_name => "Sites",
49   :description => "Array of OSQA sites to setup",
50   :default => []