Fix rubocop warnings
[chef.git] / Gemfile.lock
index 10bd9d1f2f4171e6dc517031ad28bfa188f6374f..c48ed52d921f0356f33de034839ce56ccb70798c 100644 (file)
@@ -5,8 +5,9 @@ GEM
     ast (2.3.0)
     cucumber-core (1.5.0)
       gherkin (~> 4.0)
+    diff-lcs (1.2.5)
     erubis (2.7.0)
-    foodcritic (6.3.0)
+    foodcritic (7.1.0)
       cucumber-core (>= 1.3)
       erubis
       nokogiri (>= 1.5, < 2.0)
@@ -22,11 +23,15 @@ GEM
       artifactory
       mixlib-shellout
       mixlib-versioning
-    mixlib-shellout (2.2.6)
+    mixlib-shellout (2.2.7)
     mixlib-versioning (1.1.0)
+    multi_json (1.12.1)
     net-scp (1.2.1)
       net-ssh (>= 2.6.5)
     net-ssh (3.2.0)
+    net-ssh-gateway (1.2.0)
+      net-ssh (>= 2.6.5)
+    net-telnet (0.1.1)
     nokogiri (1.6.8)
       mini_portile2 (~> 2.1.0)
       pkg-config (~> 1.1.7)
@@ -37,7 +42,23 @@ GEM
     powerpack (0.1.1)
     rainbow (2.1.0)
     rake (11.2.2)
-    rubocop (0.41.1)
+    rspec (3.5.0)
+      rspec-core (~> 3.5.0)
+      rspec-expectations (~> 3.5.0)
+      rspec-mocks (~> 3.5.0)
+    rspec-core (3.5.2)
+      rspec-support (~> 3.5.0)
+    rspec-expectations (3.5.0)
+      diff-lcs (>= 1.2.0, < 2.0)
+      rspec-support (~> 3.5.0)
+    rspec-its (1.2.0)
+      rspec-core (>= 3.0.0)
+      rspec-expectations (>= 3.0.0)
+    rspec-mocks (3.5.0)
+      diff-lcs (>= 1.2.0, < 2.0)
+      rspec-support (~> 3.5.0)
+    rspec-support (3.5.0)
+    rubocop (0.42.0)
       parser (>= 2.3.1.1, < 3.0)
       powerpack (~> 0.1)
       rainbow (>= 1.99.1, < 3.0)
@@ -46,15 +67,27 @@ GEM
     ruby-progressbar (1.8.1)
     rufus-lru (1.1.0)
     safe_yaml (1.0.4)
-    test-kitchen (1.10.2)
+    serverspec (2.36.0)
+      multi_json
+      rspec (~> 3.0)
+      rspec-its
+      specinfra (~> 2.53)
+    sfl (2.2)
+    specinfra (2.61.1)
+      net-scp
+      net-ssh (>= 2.7, < 4.0)
+      net-telnet
+      sfl
+    test-kitchen (1.11.1)
       mixlib-install (~> 1.0, >= 1.0.4)
       mixlib-shellout (>= 1.2, < 3.0)
       net-scp (~> 1.1)
       net-ssh (>= 2.9, < 4.0)
+      net-ssh-gateway (~> 1.2.0)
       safe_yaml (~> 1.0)
       thor (~> 0.18)
     thor (0.19.1)
-    treetop (1.6.5)
+    treetop (1.6.8)
       polyglot (~> 0.3)
     unicode-display_width (1.1.0)
     yajl-ruby (1.2.1)
@@ -66,6 +99,7 @@ DEPENDENCIES
   foodcritic
   kitchen-vagrant
   rubocop
+  serverspec
   test-kitchen
 
 BUNDLED WITH