Ignore failure changing sysctl values
[chef.git] / Gemfile.lock
index c555a08a511b0850ab82832422195d79e0b515af..8102dd161b78dc2838f229721abf9f0f78fcc61f 100644 (file)
 GEM
   remote: https://rubygems.org/
   specs:
-    artifactory (2.5.0)
-    ast (2.3.0)
-    backports (3.6.8)
-    cucumber-core (2.0.0)
-      backports (~> 3.6)
-      gherkin (~> 4.0)
-    diff-lcs (1.2.5)
+    ast (2.4.0)
+    backports (3.11.3)
+    builder (3.2.3)
+    cucumber-core (3.1.0)
+      backports (>= 3.8.0)
+      cucumber-tag_expressions (~> 1.1.0)
+      gherkin (>= 5.0.0)
+    cucumber-tag_expressions (1.1.1)
+    diff-lcs (1.3)
     erubis (2.7.0)
-    foodcritic (8.1.0)
+    ffi (1.9.23)
+    ffi-yajl (2.3.1)
+      libyajl2 (~> 1.2)
+    foodcritic (13.1.1)
       cucumber-core (>= 1.3)
       erubis
+      ffi-yajl (~> 2.0)
       nokogiri (>= 1.5, < 2.0)
       rake
       rufus-lru (~> 1.0)
       treetop (~> 1.4)
-      yajl-ruby (~> 1.1)
-    gherkin (4.0.0)
-    kitchen-vagrant (0.20.0)
+    gherkin (5.0.0)
+    gssapi (1.2.0)
+      ffi (>= 1.0.1)
+    gyoku (1.3.1)
+      builder (>= 2.1.2)
+    httpclient (2.8.3)
+    kitchen-vagrant (1.3.2)
       test-kitchen (~> 1.4)
-    mixlib-install (2.1.3)
-      artifactory
+    libyajl2 (1.2.0)
+    little-plugger (1.1.4)
+    logging (2.2.2)
+      little-plugger (~> 1.1)
+      multi_json (~> 1.10)
+    mini_portile2 (2.3.0)
+    mixlib-install (3.10.0)
       mixlib-shellout
       mixlib-versioning
       thor
-    mixlib-shellout (2.2.7)
-    mixlib-versioning (1.1.0)
-    multi_json (1.12.1)
+    mixlib-shellout (2.3.2)
+    mixlib-versioning (1.2.2)
+    multi_json (1.13.1)
     net-scp (1.2.1)
       net-ssh (>= 2.6.5)
-    net-ssh (3.2.0)
-    net-ssh-gateway (1.2.0)
+    net-ssh (4.2.0)
+      openssl
+    net-ssh-gateway (1.3.0)
       net-ssh (>= 2.6.5)
     net-telnet (0.1.1)
-    nokogiri (1.6.8.1)
-    parser (2.3.1.4)
-      ast (~> 2.2)
+    nokogiri (1.8.2)
+      mini_portile2 (~> 2.3.0)
+    nori (2.6.0)
+    openssl (2.1.0)
+    parallel (1.12.1)
+    parser (2.5.1.0)
+      ast (~> 2.4.0)
     polyglot (0.3.5)
     powerpack (0.1.1)
-    rainbow (2.1.0)
-    rake (11.3.0)
-    rspec (3.5.0)
-      rspec-core (~> 3.5.0)
-      rspec-expectations (~> 3.5.0)
-      rspec-mocks (~> 3.5.0)
-    rspec-core (3.5.4)
-      rspec-support (~> 3.5.0)
-    rspec-expectations (3.5.0)
+    rainbow (3.0.0)
+    rake (12.3.1)
+    rspec (3.7.0)
+      rspec-core (~> 3.7.0)
+      rspec-expectations (~> 3.7.0)
+      rspec-mocks (~> 3.7.0)
+    rspec-core (3.7.1)
+      rspec-support (~> 3.7.0)
+    rspec-expectations (3.7.0)
       diff-lcs (>= 1.2.0, < 2.0)
-      rspec-support (~> 3.5.0)
+      rspec-support (~> 3.7.0)
     rspec-its (1.2.0)
       rspec-core (>= 3.0.0)
       rspec-expectations (>= 3.0.0)
-    rspec-mocks (3.5.0)
+    rspec-mocks (3.7.0)
       diff-lcs (>= 1.2.0, < 2.0)
-      rspec-support (~> 3.5.0)
-    rspec-support (3.5.0)
-    rubocop (0.44.1)
-      parser (>= 2.3.1.1, < 3.0)
+      rspec-support (~> 3.7.0)
+    rspec-support (3.7.1)
+    rubocop (0.56.0)
+      parallel (~> 1.10)
+      parser (>= 2.5)
       powerpack (~> 0.1)
-      rainbow (>= 1.99.1, < 3.0)
+      rainbow (>= 2.2.2, < 4.0)
       ruby-progressbar (~> 1.7)
       unicode-display_width (~> 1.0, >= 1.0.1)
-    ruby-progressbar (1.8.1)
+    ruby-progressbar (1.9.0)
+    rubyntlm (0.6.2)
+    rubyzip (1.2.1)
     rufus-lru (1.1.0)
-    safe_yaml (1.0.4)
-    serverspec (2.37.2)
+    serverspec (2.41.3)
       multi_json
       rspec (~> 3.0)
       rspec-its
-      specinfra (~> 2.53)
+      specinfra (~> 2.72)
     sfl (2.3)
-    specinfra (2.63.3)
+    specinfra (2.73.3)
       net-scp
-      net-ssh (>= 2.7, < 4.0)
+      net-ssh (>= 2.7, < 5.0)
       net-telnet
       sfl
-    test-kitchen (1.13.2)
-      mixlib-install (>= 1.2, < 3.0)
+    test-kitchen (1.21.2)
+      mixlib-install (~> 3.6)
       mixlib-shellout (>= 1.2, < 3.0)
       net-scp (~> 1.1)
-      net-ssh (>= 2.9, < 4.0)
-      net-ssh-gateway (~> 1.2.0)
-      safe_yaml (~> 1.0)
-      thor (~> 0.18)
-    thor (0.19.1)
-    treetop (1.6.8)
+      net-ssh (>= 2.9, < 5.0)
+      net-ssh-gateway (~> 1.2)
+      thor (~> 0.19)
+      winrm (~> 2.0)
+      winrm-elevated (~> 1.0)
+      winrm-fs (~> 1.1)
+    thor (0.20.0)
+    treetop (1.6.10)
       polyglot (~> 0.3)
-    unicode-display_width (1.1.1)
-    yajl-ruby (1.2.1)
+    unicode-display_width (1.3.2)
+    winrm (2.2.3)
+      builder (>= 2.1.2)
+      erubis (~> 2.7)
+      gssapi (~> 1.2)
+      gyoku (~> 1.0)
+      httpclient (~> 2.2, >= 2.2.0.2)
+      logging (>= 1.6.1, < 3.0)
+      nori (~> 2.0)
+      rubyntlm (~> 0.6.0, >= 0.6.1)
+    winrm-elevated (1.1.0)
+      winrm (~> 2.0)
+      winrm-fs (~> 1.0)
+    winrm-fs (1.2.0)
+      erubis (~> 2.7)
+      logging (>= 1.6.1, < 3.0)
+      rubyzip (~> 1.1)
+      winrm (~> 2.0)
 
 PLATFORMS
   ruby
@@ -102,4 +142,4 @@ DEPENDENCIES
   test-kitchen
 
 BUNDLED WITH
-   1.11.2
+   1.16.2