Fix rubocop warnings
[chef.git] / cookbooks / mediawiki / recipes / default.rb
index 61c76172519c69867d6461e1d788edac72a317ee..9b97eacaca428a7dd402d47de71becf0500e00bf 100644 (file)
@@ -21,7 +21,6 @@ include_recipe "memcached"
 include_recipe "apache::ssl"
 include_recipe "mysql"
 include_recipe "git"
-include_recipe "elasticsearch"
 
 # Mediawiki Base Requirements
 package "php5"
@@ -45,6 +44,24 @@ package "poppler-utils"
 
 # Mediawiki backup
 package "xz-utils"
+package "liblz4-tool"
+
+# Mediawiki packages for VisualEditor support
+package "curl"
+package "parsoid"
+
+template "/etc/mediawiki/parsoid/settings.js" do
+  source "parsoid-settings.js.erb"
+  owner "root"
+  group "root"
+  mode 0o644
+end
+
+service "parsoid" do
+  action [:enable]
+  supports :status => false, :restart => true, :reload => false
+  subscribes :restart, "template[/etc/mediawiki/parsoid/settings.js]"
+end
 
 link "/etc/php5/apache2/conf.d/20-wikidiff2.ini" do
   to "../../mods-available/wikidiff2.ini"