Explicitly load letsencrypt intermediate on 14.04 machines
[chef.git] / cookbooks / ssl / recipes / default.rb
index f5239e6..1635ed2 100644 (file)
 #
 
 keys = data_bag_item("ssl", "keys")
+certs = data_bag_item("ssl", "certs")
 
 package "openssl"
 package "ssl-cert"
 
-%w(rapidssl startcom).each do |certificate|
+%w(letsencrypt rapidssl startcom dhparam).each do |certificate|
   cookbook_file "/etc/ssl/certs/#{certificate}.pem" do
     owner "root"
     group "root"
-    mode 0444
+    mode 0o444
     backup false
   end
 end
 
 ["openstreetmap", "tile.openstreetmap", "osmfoundation"].each do |certificate|
   if node[:ssl][:certificates].include?(certificate)
-    cookbook_file "/etc/ssl/certs/#{certificate}.pem" do
+    file "/etc/ssl/certs/#{certificate}.pem" do
       owner "root"
       group "root"
-      mode 0444
+      mode 0o444
+      content certs[certificate].join("\n")
       backup false
     end
 
     file "/etc/ssl/private/#{certificate}.key" do
       owner "root"
       group "ssl-cert"
-      mode 0440
+      mode 0o440
       content keys[certificate].join("\n")
       backup false
     end