Remove no longer needed support for old Ubuntu versions
[chef.git] / cookbooks / munin / recipes / default.rb
index 39085f0e2f8efc32a400440a05457fad4662ef7f..9a6b6e696cff818797c4a17309ec0db5f1f4255e 100644 (file)
 package "munin-node"
 
 service "munin-node" do
 package "munin-node"
 
 service "munin-node" do
-  if node[:lsb][:release].to_f >= 15.10
-    provider Chef::Provider::Service::Systemd
-  elsif node[:lsb][:release].to_f >= 14.04
-    provider Chef::Provider::Service::Upstart
-  end
   action [:enable, :start]
   supports :status => true, :restart => true, :reload => true
 end
   action [:enable, :start]
   supports :status => true, :restart => true, :reload => true
 end
@@ -212,7 +207,6 @@ if Dir.glob("/dev/ipmi*").empty?
 
   munin_plugin "ipmi_power" do
     action :delete
 
   munin_plugin "ipmi_power" do
     action :delete
-    only_if { node[:lsb][:release].to_f >= 14.04 }
   end
 else
   munin_plugin_conf "ipmi" do
   end
 else
   munin_plugin_conf "ipmi" do
@@ -229,7 +223,6 @@ else
 
   munin_plugin "ipmi_power" do
     target "ipmi_"
 
   munin_plugin "ipmi_power" do
     target "ipmi_"
-    only_if { node[:lsb][:release].to_f >= 14.04 }
   end
 end
 
   end
 end