Make sure tile cookbook only requests the required postgres version
[chef.git] / roles / pyrene.rb
index e9d7f02dae4c819307ae9e542c98ca5175a07687..2100846919e4f3b71ec0974d9acc5e8608a75817 100644 (file)
@@ -2,9 +2,6 @@ name "pyrene"
 description "Master role applied to pyrene"
 
 default_attributes(
-  :apt => {
-    :sources => ["postgresql"]
-  },
   :munin => {
     :plugins => {
       :hpasmcli2_temp => {
@@ -19,14 +16,17 @@ default_attributes(
         :interface => "eno1",
         :role => :external,
         :family => :inet,
-        :address => "140.211.15.29",
-        :prefix => "24",
-        :gateway => "140.211.15.1"
+        :address => "140.211.167.98"
+      },
+      :external_ipv6 => {
+        :interface => "eno1",
+        :role => :external,
+        :family => :inet6,
+        :address => "2605:bc80:3010:700::8cd3:a762"
       }
     }
   },
   :postgresql => {
-    :versions => ["10"],
     :settings => {
       :defaults => {
         :shared_buffers => "8GB",
@@ -49,7 +49,6 @@ default_attributes(
       :cluster => "10/main",
       :postgis => "2.4"
     },
-    :node_file => "/store/database/nodes",
     :styles => {
       :default => {
         :tile_directories => [