Make sure required ruby is installed for passenger
authorTom Hughes <tom@compton.nu>
Mon, 10 Feb 2014 18:49:01 +0000 (18:49 +0000)
committerTom Hughes <tom@compton.nu>
Mon, 10 Feb 2014 18:49:01 +0000 (18:49 +0000)
cookbooks/passenger/recipes/default.rb

index 6656ce338544a50b91ea9f243c083a8441d6acdc..d2254337037aee90088c8784fec1ca5b3d0bad92 100644 (file)
 
 include_recipe "apache"
 
+package "ruby#{node[:passenger][:ruby_version]}"
+package "ruby#{node[:passenger][:ruby_version]}-dev"
+package "rubygems#{node[:passenger][:ruby_version]}"
+package "irb#{node[:passenger][:ruby_version]}"
+
 template "/usr/local/bin/passenger-ruby" do
   source "ruby.erb"
   owner "root"