Remove some ancient ruby 1.8 cleanup code