Add squid2 and squid3 repositories and install the correct one