Use std=c++0x for now until Ubuntu has a newer compiler