remove no-longer needed types from MapEvent
[potlatch2.git] / net / systemeD / halcyon / MapEvent.as
index 3858639..efb0852 100644 (file)
@@ -2,6 +2,7 @@ package net.systemeD.halcyon {
 
     import flash.events.Event;
 
 
     import flash.events.Event;
 
+    /** Defines map-related events. */
     public class MapEvent extends Event {
 
                public static const DOWNLOAD:String = "download";
     public class MapEvent extends Event {
 
                public static const DOWNLOAD:String = "download";
@@ -9,8 +10,9 @@ package net.systemeD.halcyon {
                public static const MOVE:String = "move";
                public static const SCALE:String = "scale";
                public static const NUDGE_BACKGROUND:String = "nudge_background";
                public static const MOVE:String = "move";
                public static const SCALE:String = "scale";
                public static const NUDGE_BACKGROUND:String = "nudge_background";
-               public static const ERROR:String = "error";
         public static const INITIALISED:String = "initialized";
         public static const INITIALISED:String = "initialized";
+               public static const BUMP:String = "bump";
+               public static const ERROR:String = "error";                             // ** FIXME - this should be a dedicated ErrorEvent class
 
                public var params:Object;
 
 
                public var params:Object;