Replace SuperTabNavigator (not compatible with Flex 4) with standard TabNavigator...
[potlatch2.git] / net / systemeD / halcyon / WayUI.as
index 787385f..f278972 100644 (file)
@@ -9,6 +9,7 @@ package net.systemeD.halcyon {
        
        import net.systemeD.halcyon.connection.*;
        import net.systemeD.halcyon.styleparser.*;
+    import net.systemeD.halcyon.ImageBank;
 
        /** The graphical representation of a Way. */ 
        public class WayUI extends EntityUI {
@@ -293,8 +294,11 @@ package net.systemeD.halcyon {
                                        if ((!isNaN(s.fill_color) || s.fill_image) && entity.findParentRelationsOfType('multipolygon','inner').length==0 && isNaN(drawExcept)) {
                                                fill=new Shape(); addToLayer(fill,FILLSPRITE,s.sublayer);
                                                fill.graphics.moveTo(x0,y0);
-                                               if (s.fill_image) { new WayBitmapFiller(this,fill.graphics,s); }
-                                                                        else { s.applyFill(fill.graphics); }
+                                               if (s.fill_image) {
+                                                       fill.graphics.beginBitmapFill(ImageBank.getInstance().getAsBitmapData(s.fill_image));
+                                               } else {
+                                                       s.applyFill(fill.graphics);
+                                               }
                                                solidLines(fill.graphics,inners);
                                                fill.graphics.endFill();
                                                drawn=true;