don't cry for me, buggy over-verbose YAML library