Another Flex 4.6 compatibility issue