Update to rails 5.2.2.1
[rails.git] / Gemfile.lock
1 GEM
2   remote: https://rubygems.org/
3   specs:
4     SystemTimer (1.2.3)
5     aasm (5.0.2)
6       concurrent-ruby (~> 1.0)
7     actioncable (5.2.2.1)
8       actionpack (= 5.2.2.1)
9       nio4r (~> 2.0)
10       websocket-driver (>= 0.6.1)
11     actionmailer (5.2.2.1)
12       actionpack (= 5.2.2.1)
13       actionview (= 5.2.2.1)
14       activejob (= 5.2.2.1)
15       mail (~> 2.5, >= 2.5.4)
16       rails-dom-testing (~> 2.0)
17     actionpack (5.2.2.1)
18       actionview (= 5.2.2.1)
19       activesupport (= 5.2.2.1)
20       rack (~> 2.0)
21       rack-test (>= 0.6.3)
22       rails-dom-testing (~> 2.0)
23       rails-html-sanitizer (~> 1.0, >= 1.0.2)
24     actionpack-page_caching (1.1.1)
25       actionpack (>= 4.0.0, < 6)
26     actionview (5.2.2.1)
27       activesupport (= 5.2.2.1)
28       builder (~> 3.1)
29       erubi (~> 1.4)
30       rails-dom-testing (~> 2.0)
31       rails-html-sanitizer (~> 1.0, >= 1.0.3)
32     active_record_union (1.3.0)
33       activerecord (>= 4.0)
34     activejob (5.2.2.1)
35       activesupport (= 5.2.2.1)
36       globalid (>= 0.3.6)
37     activemodel (5.2.2.1)
38       activesupport (= 5.2.2.1)
39     activerecord (5.2.2.1)
40       activemodel (= 5.2.2.1)
41       activesupport (= 5.2.2.1)
42       arel (>= 9.0)
43     activestorage (5.2.2.1)
44       actionpack (= 5.2.2.1)
45       activerecord (= 5.2.2.1)
46       marcel (~> 0.3.1)
47     activesupport (5.2.2.1)
48       concurrent-ruby (~> 1.0, >= 1.0.2)
49       i18n (>= 0.7, < 2)
50       minitest (~> 5.1)
51       tzinfo (~> 1.1)
52     addressable (2.6.0)
53       public_suffix (>= 2.0.2, < 4.0)
54     annotate (2.7.4)
55       activerecord (>= 3.2, < 6.0)
56       rake (>= 10.4, < 13.0)
57     arel (9.0.0)
58     ast (2.4.0)
59     autoprefixer-rails (8.6.5)
60       execjs
61     better_errors (2.5.1)
62       coderay (>= 1.0.0)
63       erubi (>= 1.0.0)
64       rack (>= 0.9.0)
65     bigdecimal (1.1.0)
66     binding_of_caller (0.8.0)
67       debug_inspector (>= 0.0.1)
68     bootsnap (1.4.1)
69       msgpack (~> 1.0)
70     browser (2.5.3)
71     builder (3.2.3)
72     cancancan (2.3.0)
73     canonical-rails (0.2.5)
74       rails (>= 4.1, < 6.1)
75     capybara (2.18.0)
76       addressable
77       mini_mime (>= 0.1.3)
78       nokogiri (>= 1.3.3)
79       rack (>= 1.0.0)
80       rack-test (>= 0.5.4)
81       xpath (>= 2.0, < 4.0)
82     climate_control (0.2.0)
83     cliver (0.3.2)
84     coderay (1.1.2)
85     coffee-rails (4.2.2)
86       coffee-script (>= 2.2.0)
87       railties (>= 4.0.0)
88     coffee-script (2.4.1)
89       coffee-script-source
90       execjs
91     coffee-script-source (1.12.2)
92     composite_primary_keys (11.1.0)
93       activerecord (~> 5.2.1)
94     concurrent-ruby (1.1.5)
95     coveralls (0.8.22)
96       json (>= 1.8, < 3)
97       simplecov (~> 0.16.1)
98       term-ansicolor (~> 1.3)
99       thor (~> 0.19.4)
100       tins (~> 1.6)
101     crack (0.4.3)
102       safe_yaml (~> 1.0.0)
103     crass (1.0.4)
104     dalli (2.7.9)
105     debug_inspector (0.0.3)
106     delayed_job (4.1.5)
107       activesupport (>= 3.0, < 5.3)
108     delayed_job_active_record (4.1.3)
109       activerecord (>= 3.0, < 5.3)
110       delayed_job (>= 3.0, < 5)
111     docile (1.3.1)
112     dynamic_form (1.1.4)
113     erubi (1.8.0)
114     execjs (2.7.0)
115     exifr (1.3.6)
116     factory_bot (5.0.2)
117       activesupport (>= 4.2.0)
118     factory_bot_rails (5.0.1)
119       factory_bot (~> 5.0.0)
120       railties (>= 4.2.0)
121     fakefs (0.20.0)
122     faraday (0.15.4)
123       multipart-post (>= 1.2, < 3)
124     ffi (1.10.0)
125     fspath (3.1.0)
126     gd2-ffij (0.3.0)
127       ffi (>= 1.0.0)
128     geoip (1.6.4)
129     globalid (0.4.2)
130       activesupport (>= 4.2.0)
131     hashdiff (0.3.8)
132     hashie (3.6.0)
133     htmlentities (4.3.4)
134     http_accept_language (2.0.5)
135     i18n (0.9.5)
136       concurrent-ruby (~> 1.0)
137     i18n-js (3.2.1)
138       i18n (>= 0.6.6)
139     image_optim (0.26.3)
140       exifr (~> 1.2, >= 1.2.2)
141       fspath (~> 3.0)
142       image_size (>= 1.5, < 3)
143       in_threads (~> 1.3)
144       progress (~> 3.0, >= 3.0.1)
145     image_optim_rails (0.4.1)
146       image_optim (~> 0.24)
147       rails
148       sprockets
149     image_size (2.0.0)
150     in_threads (1.5.1)
151     jaro_winkler (1.5.2)
152     jquery-rails (4.3.3)
153       rails-dom-testing (>= 1, < 3)
154       railties (>= 4.2.0)
155       thor (>= 0.14, < 2.0)
156     jshint (1.5.0)
157       execjs (>= 1.4.0)
158       multi_json (~> 1.0)
159       therubyracer (~> 0.12.1)
160     json (2.2.0)
161     jsonify (0.3.1)
162       multi_json (~> 1.0)
163     jsonify-rails (0.3.2)
164       actionpack
165       jsonify (< 0.4.0)
166     jwt (2.1.0)
167     kgio (2.11.2)
168     kramdown (2.1.0)
169     libv8 (3.16.14.19)
170     libxml-ruby (3.1.0)
171     listen (3.1.5)
172       rb-inotify (~> 0.9, >= 0.9.7)
173     logstash-event (1.2.02)
174     logstasher (1.3.0)
175       activesupport (>= 4.0)
176       logstash-event (~> 1.2.0)
177       request_store
178     loofah (2.2.3)
179       crass (~> 1.0.2)
180       nokogiri (>= 1.5.9)
181     mail (2.7.1)
182       mini_mime (>= 0.1.1)
183     marcel (0.3.3)
184       mimemagic (~> 0.3.2)
185     method_source (0.9.2)
186     mime-types (3.2.2)
187       mime-types-data (~> 3.2015)
188     mime-types-data (3.2018.0812)
189     mimemagic (0.3.3)
190     mini_mime (1.0.1)
191     minitest (5.11.3)
192     msgpack (1.2.9)
193     multi_json (1.13.1)
194     multi_xml (0.6.0)
195     multipart-post (2.0.0)
196     nio4r (2.3.1)
197     nokogiri (1.10.1)
198     nokogumbo (2.0.1)
199       nokogiri (~> 1.8, >= 1.8.4)
200     oauth (0.4.7)
201     oauth-plugin (0.5.1)
202       multi_json
203       oauth (~> 0.4.4)
204       oauth2 (>= 0.5.0)
205       rack
206     oauth2 (1.4.1)
207       faraday (>= 0.8, < 0.16.0)
208       jwt (>= 1.0, < 3.0)
209       multi_json (~> 1.3)
210       multi_xml (~> 0.5)
211       rack (>= 1.2, < 3)
212     omniauth (1.9.0)
213       hashie (>= 3.4.6, < 3.7.0)
214       rack (>= 1.6.2, < 3)
215     omniauth-facebook (5.0.0)
216       omniauth-oauth2 (~> 1.2)
217     omniauth-github (1.3.0)
218       omniauth (~> 1.5)
219       omniauth-oauth2 (>= 1.4.0, < 2.0)
220     omniauth-google-oauth2 (0.6.1)
221       jwt (>= 2.0)
222       omniauth (>= 1.1.1)
223       omniauth-oauth2 (>= 1.5)
224     omniauth-mediawiki (0.0.4)
225       jwt (~> 2.0)
226       omniauth-oauth (~> 1.0)
227     omniauth-oauth (1.1.0)
228       oauth
229       omniauth (~> 1.0)
230     omniauth-oauth2 (1.6.0)
231       oauth2 (~> 1.1)
232       omniauth (~> 1.9)
233     omniauth-openid (1.0.1)
234       omniauth (~> 1.0)
235       rack-openid (~> 1.3.1)
236     omniauth-windowslive (0.0.12)
237       multi_json (~> 1.12)
238       omniauth-oauth2 (~> 1.4)
239     openstreetmap-deadlock_retry (1.3.0)
240     paperclip (5.3.0)
241       activemodel (>= 4.2.0)
242       activesupport (>= 4.2.0)
243       mime-types
244       mimemagic (~> 0.3.0)
245       terrapin (~> 0.6.0)
246     parallel (1.14.0)
247     parser (2.6.0.0)
248       ast (~> 2.4.0)
249     pg (0.21.0)
250     poltergeist (1.18.1)
251       capybara (>= 2.1, < 4)
252       cliver (~> 0.3.1)
253       websocket-driver (>= 0.2.0)
254     powerpack (0.1.2)
255     progress (3.5.0)
256     psych (3.1.0)
257     public_suffix (3.0.3)
258     puma (3.12.0)
259     quad_tile (1.0.1)
260     r2 (0.2.7)
261     rack (2.0.6)
262     rack-cors (1.0.2)
263     rack-openid (1.3.1)
264       rack (>= 1.1.0)
265       ruby-openid (>= 2.1.8)
266     rack-test (1.1.0)
267       rack (>= 1.0, < 3)
268     rack-uri_sanitizer (0.0.2)
269     rails (5.2.2.1)
270       actioncable (= 5.2.2.1)
271       actionmailer (= 5.2.2.1)
272       actionpack (= 5.2.2.1)
273       actionview (= 5.2.2.1)
274       activejob (= 5.2.2.1)
275       activemodel (= 5.2.2.1)
276       activerecord (= 5.2.2.1)
277       activestorage (= 5.2.2.1)
278       activesupport (= 5.2.2.1)
279       bundler (>= 1.3.0)
280       railties (= 5.2.2.1)
281       sprockets-rails (>= 2.0.0)
282     rails-controller-testing (1.0.4)
283       actionpack (>= 5.0.1.x)
284       actionview (>= 5.0.1.x)
285       activesupport (>= 5.0.1.x)
286     rails-dom-testing (2.0.3)
287       activesupport (>= 4.2.0)
288       nokogiri (>= 1.6)
289     rails-html-sanitizer (1.0.4)
290       loofah (~> 2.2, >= 2.2.2)
291     rails-i18n (4.0.2)
292       i18n (~> 0.6)
293       rails (>= 4.0)
294     railties (5.2.2.1)
295       actionpack (= 5.2.2.1)
296       activesupport (= 5.2.2.1)
297       method_source
298       rake (>= 0.8.7)
299       thor (>= 0.19.0, < 2.0)
300     rainbow (3.0.0)
301     rake (12.3.2)
302     rb-inotify (0.10.0)
303       ffi (~> 1.0)
304     record_tag_helper (1.0.0)
305       actionview (~> 5.x)
306     ref (2.0.0)
307     request_store (1.4.1)
308       rack (>= 1.4)
309     rinku (2.0.4)
310     rotp (4.1.0)
311       addressable (~> 2.5)
312     rubocop (0.65.0)
313       jaro_winkler (~> 1.5.1)
314       parallel (~> 1.10)
315       parser (>= 2.5, != 2.5.1.1)
316       powerpack (~> 0.1)
317       psych (>= 3.1.0)
318       rainbow (>= 2.2.2, < 4.0)
319       ruby-progressbar (~> 1.7)
320       unicode-display_width (~> 1.4.0)
321     ruby-openid (2.7.0)
322     ruby-progressbar (1.10.0)
323     safe_yaml (1.0.5)
324     sanitize (5.0.0)
325       crass (~> 1.0.2)
326       nokogiri (>= 1.8.0)
327       nokogumbo (~> 2.0)
328     sassc (2.0.1)
329       ffi (~> 1.9)
330       rake
331     sassc-rails (2.1.0)
332       railties (>= 4.0.0)
333       sassc (>= 2.0)
334       sprockets (> 3.0)
335       sprockets-rails
336       tilt
337     secure_headers (6.1.0)
338     simplecov (0.16.1)
339       docile (~> 1.1)
340       json (>= 1.8, < 3)
341       simplecov-html (~> 0.10.0)
342     simplecov-html (0.10.2)
343     sprockets (3.7.2)
344       concurrent-ruby (~> 1.0)
345       rack (> 1, < 3)
346     sprockets-rails (3.2.1)
347       actionpack (>= 4.0)
348       activesupport (>= 4.0)
349       sprockets (>= 3.0.0)
350     term-ansicolor (1.7.1)
351       tins (~> 1.0)
352     terrapin (0.6.0)
353       climate_control (>= 0.0.3, < 1.0)
354     therubyracer (0.12.3)
355       libv8 (~> 3.16.14.15)
356       ref
357     thor (0.19.4)
358     thread_safe (0.3.6)
359     tilt (2.0.9)
360     tins (1.20.2)
361     tzinfo (1.2.5)
362       thread_safe (~> 0.1)
363     uglifier (4.1.20)
364       execjs (>= 0.3.0, < 3)
365     unicode-display_width (1.4.1)
366     validates_email_format_of (1.6.3)
367       i18n
368     vendorer (0.2.0)
369     webmock (3.5.1)
370       addressable (>= 2.3.6)
371       crack (>= 0.3.2)
372       hashdiff
373     websocket-driver (0.7.0)
374       websocket-extensions (>= 0.1.0)
375     websocket-extensions (0.1.3)
376     xpath (3.2.0)
377       nokogiri (~> 1.8)
378
379 PLATFORMS
380   ruby
381
382 DEPENDENCIES
383   SystemTimer (>= 1.1.3)
384   aasm
385   actionpack-page_caching
386   active_record_union
387   annotate
388   autoprefixer-rails (~> 8.6.3)
389   better_errors
390   bigdecimal (~> 1.1.0)
391   binding_of_caller
392   bootsnap (>= 1.1.0)
393   browser
394   cancancan
395   canonical-rails
396   capybara (~> 2.13)
397   coffee-rails (~> 4.2)
398   composite_primary_keys (~> 11.1.0)
399   coveralls
400   dalli
401   delayed_job_active_record
402   dynamic_form
403   factory_bot_rails
404   fakefs
405   faraday
406   gd2-ffij
407   geoip
408   htmlentities
409   http_accept_language (~> 2.0.0)
410   i18n-js (>= 3.0.0)
411   image_optim_rails
412   jquery-rails
413   jshint
414   json
415   jsonify-rails
416   kgio
417   kramdown
418   libxml-ruby (>= 2.0.5)
419   listen
420   logstasher
421   minitest (~> 5.1)
422   oauth-plugin (>= 0.5.1)
423   omniauth
424   omniauth-facebook
425   omniauth-github
426   omniauth-google-oauth2 (>= 0.6.0)
427   omniauth-mediawiki (>= 0.0.4)
428   omniauth-openid
429   omniauth-windowslive
430   openstreetmap-deadlock_retry (>= 1.3.0)
431   paperclip (~> 5.2)
432   pg (~> 0.18)
433   poltergeist
434   psych
435   puma (~> 3.7)
436   quad_tile (~> 1.0.1)
437   r2 (~> 0.2.7)
438   rack-cors
439   rack-uri_sanitizer
440   rails (= 5.2.2.1)
441   rails-controller-testing
442   rails-i18n (~> 4.0.0)
443   record_tag_helper
444   rinku (= 2.0.4)
445   rotp
446   rubocop
447   sanitize
448   sassc-rails
449   secure_headers
450   uglifier (>= 1.3.0)
451   validates_email_format_of (>= 1.5.1)
452   vendorer
453   webmock
454
455 BUNDLED WITH
456    1.16.2