Use activerecord-import for bulk importing tracepoint records
[rails.git] / Gemfile.lock
1 GEM
2   remote: https://rubygems.org/
3   specs:
4     SystemTimer (1.2.3)
5     aasm (5.0.2)
6       concurrent-ruby (~> 1.0)
7     actioncable (5.2.2.1)
8       actionpack (= 5.2.2.1)
9       nio4r (~> 2.0)
10       websocket-driver (>= 0.6.1)
11     actionmailer (5.2.2.1)
12       actionpack (= 5.2.2.1)
13       actionview (= 5.2.2.1)
14       activejob (= 5.2.2.1)
15       mail (~> 2.5, >= 2.5.4)
16       rails-dom-testing (~> 2.0)
17     actionpack (5.2.2.1)
18       actionview (= 5.2.2.1)
19       activesupport (= 5.2.2.1)
20       rack (~> 2.0)
21       rack-test (>= 0.6.3)
22       rails-dom-testing (~> 2.0)
23       rails-html-sanitizer (~> 1.0, >= 1.0.2)
24     actionpack-page_caching (1.1.1)
25       actionpack (>= 4.0.0, < 6)
26     actionview (5.2.2.1)
27       activesupport (= 5.2.2.1)
28       builder (~> 3.1)
29       erubi (~> 1.4)
30       rails-dom-testing (~> 2.0)
31       rails-html-sanitizer (~> 1.0, >= 1.0.3)
32     active_record_union (1.3.0)
33       activerecord (>= 4.0)
34     activejob (5.2.2.1)
35       activesupport (= 5.2.2.1)
36       globalid (>= 0.3.6)
37     activemodel (5.2.2.1)
38       activesupport (= 5.2.2.1)
39     activerecord (5.2.2.1)
40       activemodel (= 5.2.2.1)
41       activesupport (= 5.2.2.1)
42       arel (>= 9.0)
43     activerecord-import (0.28.1)
44       activerecord (>= 3.2)
45     activestorage (5.2.2.1)
46       actionpack (= 5.2.2.1)
47       activerecord (= 5.2.2.1)
48       marcel (~> 0.3.1)
49     activesupport (5.2.2.1)
50       concurrent-ruby (~> 1.0, >= 1.0.2)
51       i18n (>= 0.7, < 2)
52       minitest (~> 5.1)
53       tzinfo (~> 1.1)
54     addressable (2.6.0)
55       public_suffix (>= 2.0.2, < 4.0)
56     annotate (2.7.4)
57       activerecord (>= 3.2, < 6.0)
58       rake (>= 10.4, < 13.0)
59     arel (9.0.0)
60     ast (2.4.0)
61     autoprefixer-rails (8.6.5)
62       execjs
63     better_errors (2.5.1)
64       coderay (>= 1.0.0)
65       erubi (>= 1.0.0)
66       rack (>= 0.9.0)
67     bigdecimal (1.1.0)
68     binding_of_caller (0.8.0)
69       debug_inspector (>= 0.0.1)
70     bootsnap (1.4.1)
71       msgpack (~> 1.0)
72     browser (2.5.3)
73     builder (3.2.3)
74     cancancan (2.3.0)
75     canonical-rails (0.2.5)
76       rails (>= 4.1, < 6.1)
77     capybara (2.18.0)
78       addressable
79       mini_mime (>= 0.1.3)
80       nokogiri (>= 1.3.3)
81       rack (>= 1.0.0)
82       rack-test (>= 0.5.4)
83       xpath (>= 2.0, < 4.0)
84     climate_control (0.2.0)
85     cliver (0.3.2)
86     coderay (1.1.2)
87     coffee-rails (4.2.2)
88       coffee-script (>= 2.2.0)
89       railties (>= 4.0.0)
90     coffee-script (2.4.1)
91       coffee-script-source
92       execjs
93     coffee-script-source (1.12.2)
94     composite_primary_keys (11.1.0)
95       activerecord (~> 5.2.1)
96     concurrent-ruby (1.1.5)
97     config (1.7.1)
98       activesupport (>= 3.0)
99       deep_merge (~> 1.2.1)
100       dry-validation (>= 0.12.2)
101     coveralls (0.8.22)
102       json (>= 1.8, < 3)
103       simplecov (~> 0.16.1)
104       term-ansicolor (~> 1.3)
105       thor (~> 0.19.4)
106       tins (~> 1.6)
107     crack (0.4.3)
108       safe_yaml (~> 1.0.0)
109     crass (1.0.4)
110     dalli (2.7.9)
111     debug_inspector (0.0.3)
112     deep_merge (1.2.1)
113     delayed_job (4.1.5)
114       activesupport (>= 3.0, < 5.3)
115     delayed_job_active_record (4.1.3)
116       activerecord (>= 3.0, < 5.3)
117       delayed_job (>= 3.0, < 5)
118     docile (1.3.1)
119     dry-configurable (0.8.2)
120       concurrent-ruby (~> 1.0)
121       dry-core (~> 0.4, >= 0.4.7)
122     dry-container (0.7.0)
123       concurrent-ruby (~> 1.0)
124       dry-configurable (~> 0.1, >= 0.1.3)
125     dry-core (0.4.7)
126       concurrent-ruby (~> 1.0)
127     dry-equalizer (0.2.2)
128     dry-inflector (0.1.2)
129     dry-logic (0.5.0)
130       dry-container (~> 0.2, >= 0.2.6)
131       dry-core (~> 0.2)
132       dry-equalizer (~> 0.2)
133     dry-types (0.14.0)
134       concurrent-ruby (~> 1.0)
135       dry-container (~> 0.3)
136       dry-core (~> 0.4, >= 0.4.4)
137       dry-equalizer (~> 0.2)
138       dry-inflector (~> 0.1, >= 0.1.2)
139       dry-logic (~> 0.5, >= 0.5)
140     dry-validation (0.13.0)
141       concurrent-ruby (~> 1.0)
142       dry-configurable (~> 0.1, >= 0.1.3)
143       dry-core (~> 0.2, >= 0.2.1)
144       dry-equalizer (~> 0.2)
145       dry-logic (~> 0.5, >= 0.5.0)
146       dry-types (~> 0.14, >= 0.14)
147     dynamic_form (1.1.4)
148     erubi (1.8.0)
149     execjs (2.7.0)
150     exifr (1.3.6)
151     factory_bot (5.0.2)
152       activesupport (>= 4.2.0)
153     factory_bot_rails (5.0.1)
154       factory_bot (~> 5.0.0)
155       railties (>= 4.2.0)
156     fakefs (0.20.0)
157     faraday (0.15.4)
158       multipart-post (>= 1.2, < 3)
159     ffi (1.10.0)
160     fspath (3.1.0)
161     gd2-ffij (0.3.0)
162       ffi (>= 1.0.0)
163     geoip (1.6.4)
164     globalid (0.4.2)
165       activesupport (>= 4.2.0)
166     hashdiff (0.3.8)
167     hashie (3.6.0)
168     htmlentities (4.3.4)
169     http_accept_language (2.0.5)
170     i18n (0.9.5)
171       concurrent-ruby (~> 1.0)
172     i18n-js (3.2.1)
173       i18n (>= 0.6.6)
174     image_optim (0.26.3)
175       exifr (~> 1.2, >= 1.2.2)
176       fspath (~> 3.0)
177       image_size (>= 1.5, < 3)
178       in_threads (~> 1.3)
179       progress (~> 3.0, >= 3.0.1)
180     image_optim_rails (0.4.1)
181       image_optim (~> 0.24)
182       rails
183       sprockets
184     image_size (2.0.0)
185     in_threads (1.5.1)
186     jaro_winkler (1.5.2)
187     jquery-rails (4.3.3)
188       rails-dom-testing (>= 1, < 3)
189       railties (>= 4.2.0)
190       thor (>= 0.14, < 2.0)
191     jshint (1.5.0)
192       execjs (>= 1.4.0)
193       multi_json (~> 1.0)
194       therubyracer (~> 0.12.1)
195     json (2.2.0)
196     jsonify (0.3.1)
197       multi_json (~> 1.0)
198     jsonify-rails (0.3.2)
199       actionpack
200       jsonify (< 0.4.0)
201     jwt (2.1.0)
202     kgio (2.11.2)
203     kramdown (2.1.0)
204     libv8 (3.16.14.19)
205     libxml-ruby (3.1.0)
206     listen (3.1.5)
207       rb-fsevent (~> 0.9, >= 0.9.4)
208       rb-inotify (~> 0.9, >= 0.9.7)
209       ruby_dep (~> 1.2)
210     logstash-event (1.2.02)
211     logstasher (1.3.0)
212       activesupport (>= 4.0)
213       logstash-event (~> 1.2.0)
214       request_store
215     loofah (2.2.3)
216       crass (~> 1.0.2)
217       nokogiri (>= 1.5.9)
218     mail (2.7.1)
219       mini_mime (>= 0.1.1)
220     marcel (0.3.3)
221       mimemagic (~> 0.3.2)
222     method_source (0.9.2)
223     mime-types (3.2.2)
224       mime-types-data (~> 3.2015)
225     mime-types-data (3.2018.0812)
226     mimemagic (0.3.3)
227     mini_mime (1.0.1)
228     mini_portile2 (2.4.0)
229     minitest (5.11.3)
230     msgpack (1.2.9)
231     multi_json (1.13.1)
232     multi_xml (0.6.0)
233     multipart-post (2.0.0)
234     nio4r (2.3.1)
235     nokogiri (1.10.1)
236       mini_portile2 (~> 2.4.0)
237     nokogumbo (2.0.1)
238       nokogiri (~> 1.8, >= 1.8.4)
239     oauth (0.4.7)
240     oauth-plugin (0.5.1)
241       multi_json
242       oauth (~> 0.4.4)
243       oauth2 (>= 0.5.0)
244       rack
245     oauth2 (1.4.1)
246       faraday (>= 0.8, < 0.16.0)
247       jwt (>= 1.0, < 3.0)
248       multi_json (~> 1.3)
249       multi_xml (~> 0.5)
250       rack (>= 1.2, < 3)
251     omniauth (1.9.0)
252       hashie (>= 3.4.6, < 3.7.0)
253       rack (>= 1.6.2, < 3)
254     omniauth-facebook (5.0.0)
255       omniauth-oauth2 (~> 1.2)
256     omniauth-github (1.3.0)
257       omniauth (~> 1.5)
258       omniauth-oauth2 (>= 1.4.0, < 2.0)
259     omniauth-google-oauth2 (0.6.1)
260       jwt (>= 2.0)
261       omniauth (>= 1.1.1)
262       omniauth-oauth2 (>= 1.5)
263     omniauth-mediawiki (0.0.4)
264       jwt (~> 2.0)
265       omniauth-oauth (~> 1.0)
266     omniauth-oauth (1.1.0)
267       oauth
268       omniauth (~> 1.0)
269     omniauth-oauth2 (1.6.0)
270       oauth2 (~> 1.1)
271       omniauth (~> 1.9)
272     omniauth-openid (1.0.1)
273       omniauth (~> 1.0)
274       rack-openid (~> 1.3.1)
275     omniauth-windowslive (0.0.12)
276       multi_json (~> 1.12)
277       omniauth-oauth2 (~> 1.4)
278     openstreetmap-deadlock_retry (1.3.0)
279     paperclip (5.3.0)
280       activemodel (>= 4.2.0)
281       activesupport (>= 4.2.0)
282       mime-types
283       mimemagic (~> 0.3.0)
284       terrapin (~> 0.6.0)
285     parallel (1.14.0)
286     parser (2.6.0.0)
287       ast (~> 2.4.0)
288     pg (0.21.0)
289     poltergeist (1.18.1)
290       capybara (>= 2.1, < 4)
291       cliver (~> 0.3.1)
292       websocket-driver (>= 0.2.0)
293     powerpack (0.1.2)
294     progress (3.5.0)
295     psych (3.1.0)
296     public_suffix (3.0.3)
297     puma (3.12.0)
298     quad_tile (1.0.1)
299     r2 (0.2.7)
300     rack (2.0.6)
301     rack-cors (1.0.2)
302     rack-openid (1.3.1)
303       rack (>= 1.1.0)
304       ruby-openid (>= 2.1.8)
305     rack-test (1.1.0)
306       rack (>= 1.0, < 3)
307     rack-uri_sanitizer (0.0.2)
308     rails (5.2.2.1)
309       actioncable (= 5.2.2.1)
310       actionmailer (= 5.2.2.1)
311       actionpack (= 5.2.2.1)
312       actionview (= 5.2.2.1)
313       activejob (= 5.2.2.1)
314       activemodel (= 5.2.2.1)
315       activerecord (= 5.2.2.1)
316       activestorage (= 5.2.2.1)
317       activesupport (= 5.2.2.1)
318       bundler (>= 1.3.0)
319       railties (= 5.2.2.1)
320       sprockets-rails (>= 2.0.0)
321     rails-controller-testing (1.0.4)
322       actionpack (>= 5.0.1.x)
323       actionview (>= 5.0.1.x)
324       activesupport (>= 5.0.1.x)
325     rails-dom-testing (2.0.3)
326       activesupport (>= 4.2.0)
327       nokogiri (>= 1.6)
328     rails-html-sanitizer (1.0.4)
329       loofah (~> 2.2, >= 2.2.2)
330     rails-i18n (4.0.2)
331       i18n (~> 0.6)
332       rails (>= 4.0)
333     railties (5.2.2.1)
334       actionpack (= 5.2.2.1)
335       activesupport (= 5.2.2.1)
336       method_source
337       rake (>= 0.8.7)
338       thor (>= 0.19.0, < 2.0)
339     rainbow (3.0.0)
340     rake (12.3.2)
341     rb-fsevent (0.10.3)
342     rb-inotify (0.10.0)
343       ffi (~> 1.0)
344     record_tag_helper (1.0.0)
345       actionview (~> 5.x)
346     ref (2.0.0)
347     request_store (1.4.1)
348       rack (>= 1.4)
349     rinku (2.0.4)
350     rotp (4.1.0)
351       addressable (~> 2.5)
352     rubocop (0.65.0)
353       jaro_winkler (~> 1.5.1)
354       parallel (~> 1.10)
355       parser (>= 2.5, != 2.5.1.1)
356       powerpack (~> 0.1)
357       psych (>= 3.1.0)
358       rainbow (>= 2.2.2, < 4.0)
359       ruby-progressbar (~> 1.7)
360       unicode-display_width (~> 1.4.0)
361     ruby-openid (2.7.0)
362     ruby-progressbar (1.10.0)
363     ruby_dep (1.5.0)
364     safe_yaml (1.0.5)
365     sanitize (5.0.0)
366       crass (~> 1.0.2)
367       nokogiri (>= 1.8.0)
368       nokogumbo (~> 2.0)
369     sassc (2.0.1)
370       ffi (~> 1.9)
371       rake
372     sassc-rails (2.1.0)
373       railties (>= 4.0.0)
374       sassc (>= 2.0)
375       sprockets (> 3.0)
376       sprockets-rails
377       tilt
378     secure_headers (6.1.0)
379     simplecov (0.16.1)
380       docile (~> 1.1)
381       json (>= 1.8, < 3)
382       simplecov-html (~> 0.10.0)
383     simplecov-html (0.10.2)
384     sprockets (3.7.2)
385       concurrent-ruby (~> 1.0)
386       rack (> 1, < 3)
387     sprockets-rails (3.2.1)
388       actionpack (>= 4.0)
389       activesupport (>= 4.0)
390       sprockets (>= 3.0.0)
391     term-ansicolor (1.7.1)
392       tins (~> 1.0)
393     terrapin (0.6.0)
394       climate_control (>= 0.0.3, < 1.0)
395     therubyracer (0.12.3)
396       libv8 (~> 3.16.14.15)
397       ref
398     thor (0.19.4)
399     thread_safe (0.3.6)
400     tilt (2.0.9)
401     tins (1.20.2)
402     tzinfo (1.2.5)
403       thread_safe (~> 0.1)
404     uglifier (4.1.20)
405       execjs (>= 0.3.0, < 3)
406     unicode-display_width (1.4.1)
407     validates_email_format_of (1.6.3)
408       i18n
409     vendorer (0.2.0)
410     webmock (3.5.1)
411       addressable (>= 2.3.6)
412       crack (>= 0.3.2)
413       hashdiff
414     websocket-driver (0.7.0)
415       websocket-extensions (>= 0.1.0)
416     websocket-extensions (0.1.3)
417     xpath (3.2.0)
418       nokogiri (~> 1.8)
419
420 PLATFORMS
421   ruby
422
423 DEPENDENCIES
424   SystemTimer (>= 1.1.3)
425   aasm
426   actionpack-page_caching
427   active_record_union
428   activerecord-import
429   annotate
430   autoprefixer-rails (~> 8.6.3)
431   better_errors
432   bigdecimal (~> 1.1.0)
433   binding_of_caller
434   bootsnap (>= 1.1.0)
435   browser
436   cancancan
437   canonical-rails
438   capybara (~> 2.13)
439   coffee-rails (~> 4.2)
440   composite_primary_keys (~> 11.1.0)
441   config
442   coveralls
443   dalli
444   delayed_job_active_record
445   dynamic_form
446   factory_bot_rails
447   fakefs
448   faraday
449   gd2-ffij
450   geoip
451   htmlentities
452   http_accept_language (~> 2.0.0)
453   i18n-js (>= 3.0.0)
454   image_optim_rails
455   jquery-rails
456   jshint
457   json
458   jsonify-rails
459   kgio
460   kramdown
461   libxml-ruby (>= 2.0.5)
462   listen
463   logstasher
464   minitest (~> 5.1)
465   oauth-plugin (>= 0.5.1)
466   omniauth
467   omniauth-facebook
468   omniauth-github
469   omniauth-google-oauth2 (>= 0.6.0)
470   omniauth-mediawiki (>= 0.0.4)
471   omniauth-openid
472   omniauth-windowslive
473   openstreetmap-deadlock_retry (>= 1.3.0)
474   paperclip (~> 5.2)
475   pg (~> 0.18)
476   poltergeist
477   psych
478   puma (~> 3.7)
479   quad_tile (~> 1.0.1)
480   r2 (~> 0.2.7)
481   rack-cors
482   rack-uri_sanitizer
483   rails (= 5.2.2.1)
484   rails-controller-testing
485   rails-i18n (~> 4.0.0)
486   record_tag_helper
487   rinku (= 2.0.4)
488   rotp
489   rubocop
490   sanitize
491   sassc-rails
492   secure_headers
493   uglifier (>= 1.3.0)
494   validates_email_format_of (>= 1.5.1)
495   vendorer
496   webmock
497
498 BUNDLED WITH
499    1.16.2