Merge branch 'master' into moderation
[rails.git] / Gemfile.lock
1 GEM
2   remote: https://rubygems.org/
3   specs:
4     SystemTimer (1.2.3)
5     aasm (4.1.0)
6     actioncable (5.1.4)
7       actionpack (= 5.1.4)
8       nio4r (~> 2.0)
9       websocket-driver (~> 0.6.1)
10     actionmailer (5.1.4)
11       actionpack (= 5.1.4)
12       actionview (= 5.1.4)
13       activejob (= 5.1.4)
14       mail (~> 2.5, >= 2.5.4)
15       rails-dom-testing (~> 2.0)
16     actionpack (5.1.4)
17       actionview (= 5.1.4)
18       activesupport (= 5.1.4)
19       rack (~> 2.0)
20       rack-test (>= 0.6.3)
21       rails-dom-testing (~> 2.0)
22       rails-html-sanitizer (~> 1.0, >= 1.0.2)
23     actionpack-page_caching (1.1.0)
24       actionpack (>= 4.0.0, < 6)
25     actionview (5.1.4)
26       activesupport (= 5.1.4)
27       builder (~> 3.1)
28       erubi (~> 1.4)
29       rails-dom-testing (~> 2.0)
30       rails-html-sanitizer (~> 1.0, >= 1.0.3)
31     activejob (5.1.4)
32       activesupport (= 5.1.4)
33       globalid (>= 0.3.6)
34     activemodel (5.1.4)
35       activesupport (= 5.1.4)
36     activerecord (5.1.4)
37       activemodel (= 5.1.4)
38       activesupport (= 5.1.4)
39       arel (~> 8.0)
40     activesupport (5.1.4)
41       concurrent-ruby (~> 1.0, >= 1.0.2)
42       i18n (~> 0.7)
43       minitest (~> 5.1)
44       tzinfo (~> 1.1)
45     addressable (2.5.2)
46       public_suffix (>= 2.0.2, < 4.0)
47     annotate (2.7.2)
48       activerecord (>= 3.2, < 6.0)
49       rake (>= 10.4, < 13.0)
50     arel (8.0.0)
51     ast (2.4.0)
52     autoprefixer-rails (8.0.0)
53       execjs
54     bigdecimal (1.1.0)
55     builder (3.2.3)
56     canonical-rails (0.2.2)
57       rails (>= 4.1, < 5.2)
58     capybara (2.18.0)
59       addressable
60       mini_mime (>= 0.1.3)
61       nokogiri (>= 1.3.3)
62       rack (>= 1.0.0)
63       rack-test (>= 0.5.4)
64       xpath (>= 2.0, < 4.0)
65     climate_control (0.2.0)
66     cliver (0.3.2)
67     cocaine (0.5.8)
68       climate_control (>= 0.0.3, < 1.0)
69     coffee-rails (4.2.2)
70       coffee-script (>= 2.2.0)
71       railties (>= 4.0.0)
72     coffee-script (2.4.1)
73       coffee-script-source
74       execjs
75     coffee-script-source (1.12.2)
76     composite_primary_keys (10.0.2)
77       activerecord (~> 5.1.0, >= 5.1.4)
78     concurrent-ruby (1.0.5)
79     coveralls (0.8.21)
80       json (>= 1.8, < 3)
81       simplecov (~> 0.14.1)
82       term-ansicolor (~> 1.3)
83       thor (~> 0.19.4)
84       tins (~> 1.6)
85     crack (0.4.3)
86       safe_yaml (~> 1.0.0)
87     crass (1.0.3)
88     dalli (2.7.6)
89     docile (1.1.5)
90     dynamic_form (1.1.4)
91     erubi (1.7.0)
92     execjs (2.7.0)
93     exifr (1.3.3)
94     factory_bot (4.8.2)
95       activesupport (>= 3.0.0)
96     factory_bot_rails (4.8.2)
97       factory_bot (~> 4.8.2)
98       railties (>= 3.0.0)
99     faraday (0.12.2)
100       multipart-post (>= 1.2, < 3)
101     ffi (1.9.21)
102     fspath (3.1.0)
103     geoip (1.6.3)
104     globalid (0.4.1)
105       activesupport (>= 4.2.0)
106     hashdiff (0.3.7)
107     hashie (3.5.7)
108     htmlentities (4.3.4)
109     http_accept_language (2.0.5)
110     i18n (0.9.5)
111       concurrent-ruby (~> 1.0)
112     i18n-js (3.0.4)
113       i18n (~> 0.6, >= 0.6.6)
114     image_optim (0.26.1)
115       exifr (~> 1.2, >= 1.2.2)
116       fspath (~> 3.0)
117       image_size (~> 1.5)
118       in_threads (~> 1.3)
119       progress (~> 3.0, >= 3.0.1)
120     image_optim_rails (0.4.1)
121       image_optim (~> 0.24)
122       rails
123       sprockets
124     image_size (1.5.0)
125     in_threads (1.5.0)
126     jquery-rails (4.3.1)
127       rails-dom-testing (>= 1, < 3)
128       railties (>= 4.2.0)
129       thor (>= 0.14, < 2.0)
130     jshint (1.5.0)
131       execjs (>= 1.4.0)
132       multi_json (~> 1.0)
133       therubyracer (~> 0.12.1)
134     json (2.1.0)
135     jsonify (0.3.1)
136       multi_json (~> 1.0)
137     jsonify-rails (0.3.2)
138       actionpack
139       jsonify (< 0.4.0)
140     jwt (1.5.6)
141     kgio (2.11.2)
142     libv8 (3.16.14.19)
143     libxml-ruby (3.1.0)
144     listen (3.1.5)
145       rb-fsevent (~> 0.9, >= 0.9.4)
146       rb-inotify (~> 0.9, >= 0.9.7)
147       ruby_dep (~> 1.2)
148     logstash-event (1.2.02)
149     logstasher (1.2.2)
150       activesupport (>= 4.0)
151       logstash-event (~> 1.2.0)
152       request_store
153     loofah (2.2.0)
154       crass (~> 1.0.2)
155       nokogiri (>= 1.5.9)
156     mail (2.7.0)
157       mini_mime (>= 0.1.1)
158     method_source (0.9.0)
159     mime-types (3.1)
160       mime-types-data (~> 3.2015)
161     mime-types-data (3.2016.0521)
162     mimemagic (0.3.2)
163     mini_mime (1.0.0)
164     mini_portile2 (2.3.0)
165     minitest (5.11.3)
166     multi_json (1.13.1)
167     multi_xml (0.6.0)
168     multipart-post (2.0.0)
169     nio4r (2.2.0)
170     nokogiri (1.8.2)
171       mini_portile2 (~> 2.3.0)
172     nokogumbo (1.5.0)
173       nokogiri
174     oauth (0.4.7)
175     oauth-plugin (0.5.1)
176       multi_json
177       oauth (~> 0.4.4)
178       oauth2 (>= 0.5.0)
179       rack
180     oauth2 (1.4.0)
181       faraday (>= 0.8, < 0.13)
182       jwt (~> 1.0)
183       multi_json (~> 1.3)
184       multi_xml (~> 0.5)
185       rack (>= 1.2, < 3)
186     omniauth (1.8.1)
187       hashie (>= 3.4.6, < 3.6.0)
188       rack (>= 1.6.2, < 3)
189     omniauth-facebook (4.0.0)
190       omniauth-oauth2 (~> 1.2)
191     omniauth-github (1.3.0)
192       omniauth (~> 1.5)
193       omniauth-oauth2 (>= 1.4.0, < 2.0)
194     omniauth-google-oauth2 (0.5.3)
195       jwt (>= 1.5)
196       omniauth (>= 1.1.1)
197       omniauth-oauth2 (>= 1.5)
198     omniauth-mediawiki (0.0.3)
199       jwt (~> 1.0)
200       omniauth-oauth (~> 1.0)
201     omniauth-oauth (1.1.0)
202       oauth
203       omniauth (~> 1.0)
204     omniauth-oauth2 (1.5.0)
205       oauth2 (~> 1.1)
206       omniauth (~> 1.2)
207     omniauth-openid (1.0.1)
208       omniauth (~> 1.0)
209       rack-openid (~> 1.3.1)
210     omniauth-windowslive (0.0.12)
211       multi_json (~> 1.12)
212       omniauth-oauth2 (~> 1.4)
213     openstreetmap-deadlock_retry (1.3.0)
214     paperclip (5.2.1)
215       activemodel (>= 4.2.0)
216       activesupport (>= 4.2.0)
217       cocaine (~> 0.5.5)
218       mime-types
219       mimemagic (~> 0.3.0)
220     parallel (1.12.1)
221     parser (2.4.0.2)
222       ast (~> 2.3)
223     pg (0.21.0)
224     poltergeist (1.17.0)
225       capybara (~> 2.1)
226       cliver (~> 0.3.1)
227       websocket-driver (>= 0.2.0)
228     powerpack (0.1.1)
229     progress (3.4.0)
230     psych (3.0.2)
231     public_suffix (3.0.2)
232     puma (3.11.2)
233     r2 (0.2.7)
234     rack (2.0.4)
235     rack-cors (1.0.2)
236     rack-openid (1.3.1)
237       rack (>= 1.1.0)
238       ruby-openid (>= 2.1.8)
239     rack-test (0.8.2)
240       rack (>= 1.0, < 3)
241     rack-uri_sanitizer (0.0.2)
242     rails (5.1.4)
243       actioncable (= 5.1.4)
244       actionmailer (= 5.1.4)
245       actionpack (= 5.1.4)
246       actionview (= 5.1.4)
247       activejob (= 5.1.4)
248       activemodel (= 5.1.4)
249       activerecord (= 5.1.4)
250       activesupport (= 5.1.4)
251       bundler (>= 1.3.0)
252       railties (= 5.1.4)
253       sprockets-rails (>= 2.0.0)
254     rails-controller-testing (1.0.2)
255       actionpack (~> 5.x, >= 5.0.1)
256       actionview (~> 5.x, >= 5.0.1)
257       activesupport (~> 5.x)
258     rails-dom-testing (2.0.3)
259       activesupport (>= 4.2.0)
260       nokogiri (>= 1.6)
261     rails-html-sanitizer (1.0.3)
262       loofah (~> 2.0)
263     rails-i18n (4.0.2)
264       i18n (~> 0.6)
265       rails (>= 4.0)
266     railties (5.1.4)
267       actionpack (= 5.1.4)
268       activesupport (= 5.1.4)
269       method_source
270       rake (>= 0.8.7)
271       thor (>= 0.18.1, < 2.0)
272     rainbow (3.0.0)
273     rake (12.3.0)
274     rb-fsevent (0.10.2)
275     rb-inotify (0.9.10)
276       ffi (>= 0.5.0, < 2)
277     record_tag_helper (1.0.0)
278       actionview (~> 5.x)
279     redcarpet (3.4.0)
280     ref (2.0.0)
281     request_store (1.4.0)
282       rack (>= 1.4)
283     rinku (2.0.4)
284     rotp (3.3.0)
285     rubocop (0.52.1)
286       parallel (~> 1.10)
287       parser (>= 2.4.0.2, < 3.0)
288       powerpack (~> 0.1)
289       rainbow (>= 2.2.2, < 4.0)
290       ruby-progressbar (~> 1.7)
291       unicode-display_width (~> 1.0, >= 1.0.1)
292     ruby-openid (2.7.0)
293     ruby-progressbar (1.9.0)
294     ruby_dep (1.5.0)
295     safe_yaml (1.0.4)
296     sanitize (4.6.0)
297       crass (~> 1.0.2)
298       nokogiri (>= 1.4.4)
299       nokogumbo (~> 1.4)
300     sass (3.5.5)
301       sass-listen (~> 4.0.0)
302     sass-listen (4.0.0)
303       rb-fsevent (~> 0.9, >= 0.9.4)
304       rb-inotify (~> 0.9, >= 0.9.7)
305     sass-rails (5.0.7)
306       railties (>= 4.0.0, < 6)
307       sass (~> 3.1)
308       sprockets (>= 2.8, < 4.0)
309       sprockets-rails (>= 2.0, < 4.0)
310       tilt (>= 1.1, < 3)
311     secure_headers (5.0.5)
312       useragent (>= 0.15.0)
313     simplecov (0.14.1)
314       docile (~> 1.1.0)
315       json (>= 1.8, < 3)
316       simplecov-html (~> 0.10.0)
317     simplecov-html (0.10.2)
318     sprockets (3.7.1)
319       concurrent-ruby (~> 1.0)
320       rack (> 1, < 3)
321     sprockets-rails (3.2.1)
322       actionpack (>= 4.0)
323       activesupport (>= 4.0)
324       sprockets (>= 3.0.0)
325     term-ansicolor (1.6.0)
326       tins (~> 1.0)
327     therubyracer (0.12.3)
328       libv8 (~> 3.16.14.15)
329       ref
330     thor (0.19.4)
331     thread_safe (0.3.6)
332     tilt (2.0.8)
333     tins (1.16.3)
334     tzinfo (1.2.5)
335       thread_safe (~> 0.1)
336     uglifier (4.1.6)
337       execjs (>= 0.3.0, < 3)
338     unicode-display_width (1.3.0)
339     useragent (0.16.10)
340     validates_email_format_of (1.6.3)
341       i18n
342     vendorer (0.1.16)
343     webmock (3.3.0)
344       addressable (>= 2.3.6)
345       crack (>= 0.3.2)
346       hashdiff
347     websocket-driver (0.6.5)
348       websocket-extensions (>= 0.1.0)
349     websocket-extensions (0.1.3)
350     xpath (3.0.0)
351       nokogiri (~> 1.8)
352
353 PLATFORMS
354   ruby
355
356 DEPENDENCIES
357   SystemTimer (>= 1.1.3)
358   aasm
359   actionpack-page_caching
360   annotate
361   autoprefixer-rails
362   bigdecimal (~> 1.1.0)
363   canonical-rails
364   capybara (~> 2.13)
365   coffee-rails (~> 4.2)
366   composite_primary_keys (~> 10.0.0)
367   coveralls
368   dalli
369   dynamic_form
370   factory_bot_rails
371   faraday
372   geoip
373   htmlentities
374   http_accept_language (~> 2.0.0)
375   i18n-js (>= 3.0.0)
376   image_optim_rails
377   jquery-rails
378   jshint
379   json
380   jsonify-rails
381   kgio
382   libxml-ruby (>= 2.0.5)
383   listen
384   logstasher
385   minitest (~> 5.1)
386   oauth-plugin (>= 0.5.1)
387   omniauth
388   omniauth-facebook
389   omniauth-github
390   omniauth-google-oauth2 (>= 0.2.7)
391   omniauth-mediawiki (>= 0.0.3)
392   omniauth-openid
393   omniauth-windowslive
394   openstreetmap-deadlock_retry (>= 1.3.0)
395   paperclip (~> 5.2)
396   pg (~> 0.18)
397   poltergeist
398   psych
399   puma (~> 3.7)
400   r2 (~> 0.2.7)
401   rack-cors
402   rack-uri_sanitizer
403   rails (= 5.1.4)
404   rails-controller-testing
405   rails-i18n (~> 4.0.0)
406   record_tag_helper
407   redcarpet
408   rinku (>= 1.2.2)
409   rotp
410   rubocop
411   sanitize
412   sass-rails (~> 5.0)
413   secure_headers
414   uglifier (>= 1.3.0)
415   validates_email_format_of (>= 1.5.1)
416   vendorer
417   webmock
418
419 BUNDLED WITH
420    1.15.4