Update bundle
[rails.git] / Gemfile.lock
1 GEM
2   remote: https://rubygems.org/
3   specs:
4     SystemTimer (1.2.3)
5     aasm (5.0.2)
6       concurrent-ruby (~> 1.0)
7     actioncable (5.2.2.1)
8       actionpack (= 5.2.2.1)
9       nio4r (~> 2.0)
10       websocket-driver (>= 0.6.1)
11     actionmailer (5.2.2.1)
12       actionpack (= 5.2.2.1)
13       actionview (= 5.2.2.1)
14       activejob (= 5.2.2.1)
15       mail (~> 2.5, >= 2.5.4)
16       rails-dom-testing (~> 2.0)
17     actionpack (5.2.2.1)
18       actionview (= 5.2.2.1)
19       activesupport (= 5.2.2.1)
20       rack (~> 2.0)
21       rack-test (>= 0.6.3)
22       rails-dom-testing (~> 2.0)
23       rails-html-sanitizer (~> 1.0, >= 1.0.2)
24     actionpack-page_caching (1.1.1)
25       actionpack (>= 4.0.0, < 6)
26     actionview (5.2.2.1)
27       activesupport (= 5.2.2.1)
28       builder (~> 3.1)
29       erubi (~> 1.4)
30       rails-dom-testing (~> 2.0)
31       rails-html-sanitizer (~> 1.0, >= 1.0.3)
32     active_record_union (1.3.0)
33       activerecord (>= 4.0)
34     activejob (5.2.2.1)
35       activesupport (= 5.2.2.1)
36       globalid (>= 0.3.6)
37     activemodel (5.2.2.1)
38       activesupport (= 5.2.2.1)
39     activerecord (5.2.2.1)
40       activemodel (= 5.2.2.1)
41       activesupport (= 5.2.2.1)
42       arel (>= 9.0)
43     activerecord-import (1.0.1)
44       activerecord (>= 3.2)
45     activestorage (5.2.2.1)
46       actionpack (= 5.2.2.1)
47       activerecord (= 5.2.2.1)
48       marcel (~> 0.3.1)
49     activesupport (5.2.2.1)
50       concurrent-ruby (~> 1.0, >= 1.0.2)
51       i18n (>= 0.7, < 2)
52       minitest (~> 5.1)
53       tzinfo (~> 1.1)
54     addressable (2.6.0)
55       public_suffix (>= 2.0.2, < 4.0)
56     annotate (2.7.4)
57       activerecord (>= 3.2, < 6.0)
58       rake (>= 10.4, < 13.0)
59     arel (9.0.0)
60     ast (2.4.0)
61     autoprefixer-rails (8.6.5)
62       execjs
63     better_errors (2.5.1)
64       coderay (>= 1.0.0)
65       erubi (>= 1.0.0)
66       rack (>= 0.9.0)
67     better_html (1.0.13)
68       actionview (>= 4.0)
69       activesupport (>= 4.0)
70       ast (~> 2.0)
71       erubi (~> 1.4)
72       html_tokenizer (~> 0.0.6)
73       parser (>= 2.4)
74       smart_properties
75     bigdecimal (1.1.0)
76     binding_of_caller (0.8.0)
77       debug_inspector (>= 0.0.1)
78     bootsnap (1.4.2)
79       msgpack (~> 1.0)
80     browser (2.5.3)
81     builder (3.2.3)
82     cancancan (2.3.0)
83     canonical-rails (0.2.5)
84       rails (>= 4.1, < 6.1)
85     capybara (2.18.0)
86       addressable
87       mini_mime (>= 0.1.3)
88       nokogiri (>= 1.3.3)
89       rack (>= 1.0.0)
90       rack-test (>= 0.5.4)
91       xpath (>= 2.0, < 4.0)
92     climate_control (0.2.0)
93     cliver (0.3.2)
94     coderay (1.1.2)
95     coffee-rails (4.2.2)
96       coffee-script (>= 2.2.0)
97       railties (>= 4.0.0)
98     coffee-script (2.4.1)
99       coffee-script-source
100       execjs
101     coffee-script-source (1.12.2)
102     composite_primary_keys (11.1.0)
103       activerecord (~> 5.2.1)
104     concurrent-ruby (1.1.5)
105     config (1.7.1)
106       activesupport (>= 3.0)
107       deep_merge (~> 1.2.1)
108       dry-validation (>= 0.12.2)
109     coveralls (0.8.22)
110       json (>= 1.8, < 3)
111       simplecov (~> 0.16.1)
112       term-ansicolor (~> 1.3)
113       thor (~> 0.19.4)
114       tins (~> 1.6)
115     crack (0.4.3)
116       safe_yaml (~> 1.0.0)
117     crass (1.0.4)
118     dalli (2.7.10)
119     debug_inspector (0.0.3)
120     deep_merge (1.2.1)
121     delayed_job (4.1.5)
122       activesupport (>= 3.0, < 5.3)
123     delayed_job_active_record (4.1.3)
124       activerecord (>= 3.0, < 5.3)
125       delayed_job (>= 3.0, < 5)
126     docile (1.3.1)
127     dry-configurable (0.8.2)
128       concurrent-ruby (~> 1.0)
129       dry-core (~> 0.4, >= 0.4.7)
130     dry-container (0.7.0)
131       concurrent-ruby (~> 1.0)
132       dry-configurable (~> 0.1, >= 0.1.3)
133     dry-core (0.4.7)
134       concurrent-ruby (~> 1.0)
135     dry-equalizer (0.2.2)
136     dry-inflector (0.1.2)
137     dry-logic (0.5.0)
138       dry-container (~> 0.2, >= 0.2.6)
139       dry-core (~> 0.2)
140       dry-equalizer (~> 0.2)
141     dry-types (0.14.1)
142       concurrent-ruby (~> 1.0)
143       dry-container (~> 0.3)
144       dry-core (~> 0.4, >= 0.4.4)
145       dry-equalizer (~> 0.2)
146       dry-inflector (~> 0.1, >= 0.1.2)
147       dry-logic (~> 0.5, >= 0.5)
148     dry-validation (0.13.1)
149       concurrent-ruby (~> 1.0)
150       dry-configurable (~> 0.1, >= 0.1.3)
151       dry-core (~> 0.2, >= 0.2.1)
152       dry-equalizer (~> 0.2)
153       dry-logic (~> 0.5, >= 0.5.0)
154       dry-types (~> 0.14.0)
155     dynamic_form (1.1.4)
156     erb_lint (0.0.28)
157       activesupport
158       better_html (~> 1.0.7)
159       html_tokenizer
160       rainbow
161       rubocop (~> 0.51)
162       smart_properties
163     erubi (1.8.0)
164     execjs (2.7.0)
165     exifr (1.3.6)
166     factory_bot (5.0.2)
167       activesupport (>= 4.2.0)
168     factory_bot_rails (5.0.1)
169       factory_bot (~> 5.0.0)
170       railties (>= 4.2.0)
171     fakefs (0.20.0)
172     faraday (0.15.4)
173       multipart-post (>= 1.2, < 3)
174     ffi (1.10.0)
175     fspath (3.1.0)
176     gd2-ffij (0.3.0)
177       ffi (>= 1.0.0)
178     geoip (1.6.4)
179     globalid (0.4.2)
180       activesupport (>= 4.2.0)
181     hashdiff (0.3.8)
182     hashie (3.6.0)
183     html_tokenizer (0.0.7)
184     htmlentities (4.3.4)
185     http_accept_language (2.0.5)
186     i18n (0.9.5)
187       concurrent-ruby (~> 1.0)
188     i18n-js (3.2.1)
189       i18n (>= 0.6.6)
190     image_optim (0.26.3)
191       exifr (~> 1.2, >= 1.2.2)
192       fspath (~> 3.0)
193       image_size (>= 1.5, < 3)
194       in_threads (~> 1.3)
195       progress (~> 3.0, >= 3.0.1)
196     image_optim_rails (0.4.1)
197       image_optim (~> 0.24)
198       rails
199       sprockets
200     image_size (2.0.0)
201     in_threads (1.5.1)
202     jaro_winkler (1.5.2)
203     jquery-rails (4.3.3)
204       rails-dom-testing (>= 1, < 3)
205       railties (>= 4.2.0)
206       thor (>= 0.14, < 2.0)
207     jshint (1.5.0)
208       execjs (>= 1.4.0)
209       multi_json (~> 1.0)
210       therubyracer (~> 0.12.1)
211     json (2.2.0)
212     jsonify (0.3.1)
213       multi_json (~> 1.0)
214     jsonify-rails (0.3.2)
215       actionpack
216       jsonify (< 0.4.0)
217     jwt (2.1.0)
218     kgio (2.11.2)
219     kramdown (2.1.0)
220     libv8 (3.16.14.19)
221     libxml-ruby (3.1.0)
222     listen (3.1.5)
223       rb-inotify (~> 0.9, >= 0.9.7)
224     logstash-event (1.2.02)
225     logstasher (1.3.0)
226       activesupport (>= 4.0)
227       logstash-event (~> 1.2.0)
228       request_store
229     loofah (2.2.3)
230       crass (~> 1.0.2)
231       nokogiri (>= 1.5.9)
232     mail (2.7.1)
233       mini_mime (>= 0.1.1)
234     marcel (0.3.3)
235       mimemagic (~> 0.3.2)
236     method_source (0.9.2)
237     mime-types (3.2.2)
238       mime-types-data (~> 3.2015)
239     mime-types-data (3.2018.0812)
240     mimemagic (0.3.3)
241     mini_mime (1.0.1)
242     mini_portile2 (2.4.0)
243     minitest (5.11.3)
244     msgpack (1.2.9)
245     multi_json (1.13.1)
246     multi_xml (0.6.0)
247     multipart-post (2.0.0)
248     nio4r (2.3.1)
249     nokogiri (1.10.2)
250       mini_portile2 (~> 2.4.0)
251     nokogumbo (2.0.1)
252       nokogiri (~> 1.8, >= 1.8.4)
253     oauth (0.4.7)
254     oauth-plugin (0.5.1)
255       multi_json
256       oauth (~> 0.4.4)
257       oauth2 (>= 0.5.0)
258       rack
259     oauth2 (1.4.1)
260       faraday (>= 0.8, < 0.16.0)
261       jwt (>= 1.0, < 3.0)
262       multi_json (~> 1.3)
263       multi_xml (~> 0.5)
264       rack (>= 1.2, < 3)
265     omniauth (1.9.0)
266       hashie (>= 3.4.6, < 3.7.0)
267       rack (>= 1.6.2, < 3)
268     omniauth-facebook (5.0.0)
269       omniauth-oauth2 (~> 1.2)
270     omniauth-github (1.3.0)
271       omniauth (~> 1.5)
272       omniauth-oauth2 (>= 1.4.0, < 2.0)
273     omniauth-google-oauth2 (0.6.1)
274       jwt (>= 2.0)
275       omniauth (>= 1.1.1)
276       omniauth-oauth2 (>= 1.5)
277     omniauth-mediawiki (0.0.4)
278       jwt (~> 2.0)
279       omniauth-oauth (~> 1.0)
280     omniauth-oauth (1.1.0)
281       oauth
282       omniauth (~> 1.0)
283     omniauth-oauth2 (1.6.0)
284       oauth2 (~> 1.1)
285       omniauth (~> 1.9)
286     omniauth-openid (1.0.1)
287       omniauth (~> 1.0)
288       rack-openid (~> 1.3.1)
289     omniauth-windowslive (0.0.12)
290       multi_json (~> 1.12)
291       omniauth-oauth2 (~> 1.4)
292     openstreetmap-deadlock_retry (1.3.0)
293     paperclip (5.3.0)
294       activemodel (>= 4.2.0)
295       activesupport (>= 4.2.0)
296       mime-types
297       mimemagic (~> 0.3.0)
298       terrapin (~> 0.6.0)
299     parallel (1.16.0)
300     parser (2.6.2.0)
301       ast (~> 2.4.0)
302     pg (0.21.0)
303     poltergeist (1.18.1)
304       capybara (>= 2.1, < 4)
305       cliver (~> 0.3.1)
306       websocket-driver (>= 0.2.0)
307     progress (3.5.0)
308     psych (3.1.0)
309     public_suffix (3.0.3)
310     puma (3.12.1)
311     quad_tile (1.0.1)
312     r2 (0.2.7)
313     rack (2.0.6)
314     rack-cors (1.0.3)
315     rack-openid (1.3.1)
316       rack (>= 1.1.0)
317       ruby-openid (>= 2.1.8)
318     rack-test (1.1.0)
319       rack (>= 1.0, < 3)
320     rack-uri_sanitizer (0.0.2)
321     rails (5.2.2.1)
322       actioncable (= 5.2.2.1)
323       actionmailer (= 5.2.2.1)
324       actionpack (= 5.2.2.1)
325       actionview (= 5.2.2.1)
326       activejob (= 5.2.2.1)
327       activemodel (= 5.2.2.1)
328       activerecord (= 5.2.2.1)
329       activestorage (= 5.2.2.1)
330       activesupport (= 5.2.2.1)
331       bundler (>= 1.3.0)
332       railties (= 5.2.2.1)
333       sprockets-rails (>= 2.0.0)
334     rails-controller-testing (1.0.4)
335       actionpack (>= 5.0.1.x)
336       actionview (>= 5.0.1.x)
337       activesupport (>= 5.0.1.x)
338     rails-dom-testing (2.0.3)
339       activesupport (>= 4.2.0)
340       nokogiri (>= 1.6)
341     rails-html-sanitizer (1.0.4)
342       loofah (~> 2.2, >= 2.2.2)
343     rails-i18n (4.0.2)
344       i18n (~> 0.6)
345       rails (>= 4.0)
346     railties (5.2.2.1)
347       actionpack (= 5.2.2.1)
348       activesupport (= 5.2.2.1)
349       method_source
350       rake (>= 0.8.7)
351       thor (>= 0.19.0, < 2.0)
352     rainbow (3.0.0)
353     rake (12.3.2)
354     rb-inotify (0.10.0)
355       ffi (~> 1.0)
356     record_tag_helper (1.0.0)
357       actionview (~> 5.x)
358     ref (2.0.0)
359     request_store (1.4.1)
360       rack (>= 1.4)
361     rinku (2.0.4)
362     rotp (4.1.0)
363       addressable (~> 2.5)
364     rubocop (0.66.0)
365       jaro_winkler (~> 1.5.1)
366       parallel (~> 1.10)
367       parser (>= 2.5, != 2.5.1.1)
368       psych (>= 3.1.0)
369       rainbow (>= 2.2.2, < 4.0)
370       ruby-progressbar (~> 1.7)
371       unicode-display_width (>= 1.4.0, < 1.6)
372     ruby-openid (2.7.0)
373     ruby-progressbar (1.10.0)
374     safe_yaml (1.0.5)
375     sanitize (5.0.0)
376       crass (~> 1.0.2)
377       nokogiri (>= 1.8.0)
378       nokogumbo (~> 2.0)
379     sassc (2.0.1)
380       ffi (~> 1.9)
381       rake
382     sassc-rails (2.1.0)
383       railties (>= 4.0.0)
384       sassc (>= 2.0)
385       sprockets (> 3.0)
386       sprockets-rails
387       tilt
388     secure_headers (6.1.0)
389     simplecov (0.16.1)
390       docile (~> 1.1)
391       json (>= 1.8, < 3)
392       simplecov-html (~> 0.10.0)
393     simplecov-html (0.10.2)
394     smart_properties (1.13.1)
395     sprockets (3.7.2)
396       concurrent-ruby (~> 1.0)
397       rack (> 1, < 3)
398     sprockets-rails (3.2.1)
399       actionpack (>= 4.0)
400       activesupport (>= 4.0)
401       sprockets (>= 3.0.0)
402     term-ansicolor (1.7.1)
403       tins (~> 1.0)
404     terrapin (0.6.0)
405       climate_control (>= 0.0.3, < 1.0)
406     therubyracer (0.12.3)
407       libv8 (~> 3.16.14.15)
408       ref
409     thor (0.19.4)
410     thread_safe (0.3.6)
411     tilt (2.0.9)
412     tins (1.20.2)
413     tzinfo (1.2.5)
414       thread_safe (~> 0.1)
415     uglifier (4.1.20)
416       execjs (>= 0.3.0, < 3)
417     unicode-display_width (1.5.0)
418     validates_email_format_of (1.6.3)
419       i18n
420     vendorer (0.2.0)
421     webmock (3.5.1)
422       addressable (>= 2.3.6)
423       crack (>= 0.3.2)
424       hashdiff
425     websocket-driver (0.7.0)
426       websocket-extensions (>= 0.1.0)
427     websocket-extensions (0.1.3)
428     xpath (3.2.0)
429       nokogiri (~> 1.8)
430
431 PLATFORMS
432   ruby
433
434 DEPENDENCIES
435   SystemTimer (>= 1.1.3)
436   aasm
437   actionpack-page_caching
438   active_record_union
439   activerecord-import
440   annotate
441   autoprefixer-rails (~> 8.6.3)
442   better_errors
443   bigdecimal (~> 1.1.0)
444   binding_of_caller
445   bootsnap (>= 1.1.0)
446   browser
447   cancancan
448   canonical-rails
449   capybara (~> 2.13)
450   coffee-rails (~> 4.2)
451   composite_primary_keys (~> 11.1.0)
452   config
453   coveralls
454   dalli
455   delayed_job_active_record
456   dynamic_form
457   erb_lint
458   factory_bot_rails
459   fakefs
460   faraday
461   gd2-ffij
462   geoip
463   htmlentities
464   http_accept_language (~> 2.0.0)
465   i18n-js (>= 3.0.0)
466   image_optim_rails
467   jquery-rails
468   jshint
469   json
470   jsonify-rails
471   kgio
472   kramdown
473   libxml-ruby (>= 2.0.5)
474   listen
475   logstasher
476   minitest (~> 5.1)
477   oauth-plugin (>= 0.5.1)
478   omniauth
479   omniauth-facebook
480   omniauth-github
481   omniauth-google-oauth2 (>= 0.6.0)
482   omniauth-mediawiki (>= 0.0.4)
483   omniauth-openid
484   omniauth-windowslive
485   openstreetmap-deadlock_retry (>= 1.3.0)
486   paperclip (~> 5.2)
487   pg (~> 0.18)
488   poltergeist
489   psych
490   puma (~> 3.7)
491   quad_tile (~> 1.0.1)
492   r2 (~> 0.2.7)
493   rack-cors
494   rack-uri_sanitizer
495   rails (= 5.2.2.1)
496   rails-controller-testing
497   rails-i18n (~> 4.0.0)
498   record_tag_helper
499   rinku (= 2.0.4)
500   rotp
501   rubocop
502   sanitize
503   sassc-rails
504   secure_headers
505   uglifier (>= 1.3.0)
506   validates_email_format_of (>= 1.5.1)
507   vendorer
508   webmock
509
510 BUNDLED WITH
511    1.16.2