Use gd-ffij gem to create trace icons
[rails.git] / Gemfile.lock
1 GEM
2   remote: https://rubygems.org/
3   specs:
4     SystemTimer (1.2.3)
5     aasm (5.0.1)
6       concurrent-ruby (~> 1.0)
7     actioncable (5.2.2)
8       actionpack (= 5.2.2)
9       nio4r (~> 2.0)
10       websocket-driver (>= 0.6.1)
11     actionmailer (5.2.2)
12       actionpack (= 5.2.2)
13       actionview (= 5.2.2)
14       activejob (= 5.2.2)
15       mail (~> 2.5, >= 2.5.4)
16       rails-dom-testing (~> 2.0)
17     actionpack (5.2.2)
18       actionview (= 5.2.2)
19       activesupport (= 5.2.2)
20       rack (~> 2.0)
21       rack-test (>= 0.6.3)
22       rails-dom-testing (~> 2.0)
23       rails-html-sanitizer (~> 1.0, >= 1.0.2)
24     actionpack-page_caching (1.1.1)
25       actionpack (>= 4.0.0, < 6)
26     actionview (5.2.2)
27       activesupport (= 5.2.2)
28       builder (~> 3.1)
29       erubi (~> 1.4)
30       rails-dom-testing (~> 2.0)
31       rails-html-sanitizer (~> 1.0, >= 1.0.3)
32     active_record_union (1.3.0)
33       activerecord (>= 4.0)
34     activejob (5.2.2)
35       activesupport (= 5.2.2)
36       globalid (>= 0.3.6)
37     activemodel (5.2.2)
38       activesupport (= 5.2.2)
39     activerecord (5.2.2)
40       activemodel (= 5.2.2)
41       activesupport (= 5.2.2)
42       arel (>= 9.0)
43     activestorage (5.2.2)
44       actionpack (= 5.2.2)
45       activerecord (= 5.2.2)
46       marcel (~> 0.3.1)
47     activesupport (5.2.2)
48       concurrent-ruby (~> 1.0, >= 1.0.2)
49       i18n (>= 0.7, < 2)
50       minitest (~> 5.1)
51       tzinfo (~> 1.1)
52     addressable (2.5.2)
53       public_suffix (>= 2.0.2, < 4.0)
54     annotate (2.7.4)
55       activerecord (>= 3.2, < 6.0)
56       rake (>= 10.4, < 13.0)
57     arel (9.0.0)
58     ast (2.4.0)
59     autoprefixer-rails (8.6.5)
60       execjs
61     better_errors (2.5.0)
62       coderay (>= 1.0.0)
63       erubi (>= 1.0.0)
64       rack (>= 0.9.0)
65     bigdecimal (1.1.0)
66     binding_of_caller (0.8.0)
67       debug_inspector (>= 0.0.1)
68     bootsnap (1.3.2)
69       msgpack (~> 1.0)
70     builder (3.2.3)
71     cancancan (2.3.0)
72     canonical-rails (0.2.4)
73       rails (>= 4.1, < 5.3)
74     capybara (2.18.0)
75       addressable
76       mini_mime (>= 0.1.3)
77       nokogiri (>= 1.3.3)
78       rack (>= 1.0.0)
79       rack-test (>= 0.5.4)
80       xpath (>= 2.0, < 4.0)
81     climate_control (0.2.0)
82     cliver (0.3.2)
83     coderay (1.1.2)
84     coffee-rails (4.2.2)
85       coffee-script (>= 2.2.0)
86       railties (>= 4.0.0)
87     coffee-script (2.4.1)
88       coffee-script-source
89       execjs
90     coffee-script-source (1.12.2)
91     composite_primary_keys (11.1.0)
92       activerecord (~> 5.2.1)
93     concurrent-ruby (1.1.4)
94     coveralls (0.8.22)
95       json (>= 1.8, < 3)
96       simplecov (~> 0.16.1)
97       term-ansicolor (~> 1.3)
98       thor (~> 0.19.4)
99       tins (~> 1.6)
100     crack (0.4.3)
101       safe_yaml (~> 1.0.0)
102     crass (1.0.4)
103     dalli (2.7.9)
104     debug_inspector (0.0.3)
105     delayed_job (4.1.5)
106       activesupport (>= 3.0, < 5.3)
107     delayed_job_active_record (4.1.3)
108       activerecord (>= 3.0, < 5.3)
109       delayed_job (>= 3.0, < 5)
110     docile (1.3.1)
111     dynamic_form (1.1.4)
112     erubi (1.8.0)
113     execjs (2.7.0)
114     exifr (1.3.5)
115     factory_bot (4.11.1)
116       activesupport (>= 3.0.0)
117     factory_bot_rails (4.11.1)
118       factory_bot (~> 4.11.1)
119       railties (>= 3.0.0)
120     faraday (0.15.4)
121       multipart-post (>= 1.2, < 3)
122     ffi (1.9.25)
123     fspath (3.1.0)
124     gd2-ffij (0.3.0)
125       ffi (>= 1.0.0)
126     geoip (1.6.4)
127     globalid (0.4.1)
128       activesupport (>= 4.2.0)
129     hashdiff (0.3.8)
130     hashie (3.6.0)
131     htmlentities (4.3.4)
132     http_accept_language (2.0.5)
133     i18n (0.9.5)
134       concurrent-ruby (~> 1.0)
135     i18n-js (3.2.0)
136       i18n (>= 0.8.0, < 2)
137     image_optim (0.26.3)
138       exifr (~> 1.2, >= 1.2.2)
139       fspath (~> 3.0)
140       image_size (>= 1.5, < 3)
141       in_threads (~> 1.3)
142       progress (~> 3.0, >= 3.0.1)
143     image_optim_rails (0.4.1)
144       image_optim (~> 0.24)
145       rails
146       sprockets
147     image_size (2.0.0)
148     in_threads (1.5.1)
149     jaro_winkler (1.5.2)
150     jquery-rails (4.3.3)
151       rails-dom-testing (>= 1, < 3)
152       railties (>= 4.2.0)
153       thor (>= 0.14, < 2.0)
154     jshint (1.5.0)
155       execjs (>= 1.4.0)
156       multi_json (~> 1.0)
157       therubyracer (~> 0.12.1)
158     json (2.1.0)
159     jsonify (0.3.1)
160       multi_json (~> 1.0)
161     jsonify-rails (0.3.2)
162       actionpack
163       jsonify (< 0.4.0)
164     jwt (2.1.0)
165     kgio (2.11.2)
166     libv8 (3.16.14.19)
167     libxml-ruby (3.1.0)
168     listen (3.1.5)
169       rb-fsevent (~> 0.9, >= 0.9.4)
170       rb-inotify (~> 0.9, >= 0.9.7)
171       ruby_dep (~> 1.2)
172     logstash-event (1.2.02)
173     logstasher (1.3.0)
174       activesupport (>= 4.0)
175       logstash-event (~> 1.2.0)
176       request_store
177     loofah (2.2.3)
178       crass (~> 1.0.2)
179       nokogiri (>= 1.5.9)
180     mail (2.7.1)
181       mini_mime (>= 0.1.1)
182     marcel (0.3.3)
183       mimemagic (~> 0.3.2)
184     method_source (0.9.2)
185     mime-types (3.2.2)
186       mime-types-data (~> 3.2015)
187     mime-types-data (3.2018.0812)
188     mimemagic (0.3.3)
189     mini_mime (1.0.1)
190     mini_portile2 (2.4.0)
191     minitest (5.11.3)
192     msgpack (1.2.6)
193     multi_json (1.13.1)
194     multi_xml (0.6.0)
195     multipart-post (2.0.0)
196     nio4r (2.3.1)
197     nokogiri (1.10.0)
198       mini_portile2 (~> 2.4.0)
199     nokogumbo (2.0.1)
200       nokogiri (~> 1.8, >= 1.8.4)
201     oauth (0.4.7)
202     oauth-plugin (0.5.1)
203       multi_json
204       oauth (~> 0.4.4)
205       oauth2 (>= 0.5.0)
206       rack
207     oauth2 (1.4.1)
208       faraday (>= 0.8, < 0.16.0)
209       jwt (>= 1.0, < 3.0)
210       multi_json (~> 1.3)
211       multi_xml (~> 0.5)
212       rack (>= 1.2, < 3)
213     omniauth (1.9.0)
214       hashie (>= 3.4.6, < 3.7.0)
215       rack (>= 1.6.2, < 3)
216     omniauth-facebook (5.0.0)
217       omniauth-oauth2 (~> 1.2)
218     omniauth-github (1.3.0)
219       omniauth (~> 1.5)
220       omniauth-oauth2 (>= 1.4.0, < 2.0)
221     omniauth-google-oauth2 (0.6.0)
222       jwt (>= 2.0)
223       omniauth (>= 1.1.1)
224       omniauth-oauth2 (>= 1.5)
225     omniauth-mediawiki (0.0.4)
226       jwt (~> 2.0)
227       omniauth-oauth (~> 1.0)
228     omniauth-oauth (1.1.0)
229       oauth
230       omniauth (~> 1.0)
231     omniauth-oauth2 (1.6.0)
232       oauth2 (~> 1.1)
233       omniauth (~> 1.9)
234     omniauth-openid (1.0.1)
235       omniauth (~> 1.0)
236       rack-openid (~> 1.3.1)
237     omniauth-windowslive (0.0.12)
238       multi_json (~> 1.12)
239       omniauth-oauth2 (~> 1.4)
240     openstreetmap-deadlock_retry (1.3.0)
241     paperclip (5.3.0)
242       activemodel (>= 4.2.0)
243       activesupport (>= 4.2.0)
244       mime-types
245       mimemagic (~> 0.3.0)
246       terrapin (~> 0.6.0)
247     parallel (1.12.1)
248     parser (2.5.3.0)
249       ast (~> 2.4.0)
250     pg (0.21.0)
251     poltergeist (1.18.1)
252       capybara (>= 2.1, < 4)
253       cliver (~> 0.3.1)
254       websocket-driver (>= 0.2.0)
255     powerpack (0.1.2)
256     progress (3.5.0)
257     psych (3.1.0)
258     public_suffix (3.0.3)
259     puma (3.12.0)
260     quad_tile (1.0.1)
261     r2 (0.2.7)
262     rack (2.0.6)
263     rack-cors (1.0.2)
264     rack-openid (1.3.1)
265       rack (>= 1.1.0)
266       ruby-openid (>= 2.1.8)
267     rack-test (1.1.0)
268       rack (>= 1.0, < 3)
269     rack-uri_sanitizer (0.0.2)
270     rails (5.2.2)
271       actioncable (= 5.2.2)
272       actionmailer (= 5.2.2)
273       actionpack (= 5.2.2)
274       actionview (= 5.2.2)
275       activejob (= 5.2.2)
276       activemodel (= 5.2.2)
277       activerecord (= 5.2.2)
278       activestorage (= 5.2.2)
279       activesupport (= 5.2.2)
280       bundler (>= 1.3.0)
281       railties (= 5.2.2)
282       sprockets-rails (>= 2.0.0)
283     rails-controller-testing (1.0.4)
284       actionpack (>= 5.0.1.x)
285       actionview (>= 5.0.1.x)
286       activesupport (>= 5.0.1.x)
287     rails-dom-testing (2.0.3)
288       activesupport (>= 4.2.0)
289       nokogiri (>= 1.6)
290     rails-html-sanitizer (1.0.4)
291       loofah (~> 2.2, >= 2.2.2)
292     rails-i18n (4.0.2)
293       i18n (~> 0.6)
294       rails (>= 4.0)
295     railties (5.2.2)
296       actionpack (= 5.2.2)
297       activesupport (= 5.2.2)
298       method_source
299       rake (>= 0.8.7)
300       thor (>= 0.19.0, < 2.0)
301     rainbow (3.0.0)
302     rake (12.3.2)
303     rb-fsevent (0.10.3)
304     rb-inotify (0.10.0)
305       ffi (~> 1.0)
306     record_tag_helper (1.0.0)
307       actionview (~> 5.x)
308     redcarpet (3.4.0)
309     ref (2.0.0)
310     request_store (1.4.1)
311       rack (>= 1.4)
312     rinku (2.0.4)
313     rotp (4.0.2)
314       addressable (~> 2.5)
315     rubocop (0.62.0)
316       jaro_winkler (~> 1.5.1)
317       parallel (~> 1.10)
318       parser (>= 2.5, != 2.5.1.1)
319       powerpack (~> 0.1)
320       rainbow (>= 2.2.2, < 4.0)
321       ruby-progressbar (~> 1.7)
322       unicode-display_width (~> 1.4.0)
323     ruby-openid (2.7.0)
324     ruby-progressbar (1.10.0)
325     ruby_dep (1.5.0)
326     safe_yaml (1.0.4)
327     sanitize (5.0.0)
328       crass (~> 1.0.2)
329       nokogiri (>= 1.8.0)
330       nokogumbo (~> 2.0)
331     sassc (2.0.0)
332       ffi (~> 1.9.6)
333       rake
334     sassc-rails (2.1.0)
335       railties (>= 4.0.0)
336       sassc (>= 2.0)
337       sprockets (> 3.0)
338       sprockets-rails
339       tilt
340     secure_headers (6.0.0)
341     simplecov (0.16.1)
342       docile (~> 1.1)
343       json (>= 1.8, < 3)
344       simplecov-html (~> 0.10.0)
345     simplecov-html (0.10.2)
346     sprockets (3.7.2)
347       concurrent-ruby (~> 1.0)
348       rack (> 1, < 3)
349     sprockets-rails (3.2.1)
350       actionpack (>= 4.0)
351       activesupport (>= 4.0)
352       sprockets (>= 3.0.0)
353     term-ansicolor (1.7.0)
354       tins (~> 1.0)
355     terrapin (0.6.0)
356       climate_control (>= 0.0.3, < 1.0)
357     therubyracer (0.12.3)
358       libv8 (~> 3.16.14.15)
359       ref
360     thor (0.19.4)
361     thread_safe (0.3.6)
362     tilt (2.0.9)
363     tins (1.20.2)
364     tzinfo (1.2.5)
365       thread_safe (~> 0.1)
366     uglifier (4.1.20)
367       execjs (>= 0.3.0, < 3)
368     unicode-display_width (1.4.1)
369     validates_email_format_of (1.6.3)
370       i18n
371     vendorer (0.2.0)
372     webmock (3.5.1)
373       addressable (>= 2.3.6)
374       crack (>= 0.3.2)
375       hashdiff
376     websocket-driver (0.7.0)
377       websocket-extensions (>= 0.1.0)
378     websocket-extensions (0.1.3)
379     xpath (3.2.0)
380       nokogiri (~> 1.8)
381
382 PLATFORMS
383   ruby
384
385 DEPENDENCIES
386   SystemTimer (>= 1.1.3)
387   aasm
388   actionpack-page_caching
389   active_record_union
390   annotate
391   autoprefixer-rails (~> 8.6.3)
392   better_errors
393   bigdecimal (~> 1.1.0)
394   binding_of_caller
395   bootsnap (>= 1.1.0)
396   cancancan
397   canonical-rails
398   capybara (~> 2.13)
399   coffee-rails (~> 4.2)
400   composite_primary_keys (~> 11.1.0)
401   coveralls
402   dalli
403   delayed_job_active_record
404   dynamic_form
405   factory_bot_rails
406   faraday
407   gd2-ffij
408   geoip
409   htmlentities
410   http_accept_language (~> 2.0.0)
411   i18n-js (>= 3.0.0)
412   image_optim_rails
413   jquery-rails
414   jshint
415   json
416   jsonify-rails
417   kgio
418   libxml-ruby (>= 2.0.5)
419   listen
420   logstasher
421   minitest (~> 5.1)
422   oauth-plugin (>= 0.5.1)
423   omniauth
424   omniauth-facebook
425   omniauth-github
426   omniauth-google-oauth2 (>= 0.6.0)
427   omniauth-mediawiki (>= 0.0.4)
428   omniauth-openid
429   omniauth-windowslive
430   openstreetmap-deadlock_retry (>= 1.3.0)
431   paperclip (~> 5.2)
432   pg (~> 0.18)
433   poltergeist
434   psych
435   puma (~> 3.7)
436   quad_tile (~> 1.0.1)
437   r2 (~> 0.2.7)
438   rack-cors
439   rack-uri_sanitizer
440   rails (= 5.2.2)
441   rails-controller-testing
442   rails-i18n (~> 4.0.0)
443   record_tag_helper
444   redcarpet
445   rinku (>= 1.2.2)
446   rotp
447   rubocop
448   sanitize
449   sassc-rails
450   secure_headers
451   uglifier (>= 1.3.0)
452   validates_email_format_of (>= 1.5.1)
453   vendorer
454   webmock
455
456 BUNDLED WITH
457    1.16.2