Fix rubocop warnings
[rails.git] / .rubocop.yml
1 inherit_from: .rubocop_todo.yml
2
3 Rails:
4   Enabled: true
5
6 Style/BracesAroundHashParameters:
7   EnforcedStyle: context_dependent
8
9 Style/ExtraSpacing:
10   AllowForAlignment: true
11
12 Style/FileName:
13   Exclude:
14     - 'script/deliver-message'
15     - 'script/locale/reload-languages'
16     - 'script/update-spam-blocks'
17
18 Style/IfInsideElse:
19   Enabled: false
20
21 Style/GlobalVars:
22   Exclude:
23     - 'lib/quad_tile/extconf.rb'
24
25 Style/GuardClause:
26   Enabled: false
27
28 Style/HashSyntax:
29   EnforcedStyle: hash_rockets
30   Exclude:
31     - 'lib/tasks/testing.rake'
32     - 'config/initializers/wrap_parameters.rb'
33
34 Style/StringLiterals:
35   EnforcedStyle: double_quotes
36
37 Style/WordArray:
38   Exclude:
39     - 'test/models/message_test.rb'