Add support for Facebook authentication
[rails.git] / Gemfile.lock
1 GEM
2   remote: https://rubygems.org/
3   specs:
4     SystemTimer (1.2.3)
5     actionmailer (4.2.1)
6       actionpack (= 4.2.1)
7       actionview (= 4.2.1)
8       activejob (= 4.2.1)
9       mail (~> 2.5, >= 2.5.4)
10       rails-dom-testing (~> 1.0, >= 1.0.5)
11     actionpack (4.2.1)
12       actionview (= 4.2.1)
13       activesupport (= 4.2.1)
14       rack (~> 1.6)
15       rack-test (~> 0.6.2)
16       rails-dom-testing (~> 1.0, >= 1.0.5)
17       rails-html-sanitizer (~> 1.0, >= 1.0.1)
18     actionpack-page_caching (1.0.2)
19       actionpack (>= 4.0.0, < 5)
20     actionview (4.2.1)
21       activesupport (= 4.2.1)
22       builder (~> 3.1)
23       erubis (~> 2.7.0)
24       rails-dom-testing (~> 1.0, >= 1.0.5)
25       rails-html-sanitizer (~> 1.0, >= 1.0.1)
26     activejob (4.2.1)
27       activesupport (= 4.2.1)
28       globalid (>= 0.3.0)
29     activemodel (4.2.1)
30       activesupport (= 4.2.1)
31       builder (~> 3.1)
32     activerecord (4.2.1)
33       activemodel (= 4.2.1)
34       activesupport (= 4.2.1)
35       arel (~> 6.0)
36     activesupport (4.2.1)
37       i18n (~> 0.7)
38       json (~> 1.7, >= 1.7.7)
39       minitest (~> 5.1)
40       thread_safe (~> 0.3, >= 0.3.4)
41       tzinfo (~> 1.1)
42     arel (6.0.0)
43     ast (2.0.0)
44     astrolabe (1.3.0)
45       parser (>= 2.2.0.pre.3, < 3.0)
46     autoprefixer-rails (5.1.11)
47       execjs
48       json
49     bigdecimal (1.1.0)
50     builder (3.2.2)
51     capybara (2.4.4)
52       mime-types (>= 1.16)
53       nokogiri (>= 1.3.3)
54       rack (>= 1.0.0)
55       rack-test (>= 0.5.4)
56       xpath (~> 2.0)
57     climate_control (0.0.3)
58       activesupport (>= 3.0)
59     cliver (0.3.2)
60     cocaine (0.5.7)
61       climate_control (>= 0.0.3, < 1.0)
62     coffee-rails (4.1.0)
63       coffee-script (>= 2.2.0)
64       railties (>= 4.0.0, < 5.0)
65     coffee-script (2.4.1)
66       coffee-script-source
67       execjs
68     coffee-script-source (1.9.1.1)
69     colorize (0.7.7)
70     composite_primary_keys (8.1.0)
71       activerecord (~> 4.2.0)
72     coveralls (0.8.1)
73       json (~> 1.8)
74       rest-client (>= 1.6.8, < 2)
75       simplecov (~> 0.10.0)
76       term-ansicolor (~> 1.3)
77       thor (~> 0.19.1)
78     crass (1.0.2)
79     dalli (2.7.4)
80     deadlock_retry (1.2.0)
81     docile (1.1.5)
82     domain_name (0.5.24)
83       unf (>= 0.0.5, < 1.0.0)
84     dynamic_form (1.1.4)
85     erubis (2.7.0)
86     execjs (2.5.2)
87     faraday (0.9.1)
88       multipart-post (>= 1.2, < 3)
89     globalid (0.3.5)
90       activesupport (>= 4.1.0)
91     hashie (3.4.1)
92     hike (1.2.3)
93     htmlentities (4.3.3)
94     http-cookie (1.0.2)
95       domain_name (~> 0.5)
96     http_accept_language (2.0.5)
97     httpclient (2.6.0.1)
98     i18n (0.7.0)
99     jquery-rails (4.0.3)
100       rails-dom-testing (~> 1.0)
101       railties (>= 4.2.0)
102       thor (>= 0.14, < 2.0)
103     jshint (1.3.1)
104       execjs (>= 1.4.0)
105       multi_json (~> 1.0)
106       therubyracer (~> 0.12.1)
107     json (1.8.2)
108     jsonify (0.3.1)
109       multi_json (~> 1.0)
110     jsonify-rails (0.3.2)
111       actionpack
112       jsonify (< 0.4.0)
113     jwt (1.4.1)
114     kgio (2.9.3)
115     konacha (3.3.0)
116       actionpack (>= 3.1, < 5)
117       capybara
118       colorize
119       railties (>= 3.1, < 5)
120       sprockets
121     libv8 (3.16.14.7)
122     libxml-ruby (2.8.0)
123     loofah (2.0.1)
124       nokogiri (>= 1.5.9)
125     mail (2.6.3)
126       mime-types (>= 1.16, < 3)
127     mime-types (2.5)
128     mini_portile (0.6.2)
129     minitest (5.6.1)
130     multi_json (1.11.0)
131     multi_xml (0.5.5)
132     multipart-post (2.0.0)
133     netrc (0.10.3)
134     nokogiri (1.6.6.2)
135       mini_portile (~> 0.6.0)
136     nokogumbo (1.4.1)
137       nokogiri
138     oauth (0.4.7)
139     oauth-plugin (0.5.1)
140       multi_json
141       oauth (~> 0.4.4)
142       oauth2 (>= 0.5.0)
143       rack
144     oauth2 (1.0.0)
145       faraday (>= 0.8, < 0.10)
146       jwt (~> 1.0)
147       multi_json (~> 1.3)
148       multi_xml (~> 0.5)
149       rack (~> 1.2)
150     omniauth (1.2.2)
151       hashie (>= 1.2, < 4)
152       rack (~> 1.0)
153     omniauth-facebook (2.0.1)
154       omniauth-oauth2 (~> 1.2)
155     omniauth-oauth2 (1.3.0)
156       oauth2 (~> 1.0)
157       omniauth (~> 1.2)
158     omniauth-openid (1.0.1)
159       omniauth (~> 1.0)
160       rack-openid (~> 1.3.1)
161     openstreetmap-i18n-js (3.0.0.rc5.3)
162       i18n
163     openstreetmap-omniauth-google-oauth2 (0.2.6.1)
164       jwt (~> 1.0)
165       multi_json (~> 1.3)
166       omniauth (>= 1.1.1)
167       omniauth-oauth2 (>= 1.1.1)
168     paperclip (4.2.1)
169       activemodel (>= 3.0.0)
170       activesupport (>= 3.0.0)
171       cocaine (~> 0.5.3)
172       mime-types
173     parser (2.2.2.2)
174       ast (>= 1.1, < 3.0)
175     pg (0.18.1)
176     poltergeist (1.6.0)
177       capybara (~> 2.1)
178       cliver (~> 0.3.1)
179       multi_json (~> 1.0)
180       websocket-driver (>= 0.2.0)
181     powerpack (0.1.0)
182     psych (2.0.13)
183     r2 (0.2.5)
184     rack (1.6.0)
185     rack-cors (0.4.0)
186     rack-openid (1.3.1)
187       rack (>= 1.1.0)
188       ruby-openid (>= 2.1.8)
189     rack-test (0.6.3)
190       rack (>= 1.0)
191     rails (4.2.1)
192       actionmailer (= 4.2.1)
193       actionpack (= 4.2.1)
194       actionview (= 4.2.1)
195       activejob (= 4.2.1)
196       activemodel (= 4.2.1)
197       activerecord (= 4.2.1)
198       activesupport (= 4.2.1)
199       bundler (>= 1.3.0, < 2.0)
200       railties (= 4.2.1)
201       sprockets-rails
202     rails-deprecated_sanitizer (1.0.3)
203       activesupport (>= 4.2.0.alpha)
204     rails-dom-testing (1.0.6)
205       activesupport (>= 4.2.0.beta, < 5.0)
206       nokogiri (~> 1.6.0)
207       rails-deprecated_sanitizer (>= 1.0.1)
208     rails-html-sanitizer (1.0.2)
209       loofah (~> 2.0)
210     rails-i18n (4.0.4)
211       i18n (~> 0.6)
212       railties (~> 4.0)
213     railties (4.2.1)
214       actionpack (= 4.2.1)
215       activesupport (= 4.2.1)
216       rake (>= 0.8.7)
217       thor (>= 0.18.1, < 2.0)
218     rainbow (2.0.0)
219     rake (10.4.2)
220     redcarpet (3.2.3)
221     ref (1.0.5)
222     rest-client (1.8.0)
223       http-cookie (>= 1.0.2, < 2.0)
224       mime-types (>= 1.16, < 3.0)
225       netrc (~> 0.7)
226     rinku (1.7.3)
227     rubocop (0.30.1)
228       astrolabe (~> 1.3)
229       parser (>= 2.2.2.1, < 3.0)
230       powerpack (~> 0.1)
231       rainbow (>= 1.99.1, < 3.0)
232       ruby-progressbar (~> 1.4)
233     ruby-openid (2.7.0)
234     ruby-progressbar (1.7.5)
235     sanitize (4.0.0)
236       crass (~> 1.0.2)
237       nokogiri (>= 1.4.4)
238       nokogumbo (= 1.4.1)
239     sass (3.4.13)
240     sass-rails (5.0.3)
241       railties (>= 4.0.0, < 5.0)
242       sass (~> 3.1)
243       sprockets (>= 2.8, < 4.0)
244       sprockets-rails (>= 2.0, < 4.0)
245       tilt (~> 1.1)
246     simplecov (0.10.0)
247       docile (~> 1.1.0)
248       json (~> 1.8)
249       simplecov-html (~> 0.10.0)
250     simplecov-html (0.10.0)
251     soap4r-ruby1.9 (2.0.5)
252     sprockets (2.12.3)
253       hike (~> 1.2)
254       multi_json (~> 1.0)
255       rack (~> 1.0)
256       tilt (~> 1.1, != 1.3.0)
257     sprockets-rails (2.2.4)
258       actionpack (>= 3.0)
259       activesupport (>= 3.0)
260       sprockets (>= 2.8, < 4.0)
261     term-ansicolor (1.3.0)
262       tins (~> 1.0)
263     therubyracer (0.12.2)
264       libv8 (~> 3.16.14.0)
265       ref
266     thor (0.19.1)
267     thread_safe (0.3.5)
268     tilt (1.4.1)
269     timecop (0.7.3)
270     tins (1.5.1)
271     tzinfo (1.2.2)
272       thread_safe (~> 0.1)
273     uglifier (2.7.1)
274       execjs (>= 0.3.0)
275       json (>= 1.8.0)
276     unf (0.1.4)
277       unf_ext
278     unf_ext (0.0.7.1)
279     validates_email_format_of (1.6.2)
280       i18n
281     vendorer (0.1.16)
282     websocket-driver (0.5.4)
283       websocket-extensions (>= 0.1.0)
284     websocket-extensions (0.1.2)
285     xpath (2.0.0)
286       nokogiri (~> 1.3)
287
288 PLATFORMS
289   ruby
290
291 DEPENDENCIES
292   SystemTimer (>= 1.1.3)
293   actionpack-page_caching
294   autoprefixer-rails
295   bigdecimal (~> 1.1.0)
296   coffee-rails (~> 4.1.0)
297   composite_primary_keys (~> 8.1.0)
298   coveralls
299   dalli
300   deadlock_retry (>= 1.2.0)
301   dynamic_form
302   faraday
303   htmlentities
304   http_accept_language (~> 2.0.0)
305   httpclient
306   jquery-rails
307   jshint
308   json
309   jsonify-rails
310   kgio
311   konacha
312   libxml-ruby (>= 2.0.5)
313   minitest (~> 5.1)
314   oauth-plugin (>= 0.5.1)
315   omniauth
316   omniauth-facebook
317   omniauth-openid
318   openstreetmap-i18n-js (>= 3.0.0.rc5.3)
319   openstreetmap-omniauth-google-oauth2 (>= 0.2.6.1)
320   paperclip (~> 4.0)
321   pg
322   poltergeist
323   psych
324   r2
325   rack-cors
326   rails (= 4.2.1)
327   rails-i18n (~> 4.0.0)
328   redcarpet
329   rinku (>= 1.2.2)
330   rubocop
331   sanitize
332   sass-rails (~> 5.0)
333   soap4r-ruby1.9
334   sprockets (~> 2.12.3)
335   timecop
336   uglifier (>= 1.3.0)
337   validates_email_format_of (>= 1.5.1)
338   vendorer