Merge remote-tracking branch 'upstream/pull/2115'
[rails.git] / Gemfile.lock
1 GEM
2   remote: https://rubygems.org/
3   specs:
4     SystemTimer (1.2.3)
5     aasm (5.0.1)
6       concurrent-ruby (~> 1.0)
7     actioncable (5.2.2)
8       actionpack (= 5.2.2)
9       nio4r (~> 2.0)
10       websocket-driver (>= 0.6.1)
11     actionmailer (5.2.2)
12       actionpack (= 5.2.2)
13       actionview (= 5.2.2)
14       activejob (= 5.2.2)
15       mail (~> 2.5, >= 2.5.4)
16       rails-dom-testing (~> 2.0)
17     actionpack (5.2.2)
18       actionview (= 5.2.2)
19       activesupport (= 5.2.2)
20       rack (~> 2.0)
21       rack-test (>= 0.6.3)
22       rails-dom-testing (~> 2.0)
23       rails-html-sanitizer (~> 1.0, >= 1.0.2)
24     actionpack-page_caching (1.1.1)
25       actionpack (>= 4.0.0, < 6)
26     actionview (5.2.2)
27       activesupport (= 5.2.2)
28       builder (~> 3.1)
29       erubi (~> 1.4)
30       rails-dom-testing (~> 2.0)
31       rails-html-sanitizer (~> 1.0, >= 1.0.3)
32     active_record_union (1.3.0)
33       activerecord (>= 4.0)
34     activejob (5.2.2)
35       activesupport (= 5.2.2)
36       globalid (>= 0.3.6)
37     activemodel (5.2.2)
38       activesupport (= 5.2.2)
39     activerecord (5.2.2)
40       activemodel (= 5.2.2)
41       activesupport (= 5.2.2)
42       arel (>= 9.0)
43     activestorage (5.2.2)
44       actionpack (= 5.2.2)
45       activerecord (= 5.2.2)
46       marcel (~> 0.3.1)
47     activesupport (5.2.2)
48       concurrent-ruby (~> 1.0, >= 1.0.2)
49       i18n (>= 0.7, < 2)
50       minitest (~> 5.1)
51       tzinfo (~> 1.1)
52     addressable (2.5.2)
53       public_suffix (>= 2.0.2, < 4.0)
54     annotate (2.7.4)
55       activerecord (>= 3.2, < 6.0)
56       rake (>= 10.4, < 13.0)
57     arel (9.0.0)
58     ast (2.4.0)
59     autoprefixer-rails (8.6.5)
60       execjs
61     better_errors (2.5.0)
62       coderay (>= 1.0.0)
63       erubi (>= 1.0.0)
64       rack (>= 0.9.0)
65     bigdecimal (1.1.0)
66     binding_of_caller (0.8.0)
67       debug_inspector (>= 0.0.1)
68     bootsnap (1.3.2)
69       msgpack (~> 1.0)
70     builder (3.2.3)
71     cancancan (2.3.0)
72     canonical-rails (0.2.4)
73       rails (>= 4.1, < 5.3)
74     capybara (2.18.0)
75       addressable
76       mini_mime (>= 0.1.3)
77       nokogiri (>= 1.3.3)
78       rack (>= 1.0.0)
79       rack-test (>= 0.5.4)
80       xpath (>= 2.0, < 4.0)
81     climate_control (0.2.0)
82     cliver (0.3.2)
83     coderay (1.1.2)
84     coffee-rails (4.2.2)
85       coffee-script (>= 2.2.0)
86       railties (>= 4.0.0)
87     coffee-script (2.4.1)
88       coffee-script-source
89       execjs
90     coffee-script-source (1.12.2)
91     composite_primary_keys (11.1.0)
92       activerecord (~> 5.2.1)
93     concurrent-ruby (1.1.4)
94     coveralls (0.8.22)
95       json (>= 1.8, < 3)
96       simplecov (~> 0.16.1)
97       term-ansicolor (~> 1.3)
98       thor (~> 0.19.4)
99       tins (~> 1.6)
100     crack (0.4.3)
101       safe_yaml (~> 1.0.0)
102     crass (1.0.4)
103     dalli (2.7.9)
104     debug_inspector (0.0.3)
105     delayed_job (4.1.5)
106       activesupport (>= 3.0, < 5.3)
107     delayed_job_active_record (4.1.3)
108       activerecord (>= 3.0, < 5.3)
109       delayed_job (>= 3.0, < 5)
110     docile (1.3.1)
111     dynamic_form (1.1.4)
112     erubi (1.8.0)
113     execjs (2.7.0)
114     exifr (1.3.5)
115     factory_bot (4.11.1)
116       activesupport (>= 3.0.0)
117     factory_bot_rails (4.11.1)
118       factory_bot (~> 4.11.1)
119       railties (>= 3.0.0)
120     faraday (0.15.4)
121       multipart-post (>= 1.2, < 3)
122     ffi (1.9.25)
123     fspath (3.1.0)
124     geoip (1.6.4)
125     globalid (0.4.1)
126       activesupport (>= 4.2.0)
127     hashdiff (0.3.8)
128     hashie (3.6.0)
129     htmlentities (4.3.4)
130     http_accept_language (2.0.5)
131     i18n (0.9.5)
132       concurrent-ruby (~> 1.0)
133     i18n-js (3.2.0)
134       i18n (>= 0.8.0, < 2)
135     image_optim (0.26.3)
136       exifr (~> 1.2, >= 1.2.2)
137       fspath (~> 3.0)
138       image_size (>= 1.5, < 3)
139       in_threads (~> 1.3)
140       progress (~> 3.0, >= 3.0.1)
141     image_optim_rails (0.4.1)
142       image_optim (~> 0.24)
143       rails
144       sprockets
145     image_size (2.0.0)
146     in_threads (1.5.1)
147     jaro_winkler (1.5.2)
148     jquery-rails (4.3.3)
149       rails-dom-testing (>= 1, < 3)
150       railties (>= 4.2.0)
151       thor (>= 0.14, < 2.0)
152     jshint (1.5.0)
153       execjs (>= 1.4.0)
154       multi_json (~> 1.0)
155       therubyracer (~> 0.12.1)
156     json (2.1.0)
157     jsonify (0.3.1)
158       multi_json (~> 1.0)
159     jsonify-rails (0.3.2)
160       actionpack
161       jsonify (< 0.4.0)
162     jwt (2.1.0)
163     kgio (2.11.2)
164     kramdown (1.17.0)
165     libv8 (3.16.14.19)
166     libxml-ruby (3.1.0)
167     listen (3.1.5)
168       rb-fsevent (~> 0.9, >= 0.9.4)
169       rb-inotify (~> 0.9, >= 0.9.7)
170       ruby_dep (~> 1.2)
171     logstash-event (1.2.02)
172     logstasher (1.3.0)
173       activesupport (>= 4.0)
174       logstash-event (~> 1.2.0)
175       request_store
176     loofah (2.2.3)
177       crass (~> 1.0.2)
178       nokogiri (>= 1.5.9)
179     mail (2.7.1)
180       mini_mime (>= 0.1.1)
181     marcel (0.3.3)
182       mimemagic (~> 0.3.2)
183     method_source (0.9.2)
184     mime-types (3.2.2)
185       mime-types-data (~> 3.2015)
186     mime-types-data (3.2018.0812)
187     mimemagic (0.3.3)
188     mini_mime (1.0.1)
189     mini_portile2 (2.4.0)
190     minitest (5.11.3)
191     msgpack (1.2.6)
192     multi_json (1.13.1)
193     multi_xml (0.6.0)
194     multipart-post (2.0.0)
195     nio4r (2.3.1)
196     nokogiri (1.10.0)
197       mini_portile2 (~> 2.4.0)
198     nokogumbo (2.0.1)
199       nokogiri (~> 1.8, >= 1.8.4)
200     oauth (0.4.7)
201     oauth-plugin (0.5.1)
202       multi_json
203       oauth (~> 0.4.4)
204       oauth2 (>= 0.5.0)
205       rack
206     oauth2 (1.4.1)
207       faraday (>= 0.8, < 0.16.0)
208       jwt (>= 1.0, < 3.0)
209       multi_json (~> 1.3)
210       multi_xml (~> 0.5)
211       rack (>= 1.2, < 3)
212     omniauth (1.9.0)
213       hashie (>= 3.4.6, < 3.7.0)
214       rack (>= 1.6.2, < 3)
215     omniauth-facebook (5.0.0)
216       omniauth-oauth2 (~> 1.2)
217     omniauth-github (1.3.0)
218       omniauth (~> 1.5)
219       omniauth-oauth2 (>= 1.4.0, < 2.0)
220     omniauth-google-oauth2 (0.6.0)
221       jwt (>= 2.0)
222       omniauth (>= 1.1.1)
223       omniauth-oauth2 (>= 1.5)
224     omniauth-mediawiki (0.0.4)
225       jwt (~> 2.0)
226       omniauth-oauth (~> 1.0)
227     omniauth-oauth (1.1.0)
228       oauth
229       omniauth (~> 1.0)
230     omniauth-oauth2 (1.6.0)
231       oauth2 (~> 1.1)
232       omniauth (~> 1.9)
233     omniauth-openid (1.0.1)
234       omniauth (~> 1.0)
235       rack-openid (~> 1.3.1)
236     omniauth-windowslive (0.0.12)
237       multi_json (~> 1.12)
238       omniauth-oauth2 (~> 1.4)
239     openstreetmap-deadlock_retry (1.3.0)
240     paperclip (5.3.0)
241       activemodel (>= 4.2.0)
242       activesupport (>= 4.2.0)
243       mime-types
244       mimemagic (~> 0.3.0)
245       terrapin (~> 0.6.0)
246     parallel (1.12.1)
247     parser (2.5.3.0)
248       ast (~> 2.4.0)
249     pg (0.21.0)
250     poltergeist (1.18.1)
251       capybara (>= 2.1, < 4)
252       cliver (~> 0.3.1)
253       websocket-driver (>= 0.2.0)
254     powerpack (0.1.2)
255     progress (3.5.0)
256     psych (3.1.0)
257     public_suffix (3.0.3)
258     puma (3.12.0)
259     quad_tile (1.0.1)
260     r2 (0.2.7)
261     rack (2.0.6)
262     rack-cors (1.0.2)
263     rack-openid (1.3.1)
264       rack (>= 1.1.0)
265       ruby-openid (>= 2.1.8)
266     rack-test (1.1.0)
267       rack (>= 1.0, < 3)
268     rack-uri_sanitizer (0.0.2)
269     rails (5.2.2)
270       actioncable (= 5.2.2)
271       actionmailer (= 5.2.2)
272       actionpack (= 5.2.2)
273       actionview (= 5.2.2)
274       activejob (= 5.2.2)
275       activemodel (= 5.2.2)
276       activerecord (= 5.2.2)
277       activestorage (= 5.2.2)
278       activesupport (= 5.2.2)
279       bundler (>= 1.3.0)
280       railties (= 5.2.2)
281       sprockets-rails (>= 2.0.0)
282     rails-controller-testing (1.0.4)
283       actionpack (>= 5.0.1.x)
284       actionview (>= 5.0.1.x)
285       activesupport (>= 5.0.1.x)
286     rails-dom-testing (2.0.3)
287       activesupport (>= 4.2.0)
288       nokogiri (>= 1.6)
289     rails-html-sanitizer (1.0.4)
290       loofah (~> 2.2, >= 2.2.2)
291     rails-i18n (4.0.2)
292       i18n (~> 0.6)
293       rails (>= 4.0)
294     railties (5.2.2)
295       actionpack (= 5.2.2)
296       activesupport (= 5.2.2)
297       method_source
298       rake (>= 0.8.7)
299       thor (>= 0.19.0, < 2.0)
300     rainbow (3.0.0)
301     rake (12.3.2)
302     rb-fsevent (0.10.3)
303     rb-inotify (0.10.0)
304       ffi (~> 1.0)
305     record_tag_helper (1.0.0)
306       actionview (~> 5.x)
307     ref (2.0.0)
308     request_store (1.4.1)
309       rack (>= 1.4)
310     rinku (2.0.4)
311     rotp (4.0.2)
312       addressable (~> 2.5)
313     rubocop (0.62.0)
314       jaro_winkler (~> 1.5.1)
315       parallel (~> 1.10)
316       parser (>= 2.5, != 2.5.1.1)
317       powerpack (~> 0.1)
318       rainbow (>= 2.2.2, < 4.0)
319       ruby-progressbar (~> 1.7)
320       unicode-display_width (~> 1.4.0)
321     ruby-openid (2.7.0)
322     ruby-progressbar (1.10.0)
323     ruby_dep (1.5.0)
324     safe_yaml (1.0.4)
325     sanitize (5.0.0)
326       crass (~> 1.0.2)
327       nokogiri (>= 1.8.0)
328       nokogumbo (~> 2.0)
329     sassc (2.0.0)
330       ffi (~> 1.9.6)
331       rake
332     sassc-rails (2.1.0)
333       railties (>= 4.0.0)
334       sassc (>= 2.0)
335       sprockets (> 3.0)
336       sprockets-rails
337       tilt
338     secure_headers (6.0.0)
339     simplecov (0.16.1)
340       docile (~> 1.1)
341       json (>= 1.8, < 3)
342       simplecov-html (~> 0.10.0)
343     simplecov-html (0.10.2)
344     sprockets (3.7.2)
345       concurrent-ruby (~> 1.0)
346       rack (> 1, < 3)
347     sprockets-rails (3.2.1)
348       actionpack (>= 4.0)
349       activesupport (>= 4.0)
350       sprockets (>= 3.0.0)
351     term-ansicolor (1.7.0)
352       tins (~> 1.0)
353     terrapin (0.6.0)
354       climate_control (>= 0.0.3, < 1.0)
355     therubyracer (0.12.3)
356       libv8 (~> 3.16.14.15)
357       ref
358     thor (0.19.4)
359     thread_safe (0.3.6)
360     tilt (2.0.9)
361     tins (1.20.2)
362     tzinfo (1.2.5)
363       thread_safe (~> 0.1)
364     uglifier (4.1.20)
365       execjs (>= 0.3.0, < 3)
366     unicode-display_width (1.4.1)
367     validates_email_format_of (1.6.3)
368       i18n
369     vendorer (0.2.0)
370     webmock (3.5.1)
371       addressable (>= 2.3.6)
372       crack (>= 0.3.2)
373       hashdiff
374     websocket-driver (0.7.0)
375       websocket-extensions (>= 0.1.0)
376     websocket-extensions (0.1.3)
377     xpath (3.2.0)
378       nokogiri (~> 1.8)
379
380 PLATFORMS
381   ruby
382
383 DEPENDENCIES
384   SystemTimer (>= 1.1.3)
385   aasm
386   actionpack-page_caching
387   active_record_union
388   annotate
389   autoprefixer-rails (~> 8.6.3)
390   better_errors
391   bigdecimal (~> 1.1.0)
392   binding_of_caller
393   bootsnap (>= 1.1.0)
394   cancancan
395   canonical-rails
396   capybara (~> 2.13)
397   coffee-rails (~> 4.2)
398   composite_primary_keys (~> 11.1.0)
399   coveralls
400   dalli
401   delayed_job_active_record
402   dynamic_form
403   factory_bot_rails
404   faraday
405   geoip
406   htmlentities
407   http_accept_language (~> 2.0.0)
408   i18n-js (>= 3.0.0)
409   image_optim_rails
410   jquery-rails
411   jshint
412   json
413   jsonify-rails
414   kgio
415   kramdown
416   libxml-ruby (>= 2.0.5)
417   listen
418   logstasher
419   minitest (~> 5.1)
420   oauth-plugin (>= 0.5.1)
421   omniauth
422   omniauth-facebook
423   omniauth-github
424   omniauth-google-oauth2 (>= 0.6.0)
425   omniauth-mediawiki (>= 0.0.4)
426   omniauth-openid
427   omniauth-windowslive
428   openstreetmap-deadlock_retry (>= 1.3.0)
429   paperclip (~> 5.2)
430   pg (~> 0.18)
431   poltergeist
432   psych
433   puma (~> 3.7)
434   quad_tile (~> 1.0.1)
435   r2 (~> 0.2.7)
436   rack-cors
437   rack-uri_sanitizer
438   rails (= 5.2.2)
439   rails-controller-testing
440   rails-i18n (~> 4.0.0)
441   record_tag_helper
442   rinku (>= 1.2.2)
443   rotp
444   rubocop
445   sanitize
446   sassc-rails
447   secure_headers
448   uglifier (>= 1.3.0)
449   validates_email_format_of (>= 1.5.1)
450   vendorer
451   webmock
452
453 BUNDLED WITH
454    1.16.2