Merge branch 'master' into moderation
[rails.git] / Gemfile.lock
1 GEM
2   remote: https://rubygems.org/
3   specs:
4     SystemTimer (1.2.3)
5     aasm (4.1.0)
6     actioncable (5.1.4)
7       actionpack (= 5.1.4)
8       nio4r (~> 2.0)
9       websocket-driver (~> 0.6.1)
10     actionmailer (5.1.4)
11       actionpack (= 5.1.4)
12       actionview (= 5.1.4)
13       activejob (= 5.1.4)
14       mail (~> 2.5, >= 2.5.4)
15       rails-dom-testing (~> 2.0)
16     actionpack (5.1.4)
17       actionview (= 5.1.4)
18       activesupport (= 5.1.4)
19       rack (~> 2.0)
20       rack-test (>= 0.6.3)
21       rails-dom-testing (~> 2.0)
22       rails-html-sanitizer (~> 1.0, >= 1.0.2)
23     actionpack-page_caching (1.1.0)
24       actionpack (>= 4.0.0, < 6)
25     actionview (5.1.4)
26       activesupport (= 5.1.4)
27       builder (~> 3.1)
28       erubi (~> 1.4)
29       rails-dom-testing (~> 2.0)
30       rails-html-sanitizer (~> 1.0, >= 1.0.3)
31     activejob (5.1.4)
32       activesupport (= 5.1.4)
33       globalid (>= 0.3.6)
34     activemodel (5.1.4)
35       activesupport (= 5.1.4)
36     activerecord (5.1.4)
37       activemodel (= 5.1.4)
38       activesupport (= 5.1.4)
39       arel (~> 8.0)
40     activesupport (5.1.4)
41       concurrent-ruby (~> 1.0, >= 1.0.2)
42       i18n (~> 0.7)
43       minitest (~> 5.1)
44       tzinfo (~> 1.1)
45     addressable (2.5.2)
46       public_suffix (>= 2.0.2, < 4.0)
47     annotate (2.7.2)
48       activerecord (>= 3.2, < 6.0)
49       rake (>= 10.4, < 13.0)
50     arel (8.0.0)
51     ast (2.3.0)
52     autoprefixer-rails (7.1.6)
53       execjs
54     bigdecimal (1.1.0)
55     builder (3.2.3)
56     canonical-rails (0.2.1)
57       rails (>= 4.1, < 5.2)
58     capybara (2.15.4)
59       addressable
60       mini_mime (>= 0.1.3)
61       nokogiri (>= 1.3.3)
62       rack (>= 1.0.0)
63       rack-test (>= 0.5.4)
64       xpath (~> 2.0)
65     climate_control (0.2.0)
66     cliver (0.3.2)
67     cocaine (0.5.8)
68       climate_control (>= 0.0.3, < 1.0)
69     coffee-rails (4.2.2)
70       coffee-script (>= 2.2.0)
71       railties (>= 4.0.0)
72     coffee-script (2.4.1)
73       coffee-script-source
74       execjs
75     coffee-script-source (1.12.2)
76     composite_primary_keys (10.0.1)
77       activerecord (~> 5.1.0)
78     concurrent-ruby (1.0.5)
79     coveralls (0.8.21)
80       json (>= 1.8, < 3)
81       simplecov (~> 0.14.1)
82       term-ansicolor (~> 1.3)
83       thor (~> 0.19.4)
84       tins (~> 1.6)
85     crack (0.4.3)
86       safe_yaml (~> 1.0.0)
87     crass (1.0.2)
88     dalli (2.7.6)
89     docile (1.1.5)
90     dynamic_form (1.1.4)
91     erubi (1.7.0)
92     execjs (2.7.0)
93     exifr (1.3.2)
94     factory_bot (4.8.2)
95       activesupport (>= 3.0.0)
96     factory_bot_rails (4.8.2)
97       factory_bot (~> 4.8.2)
98       railties (>= 3.0.0)
99     faraday (0.12.2)
100       multipart-post (>= 1.2, < 3)
101     ffi (1.9.18)
102     fspath (3.1.0)
103     geoip (1.6.3)
104     globalid (0.4.1)
105       activesupport (>= 4.2.0)
106     hashdiff (0.3.7)
107     hashie (3.5.6)
108     htmlentities (4.3.4)
109     http_accept_language (2.0.5)
110     i18n (0.9.0)
111       concurrent-ruby (~> 1.0)
112     i18n-js (3.0.2)
113       i18n (~> 0.6, >= 0.6.6)
114     image_optim (0.25.0)
115       exifr (~> 1.2, >= 1.2.2)
116       fspath (~> 3.0)
117       image_size (~> 1.5)
118       in_threads (~> 1.3)
119       progress (~> 3.0, >= 3.0.1)
120     image_optim_rails (0.4.1)
121       image_optim (~> 0.24)
122       rails
123       sprockets
124     image_size (1.5.0)
125     in_threads (1.4.0)
126     jquery-rails (4.3.1)
127       rails-dom-testing (>= 1, < 3)
128       railties (>= 4.2.0)
129       thor (>= 0.14, < 2.0)
130     jshint (1.5.0)
131       execjs (>= 1.4.0)
132       multi_json (~> 1.0)
133       therubyracer (~> 0.12.1)
134     json (2.1.0)
135     jsonify (0.3.1)
136       multi_json (~> 1.0)
137     jsonify-rails (0.3.2)
138       actionpack
139       jsonify (< 0.4.0)
140     jwt (1.5.6)
141     kgio (2.11.0)
142     libv8 (3.16.14.19)
143     libxml-ruby (3.0.0)
144     listen (3.1.5)
145       rb-fsevent (~> 0.9, >= 0.9.4)
146       rb-inotify (~> 0.9, >= 0.9.7)
147       ruby_dep (~> 1.2)
148     logstash-event (1.2.02)
149     logstasher (1.2.2)
150       activesupport (>= 4.0)
151       logstash-event (~> 1.2.0)
152       request_store
153     loofah (2.1.1)
154       crass (~> 1.0.2)
155       nokogiri (>= 1.5.9)
156     mail (2.6.6)
157       mime-types (>= 1.16, < 4)
158     method_source (0.9.0)
159     mime-types (3.1)
160       mime-types-data (~> 3.2015)
161     mime-types-data (3.2016.0521)
162     mimemagic (0.3.0)
163     mini_mime (0.1.4)
164     mini_portile2 (2.3.0)
165     minitest (5.10.3)
166     minitest-capybara (0.8.2)
167       capybara (~> 2.2)
168       minitest (~> 5.0)
169       rake
170     minitest-metadata (0.6.0)
171       minitest (>= 4.7, < 6.0)
172     minitest-rails (3.0.0)
173       minitest (~> 5.8)
174       railties (~> 5.0)
175     minitest-rails-capybara (3.0.1)
176       capybara (~> 2.7)
177       minitest-capybara (~> 0.8)
178       minitest-metadata (~> 0.6)
179       minitest-rails (~> 3.0)
180     multi_json (1.12.2)
181     multi_xml (0.6.0)
182     multipart-post (2.0.0)
183     nio4r (2.1.0)
184     nokogiri (1.8.1)
185       mini_portile2 (~> 2.3.0)
186     nokogumbo (1.4.13)
187       nokogiri
188     oauth (0.4.7)
189     oauth-plugin (0.5.1)
190       multi_json
191       oauth (~> 0.4.4)
192       oauth2 (>= 0.5.0)
193       rack
194     oauth2 (1.4.0)
195       faraday (>= 0.8, < 0.13)
196       jwt (~> 1.0)
197       multi_json (~> 1.3)
198       multi_xml (~> 0.5)
199       rack (>= 1.2, < 3)
200     omniauth (1.7.1)
201       hashie (>= 3.4.6, < 3.6.0)
202       rack (>= 1.6.2, < 3)
203     omniauth-facebook (4.0.0)
204       omniauth-oauth2 (~> 1.2)
205     omniauth-github (1.3.0)
206       omniauth (~> 1.5)
207       omniauth-oauth2 (>= 1.4.0, < 2.0)
208     omniauth-google-oauth2 (0.5.2)
209       jwt (~> 1.5)
210       multi_json (~> 1.3)
211       omniauth (>= 1.1.1)
212       omniauth-oauth2 (>= 1.3.1)
213     omniauth-mediawiki (0.0.3)
214       jwt (~> 1.0)
215       omniauth-oauth (~> 1.0)
216     omniauth-oauth (1.1.0)
217       oauth
218       omniauth (~> 1.0)
219     omniauth-oauth2 (1.4.0)
220       oauth2 (~> 1.0)
221       omniauth (~> 1.2)
222     omniauth-openid (1.0.1)
223       omniauth (~> 1.0)
224       rack-openid (~> 1.3.1)
225     omniauth-windowslive (0.0.12)
226       multi_json (~> 1.12)
227       omniauth-oauth2 (~> 1.4)
228     openstreetmap-deadlock_retry (1.3.0)
229     paperclip (4.3.7)
230       activemodel (>= 3.2.0)
231       activesupport (>= 3.2.0)
232       cocaine (~> 0.5.5)
233       mime-types
234       mimemagic (= 0.3.0)
235     parallel (1.12.0)
236     parser (2.4.0.0)
237       ast (~> 2.2)
238     pg (0.21.0)
239     poltergeist (1.16.0)
240       capybara (~> 2.1)
241       cliver (~> 0.3.1)
242       websocket-driver (>= 0.2.0)
243     powerpack (0.1.1)
244     progress (3.4.0)
245     psych (2.2.4)
246     public_suffix (3.0.0)
247     puma (3.10.0)
248     r2 (0.2.7)
249     rack (2.0.3)
250     rack-cors (1.0.2)
251     rack-openid (1.3.1)
252       rack (>= 1.1.0)
253       ruby-openid (>= 2.1.8)
254     rack-test (0.7.0)
255       rack (>= 1.0, < 3)
256     rack-uri_sanitizer (0.0.2)
257     rails (5.1.4)
258       actioncable (= 5.1.4)
259       actionmailer (= 5.1.4)
260       actionpack (= 5.1.4)
261       actionview (= 5.1.4)
262       activejob (= 5.1.4)
263       activemodel (= 5.1.4)
264       activerecord (= 5.1.4)
265       activesupport (= 5.1.4)
266       bundler (>= 1.3.0)
267       railties (= 5.1.4)
268       sprockets-rails (>= 2.0.0)
269     rails-controller-testing (1.0.2)
270       actionpack (~> 5.x, >= 5.0.1)
271       actionview (~> 5.x, >= 5.0.1)
272       activesupport (~> 5.x)
273     rails-dom-testing (2.0.3)
274       activesupport (>= 4.2.0)
275       nokogiri (>= 1.6)
276     rails-html-sanitizer (1.0.3)
277       loofah (~> 2.0)
278     rails-i18n (4.0.2)
279       i18n (~> 0.6)
280       rails (>= 4.0)
281     railties (5.1.4)
282       actionpack (= 5.1.4)
283       activesupport (= 5.1.4)
284       method_source
285       rake (>= 0.8.7)
286       thor (>= 0.18.1, < 2.0)
287     rainbow (2.2.2)
288       rake
289     rake (12.2.1)
290     rb-fsevent (0.10.2)
291     rb-inotify (0.9.10)
292       ffi (>= 0.5.0, < 2)
293     record_tag_helper (1.0.0)
294       actionview (~> 5.x)
295     redcarpet (3.4.0)
296     ref (2.0.0)
297     request_store (1.3.2)
298     rinku (2.0.3)
299     rotp (3.3.0)
300     rubocop (0.51.0)
301       parallel (~> 1.10)
302       parser (>= 2.3.3.1, < 3.0)
303       powerpack (~> 0.1)
304       rainbow (>= 2.2.2, < 3.0)
305       ruby-progressbar (~> 1.7)
306       unicode-display_width (~> 1.0, >= 1.0.1)
307     ruby-openid (2.7.0)
308     ruby-progressbar (1.9.0)
309     ruby_dep (1.5.0)
310     safe_yaml (1.0.4)
311     sanitize (4.5.0)
312       crass (~> 1.0.2)
313       nokogiri (>= 1.4.4)
314       nokogumbo (~> 1.4.1)
315     sass (3.5.3)
316       sass-listen (~> 4.0.0)
317     sass-listen (4.0.0)
318       rb-fsevent (~> 0.9, >= 0.9.4)
319       rb-inotify (~> 0.9, >= 0.9.7)
320     sass-rails (5.0.6)
321       railties (>= 4.0.0, < 6)
322       sass (~> 3.1)
323       sprockets (>= 2.8, < 4.0)
324       sprockets-rails (>= 2.0, < 4.0)
325       tilt (>= 1.1, < 3)
326     secure_headers (5.0.1)
327       useragent (>= 0.15.0)
328     simplecov (0.14.1)
329       docile (~> 1.1.0)
330       json (>= 1.8, < 3)
331       simplecov-html (~> 0.10.0)
332     simplecov-html (0.10.2)
333     sprockets (3.7.1)
334       concurrent-ruby (~> 1.0)
335       rack (> 1, < 3)
336     sprockets-rails (3.2.1)
337       actionpack (>= 4.0)
338       activesupport (>= 4.0)
339       sprockets (>= 3.0.0)
340     term-ansicolor (1.6.0)
341       tins (~> 1.0)
342     therubyracer (0.12.3)
343       libv8 (~> 3.16.14.15)
344       ref
345     thor (0.19.4)
346     thread_safe (0.3.6)
347     tilt (2.0.8)
348     tins (1.15.0)
349     tzinfo (1.2.4)
350       thread_safe (~> 0.1)
351     uglifier (3.2.0)
352       execjs (>= 0.3.0, < 3)
353     unicode-display_width (1.3.0)
354     useragent (0.16.8)
355     validates_email_format_of (1.6.3)
356       i18n
357     vendorer (0.1.16)
358     webmock (3.1.0)
359       addressable (>= 2.3.6)
360       crack (>= 0.3.2)
361       hashdiff
362     websocket-driver (0.6.5)
363       websocket-extensions (>= 0.1.0)
364     websocket-extensions (0.1.2)
365     xpath (2.1.0)
366       nokogiri (~> 1.3)
367
368 PLATFORMS
369   ruby
370
371 DEPENDENCIES
372   SystemTimer (>= 1.1.3)
373   aasm
374   actionpack-page_caching
375   annotate
376   autoprefixer-rails
377   bigdecimal (~> 1.1.0)
378   canonical-rails
379   capybara (~> 2.13)
380   coffee-rails (~> 4.2)
381   composite_primary_keys (~> 10.0.0)
382   coveralls
383   dalli
384   dynamic_form
385   factory_bot_rails
386   faraday
387   geoip
388   htmlentities
389   http_accept_language (~> 2.0.0)
390   i18n-js (>= 3.0.0)
391   image_optim_rails
392   jquery-rails
393   jshint
394   json
395   jsonify-rails
396   kgio
397   libxml-ruby (>= 2.0.5)
398   listen
399   logstasher
400   minitest (~> 5.1)
401   minitest-rails-capybara
402   oauth-plugin (>= 0.5.1)
403   omniauth
404   omniauth-facebook
405   omniauth-github
406   omniauth-google-oauth2 (>= 0.2.7)
407   omniauth-mediawiki (>= 0.0.3)
408   omniauth-openid
409   omniauth-windowslive
410   openstreetmap-deadlock_retry (>= 1.3.0)
411   paperclip (~> 4.0)
412   pg
413   poltergeist
414   psych
415   puma (~> 3.7)
416   r2 (~> 0.2.7)
417   rack-cors
418   rack-uri_sanitizer
419   rails (= 5.1.4)
420   rails-controller-testing
421   rails-i18n (~> 4.0.0)
422   record_tag_helper
423   redcarpet
424   rinku (>= 1.2.2)
425   rotp
426   rubocop
427   sanitize
428   sass-rails (~> 5.0)
429   secure_headers
430   uglifier (>= 1.3.0)
431   validates_email_format_of (>= 1.5.1)
432   vendorer
433   webmock
434
435 BUNDLED WITH
436    1.15.4