Update to rails 5.1.6
[rails.git] / Gemfile.lock
index 03b0331..6ee99f7 100644 (file)
@@ -2,121 +2,136 @@ GEM
   remote: https://rubygems.org/
   specs:
     SystemTimer (1.2.3)
-    actionmailer (4.2.8)
-      actionpack (= 4.2.8)
-      actionview (= 4.2.8)
-      activejob (= 4.2.8)
+    aasm (4.12.3)
+      concurrent-ruby (~> 1.0)
+    actioncable (5.1.6)
+      actionpack (= 5.1.6)
+      nio4r (~> 2.0)
+      websocket-driver (~> 0.6.1)
+    actionmailer (5.1.6)
+      actionpack (= 5.1.6)
+      actionview (= 5.1.6)
+      activejob (= 5.1.6)
       mail (~> 2.5, >= 2.5.4)
-      rails-dom-testing (~> 1.0, >= 1.0.5)
-    actionpack (4.2.8)
-      actionview (= 4.2.8)
-      activesupport (= 4.2.8)
-      rack (~> 1.6)
-      rack-test (~> 0.6.2)
-      rails-dom-testing (~> 1.0, >= 1.0.5)
+      rails-dom-testing (~> 2.0)
+    actionpack (5.1.6)
+      actionview (= 5.1.6)
+      activesupport (= 5.1.6)
+      rack (~> 2.0)
+      rack-test (>= 0.6.3)
+      rails-dom-testing (~> 2.0)
       rails-html-sanitizer (~> 1.0, >= 1.0.2)
     actionpack-page_caching (1.1.0)
       actionpack (>= 4.0.0, < 6)
-    actionview (4.2.8)
-      activesupport (= 4.2.8)
+    actionview (5.1.6)
+      activesupport (= 5.1.6)
       builder (~> 3.1)
-      erubis (~> 2.7.0)
-      rails-dom-testing (~> 1.0, >= 1.0.5)
+      erubi (~> 1.4)
+      rails-dom-testing (~> 2.0)
       rails-html-sanitizer (~> 1.0, >= 1.0.3)
-    activejob (4.2.8)
-      activesupport (= 4.2.8)
-      globalid (>= 0.3.0)
-    activemodel (4.2.8)
-      activesupport (= 4.2.8)
-      builder (~> 3.1)
-    activerecord (4.2.8)
-      activemodel (= 4.2.8)
-      activesupport (= 4.2.8)
-      arel (~> 6.0)
-    activesupport (4.2.8)
-      i18n (~> 0.7)
+    activejob (5.1.6)
+      activesupport (= 5.1.6)
+      globalid (>= 0.3.6)
+    activemodel (5.1.6)
+      activesupport (= 5.1.6)
+    activerecord (5.1.6)
+      activemodel (= 5.1.6)
+      activesupport (= 5.1.6)
+      arel (~> 8.0)
+    activesupport (5.1.6)
+      concurrent-ruby (~> 1.0, >= 1.0.2)
+      i18n (>= 0.7, < 2)
       minitest (~> 5.1)
-      thread_safe (~> 0.3, >= 0.3.4)
       tzinfo (~> 1.1)
-    addressable (2.5.0)
-      public_suffix (~> 2.0, >= 2.0.2)
-    arel (6.0.4)
-    ast (2.3.0)
-    autoprefixer-rails (6.7.7.1)
+    addressable (2.5.2)
+      public_suffix (>= 2.0.2, < 4.0)
+    annotate (2.7.4)
+      activerecord (>= 3.2, < 6.0)
+      rake (>= 10.4, < 13.0)
+    arel (8.0.0)
+    ast (2.4.0)
+    autoprefixer-rails (8.6.2)
       execjs
+    better_errors (2.4.0)
+      coderay (>= 1.0.0)
+      erubi (>= 1.0.0)
+      rack (>= 0.9.0)
     bigdecimal (1.1.0)
+    binding_of_caller (0.8.0)
+      debug_inspector (>= 0.0.1)
     builder (3.2.3)
-    canonical-rails (0.1.2)
-      rails (>= 4.1, < 5.1)
-    capybara (2.13.0)
+    canonical-rails (0.2.3)
+      rails (>= 4.1, < 5.3)
+    capybara (2.18.0)
       addressable
-      mime-types (>= 1.16)
+      mini_mime (>= 0.1.3)
       nokogiri (>= 1.3.3)
       rack (>= 1.0.0)
       rack-test (>= 0.5.4)
-      xpath (~> 2.0)
-    climate_control (0.1.0)
+      xpath (>= 2.0, < 4.0)
+    climate_control (0.2.0)
     cliver (0.3.2)
-    cocaine (0.5.8)
-      climate_control (>= 0.0.3, < 1.0)
-    coffee-rails (4.1.1)
+    coderay (1.1.2)
+    coffee-rails (4.2.2)
       coffee-script (>= 2.2.0)
-      railties (>= 4.0.0, < 5.1.x)
+      railties (>= 4.0.0)
     coffee-script (2.4.1)
       coffee-script-source
       execjs
     coffee-script-source (1.12.2)
-    colorize (0.8.1)
-    composite_primary_keys (8.1.4)
-      activerecord (~> 4.2.0)
+    composite_primary_keys (10.0.4)
+      activerecord (~> 5.1.0, >= 5.1.6)
     concurrent-ruby (1.0.5)
-    coveralls (0.8.19)
+    coveralls (0.8.21)
       json (>= 1.8, < 3)
-      simplecov (~> 0.12.0)
+      simplecov (~> 0.14.1)
       term-ansicolor (~> 1.3)
-      thor (~> 0.19.1)
+      thor (~> 0.19.4)
       tins (~> 1.6)
     crack (0.4.3)
       safe_yaml (~> 1.0.0)
-    crass (1.0.2)
-    dalli (2.7.6)
-    deadlock_retry (1.2.0)
+    crass (1.0.4)
+    dalli (2.7.8)
+    debug_inspector (0.0.3)
     docile (1.1.5)
     dynamic_form (1.1.4)
-    erubis (2.7.0)
+    erubi (1.7.1)
     execjs (2.7.0)
-    exifr (1.2.5)
-    factory_girl (4.8.0)
+    exifr (1.3.4)
+    factory_bot (4.10.0)
       activesupport (>= 3.0.0)
-    factory_girl_rails (4.8.0)
-      factory_girl (~> 4.8.0)
+    factory_bot_rails (4.10.0)
+      factory_bot (~> 4.10.0)
       railties (>= 3.0.0)
-    faraday (0.11.0)
+    faraday (0.12.2)
       multipart-post (>= 1.2, < 3)
+    ffi (1.9.25)
     fspath (3.1.0)
-    geoip (1.6.3)
-    globalid (0.3.7)
-      activesupport (>= 4.1.0)
-    hashdiff (0.3.2)
-    hashie (3.5.5)
+    geoip (1.6.4)
+    globalid (0.4.1)
+      activesupport (>= 4.2.0)
+    hashdiff (0.3.7)
+    hashie (3.5.7)
     htmlentities (4.3.4)
     http_accept_language (2.0.5)
-    i18n (0.8.1)
-    i18n-js (3.0.0.rc16)
-      i18n (~> 0.6, >= 0.6.6)
-    image_optim (0.24.2)
+    i18n (0.9.5)
+      concurrent-ruby (~> 1.0)
+    i18n-js (3.0.8)
+      i18n (>= 0.6.6, < 2)
+    image_optim (0.26.1)
       exifr (~> 1.2, >= 1.2.2)
       fspath (~> 3.0)
       image_size (~> 1.5)
       in_threads (~> 1.3)
       progress (~> 3.0, >= 3.0.1)
-    image_optim_rails (0.3.0)
-      image_optim (~> 0.24.0)
+    image_optim_rails (0.4.1)
+      image_optim (~> 0.24)
       rails
       sprockets
     image_size (1.5.0)
-    in_threads (1.4.0)
-    jquery-rails (4.3.1)
+    in_threads (1.5.0)
+    jaro_winkler (1.5.1)
+    jquery-rails (4.3.3)
       rails-dom-testing (>= 1, < 3)
       railties (>= 4.2.0)
       thor (>= 0.14, < 2.0)
@@ -124,45 +139,45 @@ GEM
       execjs (>= 1.4.0)
       multi_json (~> 1.0)
       therubyracer (~> 0.12.1)
-    json (2.0.3)
+    json (2.1.0)
     jsonify (0.3.1)
       multi_json (~> 1.0)
     jsonify-rails (0.3.2)
       actionpack
       jsonify (< 0.4.0)
     jwt (1.5.6)
-    kgio (2.11.0)
-    konacha (4.0.0)
-      actionpack (>= 4.1, < 5)
-      capybara
-      colorize
-      railties (>= 4.1, < 5)
-      sprockets (>= 2, < 4)
-      sprockets-rails (>= 2, < 4)
-      tilt
+    kgio (2.11.2)
     libv8 (3.16.14.19)
-    libxml-ruby (3.0.0)
+    libxml-ruby (3.1.0)
+    listen (3.1.5)
+      rb-fsevent (~> 0.9, >= 0.9.4)
+      rb-inotify (~> 0.9, >= 0.9.7)
+      ruby_dep (~> 1.2)
     logstash-event (1.2.02)
-    logstasher (1.2.1)
+    logstasher (1.2.2)
       activesupport (>= 4.0)
       logstash-event (~> 1.2.0)
       request_store
-    loofah (2.0.3)
+    loofah (2.2.2)
+      crass (~> 1.0.2)
       nokogiri (>= 1.5.9)
-    mail (2.6.4)
-      mime-types (>= 1.16, < 4)
+    mail (2.7.0)
+      mini_mime (>= 0.1.1)
+    method_source (0.9.0)
     mime-types (3.1)
       mime-types-data (~> 3.2015)
     mime-types-data (3.2016.0521)
-    mimemagic (0.3.0)
-    mini_portile2 (2.1.0)
-    minitest (5.10.1)
-    multi_json (1.12.1)
+    mimemagic (0.3.2)
+    mini_mime (1.0.0)
+    mini_portile2 (2.3.0)
+    minitest (5.11.3)
+    multi_json (1.13.1)
     multi_xml (0.6.0)
     multipart-post (2.0.0)
-    nokogiri (1.7.1)
-      mini_portile2 (~> 2.1.0)
-    nokogumbo (1.4.9)
+    nio4r (2.3.1)
+    nokogiri (1.8.3)
+      mini_portile2 (~> 2.3.0)
+    nokogumbo (1.5.0)
       nokogiri
     oauth (0.4.7)
     oauth-plugin (0.5.1)
@@ -170,33 +185,32 @@ GEM
       oauth (~> 0.4.4)
       oauth2 (>= 0.5.0)
       rack
-    oauth2 (1.3.0)
-      faraday (>= 0.8, < 0.11)
+    oauth2 (1.4.0)
+      faraday (>= 0.8, < 0.13)
       jwt (~> 1.0)
       multi_json (~> 1.3)
       multi_xml (~> 0.5)
       rack (>= 1.2, < 3)
-    omniauth (1.6.1)
+    omniauth (1.8.1)
       hashie (>= 3.4.6, < 3.6.0)
       rack (>= 1.6.2, < 3)
-    omniauth-facebook (4.0.0)
+    omniauth-facebook (5.0.0)
       omniauth-oauth2 (~> 1.2)
-    omniauth-github (1.2.3)
+    omniauth-github (1.3.0)
       omniauth (~> 1.5)
       omniauth-oauth2 (>= 1.4.0, < 2.0)
-    omniauth-google-oauth2 (0.4.1)
-      jwt (~> 1.5.2)
-      multi_json (~> 1.3)
+    omniauth-google-oauth2 (0.5.3)
+      jwt (>= 1.5)
       omniauth (>= 1.1.1)
-      omniauth-oauth2 (>= 1.3.1)
+      omniauth-oauth2 (>= 1.5)
     omniauth-mediawiki (0.0.3)
       jwt (~> 1.0)
       omniauth-oauth (~> 1.0)
     omniauth-oauth (1.1.0)
       oauth
       omniauth (~> 1.0)
-    omniauth-oauth2 (1.4.0)
-      oauth2 (~> 1.0)
+    omniauth-oauth2 (1.5.0)
+      oauth2 (~> 1.1)
       omniauth (~> 1.2)
     omniauth-openid (1.0.1)
       omniauth (~> 1.0)
@@ -204,158 +218,181 @@ GEM
     omniauth-windowslive (0.0.12)
       multi_json (~> 1.12)
       omniauth-oauth2 (~> 1.4)
-    paperclip (4.3.7)
-      activemodel (>= 3.2.0)
-      activesupport (>= 3.2.0)
-      cocaine (~> 0.5.5)
+    openstreetmap-deadlock_retry (1.3.0)
+    paperclip (5.3.0)
+      activemodel (>= 4.2.0)
+      activesupport (>= 4.2.0)
       mime-types
-      mimemagic (= 0.3.0)
-    parser (2.4.0.0)
-      ast (~> 2.2)
-    pg (0.20.0)
-    poltergeist (1.14.0)
-      capybara (~> 2.1)
+      mimemagic (~> 0.3.0)
+      terrapin (~> 0.6.0)
+    parallel (1.12.1)
+    parser (2.5.1.0)
+      ast (~> 2.4.0)
+    pg (0.21.0)
+    poltergeist (1.18.1)
+      capybara (>= 2.1, < 4)
       cliver (~> 0.3.1)
       websocket-driver (>= 0.2.0)
-    powerpack (0.1.1)
-    progress (3.3.1)
-    psych (2.2.4)
-    public_suffix (2.0.5)
-    r2 (0.2.6)
-    rack (1.6.5)
-    rack-cors (0.4.1)
+    powerpack (0.1.2)
+    progress (3.4.0)
+    psych (3.0.2)
+    public_suffix (3.0.2)
+    puma (3.11.4)
+    quad_tile (1.0.1)
+    r2 (0.2.7)
+    rack (2.0.5)
+    rack-cors (1.0.2)
     rack-openid (1.3.1)
       rack (>= 1.1.0)
       ruby-openid (>= 2.1.8)
-    rack-test (0.6.3)
-      rack (>= 1.0)
+    rack-test (1.0.0)
+      rack (>= 1.0, < 3)
     rack-uri_sanitizer (0.0.2)
-    rails (4.2.8)
-      actionmailer (= 4.2.8)
-      actionpack (= 4.2.8)
-      actionview (= 4.2.8)
-      activejob (= 4.2.8)
-      activemodel (= 4.2.8)
-      activerecord (= 4.2.8)
-      activesupport (= 4.2.8)
-      bundler (>= 1.3.0, < 2.0)
-      railties (= 4.2.8)
-      sprockets-rails
-    rails-deprecated_sanitizer (1.0.3)
-      activesupport (>= 4.2.0.alpha)
-    rails-dom-testing (1.0.8)
-      activesupport (>= 4.2.0.beta, < 5.0)
-      nokogiri (~> 1.6)
-      rails-deprecated_sanitizer (>= 1.0.1)
-    rails-html-sanitizer (1.0.3)
-      loofah (~> 2.0)
-    rails-i18n (4.0.9)
-      i18n (~> 0.7)
-      railties (~> 4.0)
-    railties (4.2.8)
-      actionpack (= 4.2.8)
-      activesupport (= 4.2.8)
+    rails (5.1.6)
+      actioncable (= 5.1.6)
+      actionmailer (= 5.1.6)
+      actionpack (= 5.1.6)
+      actionview (= 5.1.6)
+      activejob (= 5.1.6)
+      activemodel (= 5.1.6)
+      activerecord (= 5.1.6)
+      activesupport (= 5.1.6)
+      bundler (>= 1.3.0)
+      railties (= 5.1.6)
+      sprockets-rails (>= 2.0.0)
+    rails-controller-testing (1.0.2)
+      actionpack (~> 5.x, >= 5.0.1)
+      actionview (~> 5.x, >= 5.0.1)
+      activesupport (~> 5.x)
+    rails-dom-testing (2.0.3)
+      activesupport (>= 4.2.0)
+      nokogiri (>= 1.6)
+    rails-html-sanitizer (1.0.4)
+      loofah (~> 2.2, >= 2.2.2)
+    rails-i18n (4.0.2)
+      i18n (~> 0.6)
+      rails (>= 4.0)
+    railties (5.1.6)
+      actionpack (= 5.1.6)
+      activesupport (= 5.1.6)
+      method_source
       rake (>= 0.8.7)
       thor (>= 0.18.1, < 2.0)
-    rainbow (2.2.1)
-    rake (12.0.0)
+    rainbow (3.0.0)
+    rake (12.3.1)
+    rb-fsevent (0.10.3)
+    rb-inotify (0.9.10)
+      ffi (>= 0.5.0, < 2)
+    record_tag_helper (1.0.0)
+      actionview (~> 5.x)
     redcarpet (3.4.0)
     ref (2.0.0)
-    request_store (1.3.2)
-    rinku (2.0.2)
-    rotp (3.3.0)
-    rubocop (0.47.1)
-      parser (>= 2.3.3.1, < 3.0)
+    request_store (1.4.1)
+      rack (>= 1.4)
+    rinku (2.0.4)
+    rotp (3.3.1)
+    rubocop (0.57.2)
+      jaro_winkler (~> 1.5.1)
+      parallel (~> 1.10)
+      parser (>= 2.5)
       powerpack (~> 0.1)
-      rainbow (>= 1.99.1, < 3.0)
+      rainbow (>= 2.2.2, < 4.0)
       ruby-progressbar (~> 1.7)
       unicode-display_width (~> 1.0, >= 1.0.1)
     ruby-openid (2.7.0)
-    ruby-progressbar (1.8.1)
+    ruby-progressbar (1.9.0)
+    ruby_dep (1.5.0)
     safe_yaml (1.0.4)
-    sanitize (4.4.0)
+    sanitize (4.6.5)
       crass (~> 1.0.2)
       nokogiri (>= 1.4.4)
-      nokogumbo (~> 1.4.1)
-    sass (3.4.23)
-    sass-rails (5.0.6)
+      nokogumbo (~> 1.4)
+    sass (3.5.6)
+      sass-listen (~> 4.0.0)
+    sass-listen (4.0.0)
+      rb-fsevent (~> 0.9, >= 0.9.4)
+      rb-inotify (~> 0.9, >= 0.9.7)
+    sass-rails (5.0.7)
       railties (>= 4.0.0, < 6)
       sass (~> 3.1)
       sprockets (>= 2.8, < 4.0)
       sprockets-rails (>= 2.0, < 4.0)
       tilt (>= 1.1, < 3)
-    secure_headers (3.6.2)
-      useragent
-    simplecov (0.12.0)
+    secure_headers (6.0.0)
+    simplecov (0.14.1)
       docile (~> 1.1.0)
       json (>= 1.8, < 3)
       simplecov-html (~> 0.10.0)
-    simplecov-html (0.10.0)
+    simplecov-html (0.10.2)
     sprockets (3.7.1)
       concurrent-ruby (~> 1.0)
       rack (> 1, < 3)
-    sprockets-rails (3.2.0)
+    sprockets-rails (3.2.1)
       actionpack (>= 4.0)
       activesupport (>= 4.0)
       sprockets (>= 3.0.0)
-    term-ansicolor (1.4.0)
+    term-ansicolor (1.6.0)
       tins (~> 1.0)
+    terrapin (0.6.0)
+      climate_control (>= 0.0.3, < 1.0)
     therubyracer (0.12.3)
       libv8 (~> 3.16.14.15)
       ref
     thor (0.19.4)
     thread_safe (0.3.6)
-    tilt (2.0.7)
-    timecop (0.8.1)
-    tins (1.13.2)
-    tzinfo (1.2.2)
+    tilt (2.0.8)
+    tins (1.16.3)
+    tzinfo (1.2.5)
       thread_safe (~> 0.1)
-    uglifier (3.1.9)
+    uglifier (4.1.11)
       execjs (>= 0.3.0, < 3)
-    unicode-display_width (1.1.3)
-    useragent (0.16.8)
+    unicode-display_width (1.4.0)
     validates_email_format_of (1.6.3)
       i18n
     vendorer (0.1.16)
-    webmock (2.3.2)
+    webmock (3.4.2)
       addressable (>= 2.3.6)
       crack (>= 0.3.2)
       hashdiff
     websocket-driver (0.6.5)
       websocket-extensions (>= 0.1.0)
-    websocket-extensions (0.1.2)
-    xpath (2.0.0)
-      nokogiri (~> 1.3)
+    websocket-extensions (0.1.3)
+    xpath (3.1.0)
+      nokogiri (~> 1.8)
 
 PLATFORMS
   ruby
 
 DEPENDENCIES
   SystemTimer (>= 1.1.3)
+  aasm
   actionpack-page_caching
+  annotate
   autoprefixer-rails
+  better_errors
   bigdecimal (~> 1.1.0)
+  binding_of_caller
   canonical-rails
-  coffee-rails (~> 4.1.0)
-  composite_primary_keys (~> 8.1.0)
+  capybara (~> 2.13)
+  coffee-rails (~> 4.2)
+  composite_primary_keys (~> 10.0.4)
   coveralls
   dalli
-  deadlock_retry (>= 1.2.0)
   dynamic_form
-  factory_girl_rails
+  factory_bot_rails
   faraday
   geoip
   htmlentities
   http_accept_language (~> 2.0.0)
-  i18n-js (>= 3.0.0.rc10)
+  i18n-js (>= 3.0.0)
   image_optim_rails
   jquery-rails
   jshint
   json
   jsonify-rails
   kgio
-  konacha
   libxml-ruby (>= 2.0.5)
+  listen
   logstasher
   minitest (~> 5.1)
   oauth-plugin (>= 0.5.1)
@@ -366,15 +403,20 @@ DEPENDENCIES
   omniauth-mediawiki (>= 0.0.3)
   omniauth-openid
   omniauth-windowslive
-  paperclip (~> 4.0)
-  pg
+  openstreetmap-deadlock_retry (>= 1.3.0)
+  paperclip (~> 5.2)
+  pg (~> 0.18)
   poltergeist
   psych
-  r2
+  puma (~> 3.7)
+  quad_tile (~> 1.0.1)
+  r2 (~> 0.2.7)
   rack-cors
   rack-uri_sanitizer
-  rails (= 4.2.8)
+  rails (= 5.1.6)
+  rails-controller-testing
   rails-i18n (~> 4.0.0)
+  record_tag_helper
   redcarpet
   rinku (>= 1.2.2)
   rotp
@@ -382,11 +424,10 @@ DEPENDENCIES
   sanitize
   sass-rails (~> 5.0)
   secure_headers
-  timecop
   uglifier (>= 1.3.0)
   validates_email_format_of (>= 1.5.1)
   vendorer
   webmock
 
 BUNDLED WITH
-   1.12.5
+   1.16.2