Allow indexing of diary entries again
[rails.git] / Gemfile.lock
index de5157c..80f9468 100644 (file)
@@ -79,6 +79,8 @@ GEM
       msgpack (~> 1.0)
     browser (2.5.3)
     builder (3.2.3)
+    bzip2-ffi (1.0.0)
+      ffi (~> 1.0)
     cancancan (3.0.1)
     canonical-rails (0.2.5)
       rails (>= 4.1, < 6.1)
@@ -99,7 +101,6 @@ GEM
       coffee-script-source
       execjs
     coffee-script-source (1.12.2)
-    colorize (0.8.1)
     composite_primary_keys (11.1.0)
       activerecord (~> 5.2.1)
     concurrent-ruby (1.1.5)
@@ -162,10 +163,6 @@ GEM
       rubocop (~> 0.51)
       smart_properties
     erubi (1.8.0)
-    eslint-rails-ee (1.0.2)
-      colorize
-      execjs
-      railties (>= 3.2)
     execjs (2.7.0)
     exifr (1.3.6)
     factory_bot (5.0.2)
@@ -177,8 +174,10 @@ GEM
     faraday (0.15.4)
       multipart-post (>= 1.2, < 3)
     ffi (1.11.1)
+    ffi-libarchive (0.4.6)
+      ffi (~> 1.0)
     fspath (3.1.1)
-    gd2-ffij (0.3.0)
+    gd2-ffij (0.4.0)
       ffi (>= 1.0.0)
     geoip (1.6.4)
     globalid (0.4.2)
@@ -218,7 +217,6 @@ GEM
     jwt (2.2.1)
     kgio (2.11.2)
     kramdown (2.1.0)
-    libv8 (3.16.14.19)
     libxml-ruby (3.1.0)
     listen (3.1.5)
       rb-fsevent (~> 0.9, >= 0.9.4)
@@ -359,7 +357,6 @@ GEM
       ffi (~> 1.0)
     record_tag_helper (1.0.0)
       actionview (~> 5.x)
-    ref (2.0.0)
     request_store (1.4.1)
       rack (>= 1.4)
     rinku (2.0.6)
@@ -414,9 +411,6 @@ GEM
       tins (~> 1.0)
     terrapin (0.6.0)
       climate_control (>= 0.0.3, < 1.0)
-    therubyracer (0.12.3)
-      libv8 (~> 3.16.14.15)
-      ref
     thor (0.20.3)
     thread_safe (0.3.6)
     tilt (2.0.9)
@@ -455,6 +449,7 @@ DEPENDENCIES
   binding_of_caller
   bootsnap (>= 1.1.0)
   browser
+  bzip2-ffi
   cancancan
   canonical-rails
   capybara (~> 2.13)
@@ -466,12 +461,11 @@ DEPENDENCIES
   delayed_job_active_record
   dynamic_form
   erb_lint
-  eslint-rails-ee
-  execjs
   factory_bot_rails
   fakefs
   faraday
-  gd2-ffij
+  ffi-libarchive
+  gd2-ffij (>= 0.4.0)
   geoip
   htmlentities
   http_accept_language (~> 2.0.0)
@@ -485,6 +479,7 @@ DEPENDENCIES
   libxml-ruby (>= 2.0.5)
   listen
   logstasher
+  mimemagic
   minitest (~> 5.1)
   oauth-plugin (>= 0.5.1)
   omniauth
@@ -517,7 +512,6 @@ DEPENDENCIES
   sassc-rails
   secure_headers
   strong_migrations
-  therubyracer
   uglifier (>= 1.3.0)
   validates_email_format_of (>= 1.5.1)
   vendorer