Fix rubocop warnings
[rails.git] / config / application.rb
index 3cb01eabf0279340d9a663d3fb7e944a4734f3d5..ff9ac16027e9ff4dfc1f489066af8f60e639eb21 100644 (file)
@@ -1,20 +1,20 @@
-require File.expand_path('../boot', __FILE__)
+require File.expand_path("../boot", __FILE__)
 
 
-require File.expand_path('../preinitializer', __FILE__)
+require File.expand_path("../preinitializer", __FILE__)
 
 if STATUS == :database_offline
 
 if STATUS == :database_offline
-require "action_controller/railtie"
-require "action_mailer/railtie"
-require "active_model/railtie"
-require "sprockets/railtie"
-require "rails/test_unit/railtie"
+  require "action_controller/railtie"
+  require "action_mailer/railtie"
+  require "active_model/railtie"
+  require "sprockets/railtie"
+  require "rails/test_unit/railtie"
 else
 else
-require 'rails/all'
+  require "rails/all"
 end
 
 # Require the gems listed in Gemfile, including any gems
 # you've limited to :test, :development, or :production.
 end
 
 # Require the gems listed in Gemfile, including any gems
 # you've limited to :test, :development, or :production.
-Bundler.require(:default, Rails.env)
+Bundler.require(*Rails.groups)
 
 module OpenStreetMap
   class Application < Rails::Application
 
 module OpenStreetMap
   class Application < Rails::Application
@@ -30,28 +30,34 @@ module OpenStreetMap
     # config.i18n.load_path += Dir[Rails.root.join('my', 'locales', '*.{rb,yml}').to_s]
     # config.i18n.default_locale = :de
 
     # config.i18n.load_path += Dir[Rails.root.join('my', 'locales', '*.{rb,yml}').to_s]
     # config.i18n.default_locale = :de
 
-    # Custom directories with classes and modules you want to be autoloadable.
-    config.autoload_paths += %W(#{config.root}/lib)
+    # Do not swallow errors in after_commit/after_rollback callbacks.
+    config.active_record.raise_in_transactional_callbacks = true unless STATUS == :database_offline
 
 
-    # Configure the default encoding used in templates for Ruby 1.9.
-    config.encoding = "utf-8"
+    # Custom directories with classes and modules you want to be autoloadable.
+    config.autoload_paths += %W[#{config.root}/lib]
 
     # Use SQL instead of Active Record's schema dumper when creating the database.
     # This is necessary if your schema can't be completely dumped by the schema dumper,
     # like if you have constraints or database-specific column types
 
     # Use SQL instead of Active Record's schema dumper when creating the database.
     # This is necessary if your schema can't be completely dumped by the schema dumper,
     # like if you have constraints or database-specific column types
-    unless STATUS == :database_offline
-      config.active_record.schema_format = :sql
-    end
+    config.active_record.schema_format = :sql unless STATUS == :database_offline
 
 
-    # Enable the asset pipeline
-    config.assets.enabled = true
+    # Don't eager load models when the database is offline
+    config.paths["app/models"].skip_eager_load! if STATUS == :database_offline
 
 
-    # Version of your assets, change this if you want to expire all your assets
-    config.assets.version = '1.0'
+    # Use memcached for caching if required
+    if defined?(MEMCACHE_SERVERS)
+      config.cache_store = :mem_cache_store, MEMCACHE_SERVERS, { :namespace => "rails:cache" }
+    end
 
 
-    # Don't eager load models when the database is offline
-    if STATUS == :database_offline
-      config.paths["app/models"].skip_eager_load!
+    # Use logstash for logging if required
+    if defined?(LOGSTASH_PATH)
+      config.logstasher.enabled = true
+      config.logstasher.suppress_app_log = false
+      config.logstasher.logger_path = LOGSTASH_PATH
+      config.logstasher.log_controller_parameters = true
     end
     end
+
+    # Configure image optimisation
+    config.assets.image_optim = YAML.load_file(Rails.root.join("config", "image_optim.yml"))
   end
 end
   end
 end