Fix rubocop warnings
[rails.git] / .travis.yml
index e4f7390936762ad0c41a3abd09aa2350f2d6393f..ad8f7e599ea42dff4504becf9e0aaa15625a942d 100644 (file)
@@ -1,7 +1,7 @@
 sudo: false
 language: ruby
 rvm:
-  - 1.9.3
+  - 2.3.1
 cache: bundler
 addons:
   postgresql: 9.1
@@ -14,6 +14,7 @@ env:
   global:
     - OSM_MEMCACHE_SERVERS="127.0.0.1"
 before_script:
+  - cp config/example.application.yml config/application.yml
   - psql -U postgres -c "CREATE DATABASE openstreetmap"
   - psql -U postgres -c "CREATE EXTENSION btree_gist" openstreetmap
   - make -C db/functions libpgosm.so
@@ -25,4 +26,4 @@ before_script:
 script:
   - bundle exec rubocop -f fuubar
   - bundle exec rake jshint
-  - bundle exec rake test
+  - bundle exec rake test:db