prevent update of any object without providing the correct/current
[rails.git] / app / controllers / node_controller.rb
index 956a8b8d9e10a50532c98863fbfbd38922777f5c..fa6759c3b5debb59e601a7bd519d401ac352dfd9 100644 (file)
@@ -49,6 +49,10 @@ class NodeController < ApplicationController
     begin
       node = Node.find(params[:id])
       new_node = Node.from_xml(request.raw_post)
+      if new_node.version != node.version
+        render :text => "Version mismatch: Provided " + new_node.version.to_s + ", server had: " + node.version.to_s, :status => :bad_request
+        return
+      end  
 
       if new_node and new_node.id == node.id
         node.update_from(new_node, @user)