jsrouting: don't close the smallscreen header until both geocodes entered
[rails.git] / Gemfile
diff --git a/Gemfile b/Gemfile
index 5b5a76e650d15abc1f14bed7fe936864c1102c05..e59705dad6df15aa0ee58da4d64194581fad5004 100644 (file)
--- a/Gemfile
+++ b/Gemfile
@@ -1,35 +1,56 @@
-# Gem source to use
-source 'http://rubygems.org'
+source 'https://rubygems.org'
 
 # Require rails
-gem 'rails', '3.2.9'
+gem 'rails', '4.2.0'
 
 # Require things which have moved to gems in ruby 1.9
-gem 'bigdecimal', :platforms => :ruby_19
+gem 'bigdecimal', "~> 1.1.0", :platforms => :ruby_19
 
-# Require the postgres database driver
+# Require things which have moved to gems in ruby 2.0
+gem 'psych', :platforms => :ruby_20
+
+# Require json for multi_json
+gem 'json'
+
+# Use postgres as the database
 gem 'pg'
 
-# Load jquery support
+# Use SCSS for stylesheets
+gem 'sass-rails', '~> 5.0'
+
+# Use Uglifier as compressor for JavaScript assets
+gem 'uglifier', '>= 1.3.0'
+
+# Use CoffeeScript for .js.coffee assets and views
+gem 'coffee-rails', '~> 4.1.0'
+
+# Use jquery as the JavaScript library
 gem 'jquery-rails'
 
-# Load R2 for RTL conversion
+# Build JSON APIs with ease. Read more: https://github.com/rails/jbuilder
+# gem 'jbuilder', '~> 2.0'
+gem 'jsonify-rails'
+
+# Use R2 for RTL conversion
 gem 'r2'
 
+# Use autoprefixer to generate CSS prefixes
+gem 'autoprefixer-rails'
+
 # Load rails plugins
-gem 'rails-i18n', ">= 0.6.3"
+gem 'rails-i18n', "~> 4.0.0"
 gem 'dynamic_form'
 gem 'rinku', '>= 1.2.2', :require => 'rails_rinku'
-gem 'oauth-plugin', '>= 0.4.1', :require => 'oauth-plugin'
+gem 'oauth-plugin', '>= 0.5.1'
 gem 'open_id_authentication', '>= 1.1.0'
 gem 'validates_email_format_of', '>= 1.5.1'
-gem 'composite_primary_keys', '>= 5.0.10'
-gem 'http_accept_language', '>= 1.0.2'
-gem 'paperclip', '~> 2.0'
+gem 'composite_primary_keys', '~> 8.0.0'
+gem 'http_accept_language', '~> 2.0.0'
+gem 'paperclip', '~> 4.0'
 gem 'deadlock_retry', '>= 1.2.0'
-gem 'i18n-js', '>= 3.0.0.rc2'
+gem 'openstreetmap-i18n-js', '>= 3.0.0.rc5.3', :require => 'i18n-js'
 gem 'rack-cors'
-gem 'jsonify-rails'
+gem 'actionpack-page_caching'
 
 # We need ruby-openid 2.2.0 or later for ruby 1.9 support
 gem 'ruby-openid', '>= 2.2.0'
@@ -38,7 +59,7 @@ gem 'ruby-openid', '>= 2.2.0'
 gem 'redcarpet'
 
 # Character conversion support for ruby 1.8
-gem 'iconv', :platforms => :ruby_18
+gem 'iconv', '= 0.1', :platforms => :ruby_18
 
 # Load libxml support for XML parsing and generation
 gem 'libxml-ruby', '>= 2.0.5', :require => 'libxml'
@@ -50,23 +71,27 @@ gem 'htmlentities'
 # Load SystemTimer for implementing request timeouts
 gem 'SystemTimer', '>= 1.1.3', :require => 'system_timer', :platforms => :ruby_18
 
-# Load httpclient for SOAP support for Quova GeoIP queries
+# Load httpclient and soap4r for SOAP support for Quova GeoIP queries
 gem 'httpclient'
+gem 'soap4r-ruby1.9'
 
-# Load memcache in case we are using it
-gem 'memcached', '>= 1.4.1'
+# Load memcache client in case we are using it
+gem 'dalli'
+gem 'kgio'
+
+# Gems useful for development
+group :development do
+  gem 'vendorer'
+end
 
 # Gems needed for running tests
 group :test do
   gem 'timecop'
-  gem 'minitest', :platforms => :ruby_19
+  gem 'minitest', '~> 5.1', :platforms => [:ruby_19, :ruby_20]
 end
 
-# Gems needed for compiling assets
-group :assets do
-  gem 'sass-rails', '~> 3.2.3'
-  gem 'coffee-rails', '~> 3.2.1'
-  gem 'uglifier', '>= 1.0.3'
-  gem 'therubyracer'
-  gem 'ejs'
+# Needed in development as well so rake can see konacha tasks
+group :development, :test do
+  gem 'konacha'
+  gem 'poltergeist'
 end