Fix tests that referred to node lat and lons
[rails.git] / db / functions / quadtile.c
index d60189245bd3f2ef5c09fe61a91bc87beab01868..748e0b9aa211f3a8e371a57bcba5c8ce0274585b 100644 (file)
@@ -1,31 +1,25 @@
-#include <my_global.h>
-#include <my_sys.h>
-#include <m_string.h>
-#include <mysql.h>
+#include <math.h>
 #include <quad_tile.h>
+#include <postgres.h>
+#include <fmgr.h>
 
-my_bool tile_for_point_init(UDF_INIT *initid, UDF_ARGS *args, char *message)
+Datum
+tile_for_point(PG_FUNCTION_ARGS)
 {
-   if ( args->arg_count != 2 ||
-        args->arg_type[0] != INT_RESULT ||
-        args->arg_type[1] != INT_RESULT )
-   {
-      strcpy( message, "Your tile_for_point arguments are bogus!" );
-      return 1;
-   }
+  double lat = PG_GETARG_INT32(0) / 10000000.0;
+  double lon = PG_GETARG_INT32(1) / 10000000.0;
 
-   return 0;
+  PG_RETURN_INT64(xy2tile(lon2x(lon), lat2y(lat)));
 }
 
-void tile_for_point_deinit(UDF_INIT *initid)
-{
-   return;
-}
+PG_FUNCTION_INFO_V1(tile_for_point);
 
-long long tile_for_point(UDF_INIT *initid, UDF_ARGS *args, char *is_null, char *error)
-{
-   long long lat = *(long long *)args->args[0];
-   long long lon = *(long long *)args->args[1];
-
-   return xy2tile(lon2x(lon / 10000000.0), lat2y(lat / 10000000.0));
-}
+/*
+ * To bind this into PGSQL, try something like:
+ *
+ * CREATE FUNCTION tile_for_point(int4, int4) RETURNS int8
+ *  AS '/path/to/rails-port/db/functions/libpgosm', 'tile_for_point'
+ *  LANGUAGE C STRICT;
+ *
+ * (without all the *s)
+ */