Potlatch 1.0
[rails.git] / lib / osm.rb
index f3a625c4eba61b90aef57ccb198a62d7fe96a959..885d1e35821961d998e85bf78e75eff081a9ff57 100644 (file)
@@ -133,13 +133,12 @@ module OSM
     attr_reader :provided, :latest, :id, :type
 
     def render_opts
-      { :text => "Version mismatch: Provided " + provided.to_s +
-        ", server had: " + latest.to_s + " of " + type + " " + id.to_s, 
+      { :text => "Version mismatch: Provided #{provided}, server had: #{latest} of #{type} #{id}",
         :status => :conflict, :content_type => "text/plain" }
     end
     
     def to_s
-       "Version mismatch: Provided " + provided.to_s + ", server had: " + latest.to_s + " of " + type + " " + id.to_s
+       "Version mismatch: Provided #{provided}, server had: #{latest} of #{type} #{id}"
     end
   end