Fix compatibility with older versions of the ruby std lib (i.e: the one on cruise...
[rails.git] / lib / geo_record.rb
index 025bbe4a87b38b13a960751bdc2e63304e75e762..2740eab0c5472da4c76d95128c5f8253dd440cbb 100644 (file)
@@ -1,4 +1,9 @@
 module GeoRecord
+  # This scaling factor is used to convert between the float lat/lon that is 
+  # returned by the API, and the integer lat/lon equivalent that is stored in
+  # the database.
+  SCALE = 10000000
+  
   def self.included(base)
     base.extend(ClassMethods)
   end
@@ -20,32 +25,23 @@ module GeoRecord
   end
 
   def lat=(l)
-    self.latitude = (l * 10000000).round
+    self.latitude = (l * SCALE).round
   end
 
   def lon=(l)
-    self.longitude = (l * 10000000).round
+    self.longitude = (l * SCALE).round
   end
 
   # Return WGS84 latitude
   def lat
-    return self.latitude.to_f / 10000000
+    return self.latitude.to_f / SCALE
   end
 
   # Return WGS84 longitude
   def lon
-    return self.longitude.to_f / 10000000
-  end
-
-  # Potlatch projections
-  def lon_potlatch(baselong,masterscale)
-    (self.lon-baselong)*masterscale
+    return self.longitude.to_f / SCALE
   end
 
-  def lat_potlatch(basey,masterscale)
-    -(lat2y(self.lat)-basey)*masterscale
-  end
-  
 private
   
   def lat2y(a)