Add JSHint support
[rails.git] / Gemfile.lock
index f4a2c9b5b746b742c6d7453345a31daff30766c2..f40dc2b72aaef4c0abf54569f7d7478fbd743d40 100644 (file)
@@ -88,6 +88,10 @@ GEM
       rails-dom-testing (~> 1.0)
       railties (>= 4.2.0)
       thor (>= 0.14, < 2.0)
+    jshint (1.3.1)
+      execjs (>= 1.4.0)
+      multi_json (~> 1.0)
+      therubyracer (~> 0.12.1)
     json (1.8.2)
     jsonify (0.3.1)
       multi_json (~> 1.0)
@@ -102,6 +106,7 @@ GEM
       colorize
       railties (>= 3.1, < 5)
       sprockets
+    libv8 (3.16.14.7)
     libxml-ruby (2.8.0)
     loofah (2.0.1)
       nokogiri (>= 1.5.9)
@@ -186,6 +191,7 @@ GEM
     rainbow (2.0.0)
     rake (10.4.2)
     redcarpet (3.2.2)
+    ref (1.0.5)
     rinku (1.7.3)
     rubocop (0.29.1)
       astrolabe (~> 1.3)
@@ -195,7 +201,7 @@ GEM
       ruby-progressbar (~> 1.4)
     ruby-openid (2.6.0)
     ruby-progressbar (1.7.1)
-    sanitize (3.1.1)
+    sanitize (3.1.2)
       crass (~> 1.0.1)
       nokogiri (>= 1.4.4)
       nokogumbo (= 1.2.0)
@@ -216,6 +222,9 @@ GEM
       actionpack (>= 3.0)
       activesupport (>= 3.0)
       sprockets (>= 2.8, < 4.0)
+    therubyracer (0.12.1)
+      libv8 (~> 3.16.14.0)
+      ref
     thor (0.19.1)
     thread_safe (0.3.4)
     tilt (1.4.1)
@@ -228,7 +237,7 @@ GEM
     validates_email_format_of (1.6.2)
       i18n
     vendorer (0.1.16)
-    websocket-driver (0.5.2)
+    websocket-driver (0.5.3)
       websocket-extensions (>= 0.1.0)
     websocket-extensions (0.1.2)
     xpath (2.0.0)
@@ -251,6 +260,7 @@ DEPENDENCIES
   http_accept_language (~> 2.0.0)
   httpclient
   jquery-rails
+  jshint
   json
   jsonify-rails
   kgio