Localisation updates from translatewiki.net (2009-12-05)
[rails.git] / config / initializers / libxml.rb
index a1870dbab8b4aaaacfe5e5169bcb40e622f3dc11..07f79660f8a8b13107a3bc84dd6f41430b960200 100644 (file)
@@ -1,7 +1,5 @@
-require 'rubygems'
-gem 'libxml-ruby', '>= 0.8.3'
-require 'libxml'
-
-LibXML::XML::Parser.register_error_handler do |message|
+# This is required otherwise libxml writes out memory errors to
+# the standard output and exits uncleanly
+LibXML::XML::Error.set_handler do |message|
   raise message
 end