Update bundle
authorTom Hughes <tom@compton.nu>
Mon, 22 Jan 2018 14:17:52 +0000 (14:17 +0000)
committerTom Hughes <tom@compton.nu>
Mon, 22 Jan 2018 18:55:45 +0000 (18:55 +0000)
Gemfile
Gemfile.lock

diff --git a/Gemfile b/Gemfile
index 79d95f9d5af3e7bc91376002e0e3574997c28aa8..07ee5a3862b707cd2aeda300c8b19ad10401cb58 100644 (file)
--- a/Gemfile
+++ b/Gemfile
@@ -13,7 +13,7 @@ gem "psych", :platforms => :ruby_20
 gem "json"
 
 # Use postgres as the database
-gem "pg"
+gem "pg", "~> 0.18"
 
 # Use SCSS for stylesheets
 gem "sass-rails", "~> 5.0"
@@ -48,7 +48,7 @@ gem "http_accept_language", "~> 2.0.0"
 gem "i18n-js", ">= 3.0.0"
 gem "oauth-plugin", ">= 0.5.1"
 gem "openstreetmap-deadlock_retry", ">= 1.3.0", :require => "deadlock_retry"
-gem "paperclip", "~> 4.0"
+gem "paperclip", "~> 5.0"
 gem "rack-cors"
 gem "rails-i18n", "~> 4.0.0"
 gem "record_tag_helper"
index 1cff441517ad978f29781b934b7d06f0ecf88c48..c03ab51a548e5e0154a2a4b418dc469f7561bac6 100644 (file)
@@ -48,19 +48,19 @@ GEM
       rake (>= 10.4, < 13.0)
     arel (8.0.0)
     ast (2.3.0)
-    autoprefixer-rails (7.1.6)
+    autoprefixer-rails (7.2.5)
       execjs
     bigdecimal (1.1.0)
     builder (3.2.3)
     canonical-rails (0.2.1)
       rails (>= 4.1, < 5.2)
-    capybara (2.16.1)
+    capybara (2.17.0)
       addressable
       mini_mime (>= 0.1.3)
       nokogiri (>= 1.3.3)
       rack (>= 1.0.0)
       rack-test (>= 0.5.4)
-      xpath (~> 2.0)
+      xpath (>= 2.0, < 4.0)
     climate_control (0.2.0)
     cliver (0.3.2)
     cocaine (0.5.8)
@@ -72,8 +72,8 @@ GEM
       coffee-script-source
       execjs
     coffee-script-source (1.12.2)
-    composite_primary_keys (10.0.1)
-      activerecord (~> 5.1.0)
+    composite_primary_keys (10.0.2)
+      activerecord (~> 5.1.0, >= 5.1.4)
     concurrent-ruby (1.0.5)
     coveralls (0.8.21)
       json (>= 1.8, < 3)
@@ -89,7 +89,7 @@ GEM
     dynamic_form (1.1.4)
     erubi (1.7.0)
     execjs (2.7.0)
-    exifr (1.3.2)
+    exifr (1.3.3)
     factory_bot (4.8.2)
       activesupport (>= 3.0.0)
     factory_bot_rails (4.8.2)
@@ -103,14 +103,14 @@ GEM
     globalid (0.4.1)
       activesupport (>= 4.2.0)
     hashdiff (0.3.7)
-    hashie (3.5.6)
+    hashie (3.5.7)
     htmlentities (4.3.4)
     http_accept_language (2.0.5)
     i18n (0.9.1)
       concurrent-ruby (~> 1.0)
-    i18n-js (3.0.2)
+    i18n-js (3.0.3)
       i18n (~> 0.6, >= 0.6.6)
-    image_optim (0.26.0)
+    image_optim (0.26.1)
       exifr (~> 1.2, >= 1.2.2)
       fspath (~> 3.0)
       image_size (~> 1.5)
@@ -137,7 +137,7 @@ GEM
       actionpack
       jsonify (< 0.4.0)
     jwt (1.5.6)
-    kgio (2.11.0)
+    kgio (2.11.1)
     libv8 (3.16.14.19)
     libxml-ruby (3.0.0)
     listen (3.1.5)
@@ -158,14 +158,14 @@ GEM
     mime-types (3.1)
       mime-types-data (~> 3.2015)
     mime-types-data (3.2016.0521)
-    mimemagic (0.3.0)
+    mimemagic (0.3.2)
     mini_mime (1.0.0)
     mini_portile2 (2.3.0)
-    minitest (5.10.3)
-    multi_json (1.12.2)
+    minitest (5.11.1)
+    multi_json (1.13.1)
     multi_xml (0.6.0)
     multipart-post (2.0.0)
-    nio4r (2.1.0)
+    nio4r (2.2.0)
     nokogiri (1.8.1)
       mini_portile2 (~> 2.3.0)
     nokogumbo (1.4.13)
@@ -182,7 +182,7 @@ GEM
       multi_json (~> 1.3)
       multi_xml (~> 0.5)
       rack (>= 1.2, < 3)
-    omniauth (1.7.1)
+    omniauth (1.8.1)
       hashie (>= 3.4.6, < 3.6.0)
       rack (>= 1.6.2, < 3)
     omniauth-facebook (4.0.0)
@@ -201,8 +201,8 @@ GEM
     omniauth-oauth (1.1.0)
       oauth
       omniauth (~> 1.0)
-    omniauth-oauth2 (1.4.0)
-      oauth2 (~> 1.0)
+    omniauth-oauth2 (1.5.0)
+      oauth2 (~> 1.1)
       omniauth (~> 1.2)
     omniauth-openid (1.0.1)
       omniauth (~> 1.0)
@@ -211,25 +211,25 @@ GEM
       multi_json (~> 1.12)
       omniauth-oauth2 (~> 1.4)
     openstreetmap-deadlock_retry (1.3.0)
-    paperclip (4.3.7)
-      activemodel (>= 3.2.0)
-      activesupport (>= 3.2.0)
+    paperclip (5.1.0)
+      activemodel (>= 4.2.0)
+      activesupport (>= 4.2.0)
       cocaine (~> 0.5.5)
       mime-types
-      mimemagic (= 0.3.0)
-    parallel (1.12.0)
+      mimemagic (~> 0.3.0)
+    parallel (1.12.1)
     parser (2.4.0.2)
       ast (~> 2.3)
     pg (0.21.0)
-    poltergeist (1.16.0)
+    poltergeist (1.17.0)
       capybara (~> 2.1)
       cliver (~> 0.3.1)
       websocket-driver (>= 0.2.0)
     powerpack (0.1.1)
     progress (3.4.0)
-    psych (2.2.4)
+    psych (3.0.2)
     public_suffix (3.0.1)
-    puma (3.11.0)
+    puma (3.11.2)
     r2 (0.2.7)
     rack (2.0.3)
     rack-cors (1.0.2)
@@ -269,8 +269,7 @@ GEM
       method_source
       rake (>= 0.8.7)
       thor (>= 0.18.1, < 2.0)
-    rainbow (2.2.2)
-      rake
+    rainbow (3.0.0)
     rake (12.3.0)
     rb-fsevent (0.10.2)
     rb-inotify (0.9.10)
@@ -279,14 +278,15 @@ GEM
       actionview (~> 5.x)
     redcarpet (3.4.0)
     ref (2.0.0)
-    request_store (1.3.2)
-    rinku (2.0.3)
+    request_store (1.4.0)
+      rack (>= 1.4)
+    rinku (2.0.4)
     rotp (3.3.0)
-    rubocop (0.51.0)
+    rubocop (0.52.1)
       parallel (~> 1.10)
-      parser (>= 2.3.3.1, < 3.0)
+      parser (>= 2.4.0.2, < 3.0)
       powerpack (~> 0.1)
-      rainbow (>= 2.2.2, < 3.0)
+      rainbow (>= 2.2.2, < 4.0)
       ruby-progressbar (~> 1.7)
       unicode-display_width (~> 1.0, >= 1.0.1)
     ruby-openid (2.7.0)
@@ -297,7 +297,7 @@ GEM
       crass (~> 1.0.2)
       nokogiri (>= 1.4.4)
       nokogumbo (~> 1.4.1)
-    sass (3.5.3)
+    sass (3.5.5)
       sass-listen (~> 4.0.0)
     sass-listen (4.0.0)
       rb-fsevent (~> 0.9, >= 0.9.4)
@@ -308,7 +308,7 @@ GEM
       sprockets (>= 2.8, < 4.0)
       sprockets-rails (>= 2.0, < 4.0)
       tilt (>= 1.1, < 3)
-    secure_headers (5.0.3)
+    secure_headers (5.0.4)
       useragent (>= 0.15.0)
     simplecov (0.14.1)
       docile (~> 1.1.0)
@@ -330,25 +330,25 @@ GEM
     thor (0.19.4)
     thread_safe (0.3.6)
     tilt (2.0.8)
-    tins (1.16.0)
+    tins (1.16.3)
     tzinfo (1.2.4)
       thread_safe (~> 0.1)
-    uglifier (3.2.0)
+    uglifier (4.1.3)
       execjs (>= 0.3.0, < 3)
     unicode-display_width (1.3.0)
-    useragent (0.16.8)
+    useragent (0.16.9)
     validates_email_format_of (1.6.3)
       i18n
     vendorer (0.1.16)
-    webmock (3.1.1)
+    webmock (3.3.0)
       addressable (>= 2.3.6)
       crack (>= 0.3.2)
       hashdiff
     websocket-driver (0.6.5)
       websocket-extensions (>= 0.1.0)
     websocket-extensions (0.1.3)
-    xpath (2.1.0)
-      nokogiri (~> 1.3)
+    xpath (3.0.0)
+      nokogiri (~> 1.8)
 
 PLATFORMS
   ruby
@@ -391,8 +391,8 @@ DEPENDENCIES
   omniauth-openid
   omniauth-windowslive
   openstreetmap-deadlock_retry (>= 1.3.0)
-  paperclip (~> 4.0)
-  pg
+  paperclip (~> 5.0)
+  pg (~> 0.18)
   poltergeist
   psych
   puma (~> 3.7)