Replace sass-rails with sassc-rails
authorTom Hughes <tom@compton.nu>
Sun, 12 Aug 2018 18:53:28 +0000 (19:53 +0100)
committerTom Hughes <tom@compton.nu>
Sun, 12 Aug 2018 18:53:51 +0000 (19:53 +0100)
http://sass.logdown.com/posts/7081811

Gemfile
Gemfile.lock

diff --git a/Gemfile b/Gemfile
index 9d75954..7600fde 100644 (file)
--- a/Gemfile
+++ b/Gemfile
@@ -16,7 +16,7 @@ gem "json"
 gem "pg", "~> 0.18"
 
 # Use SCSS for stylesheets
-gem "sass-rails", "~> 5.0"
+gem "sassc-rails"
 
 # Use Uglifier as compressor for JavaScript assets
 gem "uglifier", ">= 1.3.0"
index 201b685..eb89e7d 100644 (file)
@@ -317,12 +317,16 @@ GEM
     sass-listen (4.0.0)
       rb-fsevent (~> 0.9, >= 0.9.4)
       rb-inotify (~> 0.9, >= 0.9.7)
-    sass-rails (5.0.7)
-      railties (>= 4.0.0, < 6)
-      sass (~> 3.1)
-      sprockets (>= 2.8, < 4.0)
-      sprockets-rails (>= 2.0, < 4.0)
-      tilt (>= 1.1, < 3)
+    sassc (1.12.1)
+      ffi (~> 1.9.6)
+      sass (>= 3.3.0)
+    sassc-rails (1.3.0)
+      railties (>= 4.0.0)
+      sass
+      sassc (~> 1.9)
+      sprockets (> 2.11)
+      sprockets-rails
+      tilt
     secure_headers (6.0.0)
     simplecov (0.16.1)
       docile (~> 1.1)
@@ -428,7 +432,7 @@ DEPENDENCIES
   rotp
   rubocop
   sanitize
-  sass-rails (~> 5.0)
+  sassc-rails
   secure_headers
   uglifier (>= 1.3.0)
   validates_email_format_of (>= 1.5.1)