Use a pessimistic version constraint for libxml
authorTom Hughes <tom@compton.nu>
Tue, 17 May 2011 20:35:59 +0000 (21:35 +0100)
committerTom Hughes <tom@compton.nu>
Tue, 17 May 2011 20:35:59 +0000 (21:35 +0100)
It seems that rails doesn't handle gems wth multiple version
constraints right - it generates invalid install commands. So
we use a pessimistic constraint instead.

config/environment.rb

index 15ec245..58d9432 100644 (file)
@@ -18,7 +18,7 @@ Rails::Initializer.run do |config|
   unless  STATUS == :database_offline
     config.gem 'composite_primary_keys', :version => '2.2.2'
   end
-  config.gem 'libxml-ruby', :version => ['>= 1.1.1', ' < 2.0.0'], :lib => 'libxml'
+  config.gem 'libxml-ruby', :version => '~> 1.1.1', :lib => 'libxml'
   config.gem 'rmagick', :lib => 'RMagick'
   config.gem 'oauth', :version => '>= 0.4.3'
   config.gem 'oauth-plugin', :version => '0.3.14'