This script requires perl 5.10