Remove require_terms_agreed configuration option