Upgrade minimum version of ruby to 2.5