You need at least version 0.9.1 of the composite keys gem.