Update xid_to_int4 to use postgres version 1 calling convention