Go back to the normal oauth-plugin now it is fixed