Update Potlatch 2 to r24969 build