05bfc6cbd3e6d14ea36f335a468cf6767038de70
[rails.git] / Gemfile
1 source "https://rubygems.org"
2
3 # Require rails
4 gem "rails", "5.2.0"
5
6 # Require things which have moved to gems in ruby 1.9
7 gem "bigdecimal", "~> 1.1.0", :platforms => :ruby_19
8
9 # Require things which have moved to gems in ruby 2.0
10 gem "psych", :platforms => :ruby_20
11
12 # Require json for multi_json
13 gem "json"
14
15 # Use postgres as the database
16 gem "pg", "~> 0.18"
17
18 # Use SCSS for stylesheets
19 gem "sassc-rails"
20
21 # Use Uglifier as compressor for JavaScript assets
22 gem "uglifier", ">= 1.3.0"
23
24 # Use CoffeeScript for .js.coffee assets and views
25 gem "coffee-rails", "~> 4.2"
26
27 # Use jquery as the JavaScript library
28 gem "jquery-rails"
29
30 # Build JSON APIs with ease. Read more: https://github.com/rails/jbuilder
31 # gem 'jbuilder', '~> 2.0'
32 gem "jsonify-rails"
33
34 # Reduces boot times through caching; required in config/boot.rb
35 gem "bootsnap", ">= 1.1.0", :require => false
36
37 # Use R2 for RTL conversion
38 gem "r2", "~> 0.2.7"
39
40 # Use autoprefixer to generate CSS prefixes
41 gem "autoprefixer-rails", "~> 8.6.3"
42
43 # Use image_optim to optimise images
44 gem "image_optim_rails"
45
46 # Load rails plugins
47 gem "actionpack-page_caching"
48 gem "cancancan"
49 gem "composite_primary_keys", "~> 11.0.0"
50 gem "delayed_job_active_record"
51 gem "dynamic_form"
52 gem "http_accept_language", "~> 2.0.0"
53 gem "i18n-js", ">= 3.0.0"
54 gem "oauth-plugin", ">= 0.5.1"
55 gem "openstreetmap-deadlock_retry", ">= 1.3.0", :require => "deadlock_retry"
56 gem "paperclip", "~> 5.2"
57 gem "rack-cors"
58 gem "rails-i18n", "~> 4.0.0"
59 gem "record_tag_helper"
60 gem "rinku", ">= 1.2.2", :require => "rails_rinku"
61 gem "validates_email_format_of", ">= 1.5.1"
62
63 # Native OSM extensions
64 gem "quad_tile", "~> 1.0.1"
65
66 # Sanitise URIs
67 gem "rack-uri_sanitizer"
68
69 # Omniauth for authentication
70 gem "omniauth"
71 gem "omniauth-facebook"
72 gem "omniauth-github"
73 gem "omniauth-google-oauth2", ">= 0.2.7"
74 gem "omniauth-mediawiki", ">= 0.0.3"
75 gem "omniauth-openid"
76 gem "omniauth-windowslive"
77
78 # Markdown formatting support
79 gem "redcarpet"
80
81 # For status transitions of Issues
82 gem "aasm"
83
84 # Load libxml support for XML parsing and generation
85 gem "libxml-ruby", ">= 2.0.5", :require => "libxml"
86
87 # Use for HTML sanitisation
88 gem "htmlentities"
89 gem "sanitize"
90
91 # Load SystemTimer for implementing request timeouts
92 gem "SystemTimer", ">= 1.1.3", :require => "system_timer", :platforms => :ruby_18
93
94 # Load faraday for mockable HTTP client
95 gem "faraday"
96
97 # Load geoip for querying Maxmind GeoIP database
98 gem "geoip"
99
100 # Load rotp to generate TOTP tokens
101 gem "rotp"
102
103 # Load memcache client in case we are using it
104 gem "dalli"
105 gem "kgio"
106
107 # Load secure_headers for Content-Security-Policy support
108 gem "secure_headers"
109
110 # Load canonical-rails to generate canonical URLs
111 gem "canonical-rails"
112
113 # Used to generate logstash friendly log files
114 gem "logstasher"
115
116 # Gems useful for development
117 group :development do
118   gem "annotate"
119   gem "better_errors"
120   gem "binding_of_caller"
121   gem "listen"
122   gem "vendorer"
123 end
124
125 # Gems needed for running tests
126 group :test do
127   gem "minitest", "~> 5.1", :platforms => [:ruby_19, :ruby_20]
128   gem "rails-controller-testing"
129   gem "rubocop"
130   gem "webmock"
131 end
132
133 # Needed in development as well so rake can see konacha tasks
134 group :development, :test do
135   gem "capybara", "~> 2.13"
136   gem "coveralls", :require => false
137   gem "factory_bot_rails"
138   gem "jshint"
139   gem "poltergeist"
140   gem "puma", "~> 3.7"
141 end