]> git.openstreetmap.org Git - rails.git/blob - Gemfile.lock
a23782ebd9f2899e2dd7a701ff74c79b2d3d542d
[rails.git] / Gemfile.lock
1 GEM
2   remote: https://rubygems.org/
3   specs:
4     aasm (5.2.0)
5       concurrent-ruby (~> 1.0)
6     actioncable (7.0.3)
7       actionpack (= 7.0.3)
8       activesupport (= 7.0.3)
9       nio4r (~> 2.0)
10       websocket-driver (>= 0.6.1)
11     actionmailbox (7.0.3)
12       actionpack (= 7.0.3)
13       activejob (= 7.0.3)
14       activerecord (= 7.0.3)
15       activestorage (= 7.0.3)
16       activesupport (= 7.0.3)
17       mail (>= 2.7.1)
18       net-imap
19       net-pop
20       net-smtp
21     actionmailer (7.0.3)
22       actionpack (= 7.0.3)
23       actionview (= 7.0.3)
24       activejob (= 7.0.3)
25       activesupport (= 7.0.3)
26       mail (~> 2.5, >= 2.5.4)
27       net-imap
28       net-pop
29       net-smtp
30       rails-dom-testing (~> 2.0)
31     actionpack (7.0.3)
32       actionview (= 7.0.3)
33       activesupport (= 7.0.3)
34       rack (~> 2.0, >= 2.2.0)
35       rack-test (>= 0.6.3)
36       rails-dom-testing (~> 2.0)
37       rails-html-sanitizer (~> 1.0, >= 1.2.0)
38     actionpack-page_caching (1.2.4)
39       actionpack (>= 4.0.0)
40     actiontext (7.0.3)
41       actionpack (= 7.0.3)
42       activerecord (= 7.0.3)
43       activestorage (= 7.0.3)
44       activesupport (= 7.0.3)
45       globalid (>= 0.6.0)
46       nokogiri (>= 1.8.5)
47     actionview (7.0.3)
48       activesupport (= 7.0.3)
49       builder (~> 3.1)
50       erubi (~> 1.4)
51       rails-dom-testing (~> 2.0)
52       rails-html-sanitizer (~> 1.1, >= 1.2.0)
53     active_record_union (1.3.0)
54       activerecord (>= 4.0)
55     activejob (7.0.3)
56       activesupport (= 7.0.3)
57       globalid (>= 0.3.6)
58     activemodel (7.0.3)
59       activesupport (= 7.0.3)
60     activerecord (7.0.3)
61       activemodel (= 7.0.3)
62       activesupport (= 7.0.3)
63     activerecord-import (1.4.0)
64       activerecord (>= 4.2)
65     activestorage (7.0.3)
66       actionpack (= 7.0.3)
67       activejob (= 7.0.3)
68       activerecord (= 7.0.3)
69       activesupport (= 7.0.3)
70       marcel (~> 1.0)
71       mini_mime (>= 1.1.0)
72     activesupport (7.0.3)
73       concurrent-ruby (~> 1.0, >= 1.0.2)
74       i18n (>= 1.6, < 2)
75       minitest (>= 5.1)
76       tzinfo (~> 2.0)
77     addressable (2.8.0)
78       public_suffix (>= 2.0.2, < 5.0)
79     annotate (3.2.0)
80       activerecord (>= 3.2, < 8.0)
81       rake (>= 10.4, < 14.0)
82     argon2 (2.1.1)
83       ffi (~> 1.14)
84       ffi-compiler (~> 1.0)
85     ast (2.4.2)
86     autoprefixer-rails (10.4.7.0)
87       execjs (~> 2)
88     aws-eventstream (1.2.0)
89     aws-partitions (1.587.0)
90     aws-sdk-core (3.130.2)
91       aws-eventstream (~> 1, >= 1.0.2)
92       aws-partitions (~> 1, >= 1.525.0)
93       aws-sigv4 (~> 1.1)
94       jmespath (~> 1.0)
95     aws-sdk-kms (1.56.0)
96       aws-sdk-core (~> 3, >= 3.127.0)
97       aws-sigv4 (~> 1.1)
98     aws-sdk-s3 (1.114.0)
99       aws-sdk-core (~> 3, >= 3.127.0)
100       aws-sdk-kms (~> 1)
101       aws-sigv4 (~> 1.4)
102     aws-sigv4 (1.5.0)
103       aws-eventstream (~> 1, >= 1.0.2)
104     better_errors (2.9.1)
105       coderay (>= 1.0.0)
106       erubi (>= 1.0.0)
107       rack (>= 0.9.0)
108     better_html (1.0.16)
109       actionview (>= 4.0)
110       activesupport (>= 4.0)
111       ast (~> 2.0)
112       erubi (~> 1.4)
113       html_tokenizer (~> 0.0.6)
114       parser (>= 2.4)
115       smart_properties
116     binding_of_caller (1.0.0)
117       debug_inspector (>= 0.0.1)
118     bootsnap (1.11.1)
119       msgpack (~> 1.2)
120     bootstrap (4.5.3)
121       autoprefixer-rails (>= 9.1.0)
122       popper_js (>= 1.14.3, < 2)
123       sassc-rails (>= 2.0.0)
124     bootstrap_form (4.5.0)
125       actionpack (>= 5.2)
126       activemodel (>= 5.2)
127     brakeman (5.2.3)
128     browser (5.3.1)
129     builder (3.2.4)
130     bzip2-ffi (1.1.0)
131       ffi (~> 1.0)
132     cancancan (3.3.0)
133     canonical-rails (0.2.14)
134       rails (>= 4.1, <= 7.1)
135     capybara (3.37.1)
136       addressable
137       matrix
138       mini_mime (>= 0.1.3)
139       nokogiri (~> 1.8)
140       rack (>= 1.6.0)
141       rack-test (>= 0.6.3)
142       regexp_parser (>= 1.5, < 3.0)
143       xpath (~> 3.2)
144     childprocess (4.1.0)
145     coderay (1.1.3)
146     composite_primary_keys (14.0.4)
147       activerecord (~> 7.0.2)
148     concurrent-ruby (1.1.10)
149     config (4.0.0)
150       deep_merge (~> 1.2, >= 1.2.1)
151       dry-validation (~> 1.0, >= 1.0.0)
152     connection_pool (2.2.5)
153     crack (0.4.5)
154       rexml
155     crass (1.0.6)
156     dalli (3.2.1)
157     debug_inspector (1.1.0)
158     deep_merge (1.2.2)
159     delayed_job (4.1.10)
160       activesupport (>= 3.0, < 8.0)
161     delayed_job_active_record (4.1.7)
162       activerecord (>= 3.0, < 8.0)
163       delayed_job (>= 3.0, < 5)
164     digest (3.1.0)
165     docile (1.4.0)
166     doorkeeper (5.5.4)
167       railties (>= 5)
168     doorkeeper-i18n (5.2.3)
169       doorkeeper (>= 5.2)
170     dry-configurable (0.15.0)
171       concurrent-ruby (~> 1.0)
172       dry-core (~> 0.6)
173     dry-container (0.9.0)
174       concurrent-ruby (~> 1.0)
175       dry-configurable (~> 0.13, >= 0.13.0)
176     dry-core (0.7.1)
177       concurrent-ruby (~> 1.0)
178     dry-inflector (0.2.1)
179     dry-initializer (3.1.1)
180     dry-logic (1.2.0)
181       concurrent-ruby (~> 1.0)
182       dry-core (~> 0.5, >= 0.5)
183     dry-schema (1.9.1)
184       concurrent-ruby (~> 1.0)
185       dry-configurable (~> 0.13, >= 0.13.0)
186       dry-core (~> 0.5, >= 0.5)
187       dry-initializer (~> 3.0)
188       dry-logic (~> 1.0)
189       dry-types (~> 1.5)
190     dry-types (1.5.1)
191       concurrent-ruby (~> 1.0)
192       dry-container (~> 0.3)
193       dry-core (~> 0.5, >= 0.5)
194       dry-inflector (~> 0.1, >= 0.1.2)
195       dry-logic (~> 1.0, >= 1.0.2)
196     dry-validation (1.8.0)
197       concurrent-ruby (~> 1.0)
198       dry-container (~> 0.7, >= 0.7.1)
199       dry-core (~> 0.5, >= 0.5)
200       dry-initializer (~> 3.0)
201       dry-schema (~> 1.9, >= 1.9.1)
202     erb_lint (0.1.1)
203       activesupport
204       better_html (~> 1.0.7)
205       html_tokenizer
206       parser (>= 2.7.1.4)
207       rainbow
208       rubocop
209       smart_properties
210     erubi (1.10.0)
211     execjs (2.8.1)
212     exifr (1.3.9)
213     factory_bot (6.2.1)
214       activesupport (>= 5.0.0)
215     factory_bot_rails (6.2.0)
216       factory_bot (~> 6.2.0)
217       railties (>= 5.0.0)
218     faraday (2.3.0)
219       faraday-net_http (~> 2.0)
220       ruby2_keywords (>= 0.0.4)
221     faraday-net_http (2.0.2)
222     ffi (1.15.5)
223     ffi-compiler (1.0.1)
224       ffi (>= 1.0.0)
225       rake
226     ffi-libarchive (1.1.3)
227       ffi (~> 1.0)
228     fspath (3.1.2)
229     gd2-ffij (0.4.0)
230       ffi (>= 1.0.0)
231     globalid (1.0.0)
232       activesupport (>= 5.0)
233     hashdiff (1.0.1)
234     hashie (5.0.0)
235     html_tokenizer (0.0.7)
236     htmlentities (4.3.4)
237     http_accept_language (2.1.1)
238     i18n (1.10.0)
239       concurrent-ruby (~> 1.0)
240     i18n-js (3.9.2)
241       i18n (>= 0.6.6)
242     image_optim (0.31.1)
243       exifr (~> 1.2, >= 1.2.2)
244       fspath (~> 3.0)
245       image_size (>= 1.5, < 4)
246       in_threads (~> 1.3)
247       progress (~> 3.0, >= 3.0.1)
248     image_optim_rails (0.5.0)
249       image_optim (~> 0.24)
250       railties
251       sprockets
252     image_processing (1.12.2)
253       mini_magick (>= 4.9.5, < 5)
254       ruby-vips (>= 2.0.17, < 3)
255     image_size (3.0.1)
256     in_threads (1.6.0)
257     jbuilder (2.11.5)
258       actionview (>= 5.0.0)
259       activesupport (>= 5.0.0)
260     jmespath (1.6.1)
261     jquery-rails (4.4.0)
262       rails-dom-testing (>= 1, < 3)
263       railties (>= 4.2.0)
264       thor (>= 0.14, < 2.0)
265     json (2.6.2)
266     jwt (2.3.0)
267     kgio (2.11.4)
268     kramdown (2.4.0)
269       rexml
270     libxml-ruby (3.2.2)
271     listen (3.7.1)
272       rb-fsevent (~> 0.10, >= 0.10.3)
273       rb-inotify (~> 0.9, >= 0.9.10)
274     logstasher (2.1.5)
275       activesupport (>= 5.2)
276       request_store
277     loofah (2.18.0)
278       crass (~> 1.0.2)
279       nokogiri (>= 1.5.9)
280     mail (2.7.1)
281       mini_mime (>= 0.1.1)
282     marcel (1.0.2)
283     matrix (0.4.2)
284     maxminddb (0.1.22)
285     method_source (1.0.0)
286     mini_magick (4.11.0)
287     mini_mime (1.1.2)
288     mini_portile2 (2.8.0)
289     minitest (5.15.0)
290     msgpack (1.5.1)
291     multi_json (1.15.0)
292     multi_xml (0.6.0)
293     net-imap (0.2.3)
294       digest
295       net-protocol
296       strscan
297     net-pop (0.1.1)
298       digest
299       net-protocol
300       timeout
301     net-protocol (0.1.3)
302       timeout
303     net-smtp (0.3.1)
304       digest
305       net-protocol
306       timeout
307     nio4r (2.5.8)
308     nokogiri (1.13.6)
309       mini_portile2 (~> 2.8.0)
310       racc (~> 1.4)
311     oauth (0.4.7)
312     oauth-plugin (0.5.1)
313       multi_json
314       oauth (~> 0.4.4)
315       oauth2 (>= 0.5.0)
316       rack
317     oauth2 (1.4.9)
318       faraday (>= 0.17.3, < 3.0)
319       jwt (>= 1.0, < 3.0)
320       multi_json (~> 1.3)
321       multi_xml (~> 0.5)
322       rack (>= 1.2, < 3)
323     omniauth (2.0.4)
324       hashie (>= 3.4.6)
325       rack (>= 1.6.2, < 3)
326       rack-protection
327     omniauth-facebook (9.0.0)
328       omniauth-oauth2 (~> 1.2)
329     omniauth-github (2.0.0)
330       omniauth (~> 2.0)
331       omniauth-oauth2 (~> 1.7.1)
332     omniauth-google-oauth2 (1.0.1)
333       jwt (>= 2.0)
334       oauth2 (~> 1.1)
335       omniauth (~> 2.0)
336       omniauth-oauth2 (~> 1.7.1)
337     omniauth-mediawiki (0.0.4)
338       jwt (~> 2.0)
339       omniauth-oauth (~> 1.0)
340     omniauth-oauth (1.2.0)
341       oauth
342       omniauth (>= 1.0, < 3)
343     omniauth-oauth2 (1.7.2)
344       oauth2 (~> 1.4)
345       omniauth (>= 1.9, < 3)
346     omniauth-openid (2.0.1)
347       omniauth (>= 1.0, < 3.0)
348       rack-openid (~> 1.4.0)
349     omniauth-rails_csrf_protection (1.0.1)
350       actionpack (>= 4.2)
351       omniauth (~> 2.0)
352     omniauth-windowslive (0.0.12)
353       multi_json (~> 1.12)
354       omniauth-oauth2 (~> 1.4)
355     openstreetmap-deadlock_retry (1.3.1)
356     parallel (1.22.1)
357     parser (3.1.2.0)
358       ast (~> 2.4.1)
359     pg (1.3.5)
360     popper_js (1.16.0)
361     progress (3.6.0)
362     public_suffix (4.0.7)
363     puma (5.6.4)
364       nio4r (~> 2.0)
365     quad_tile (1.0.1)
366     r2 (0.2.7)
367     racc (1.6.0)
368     rack (2.2.3)
369     rack-cors (1.1.1)
370       rack (>= 2.0.0)
371     rack-openid (1.4.2)
372       rack (>= 1.1.0)
373       ruby-openid (>= 2.1.8)
374     rack-protection (2.2.0)
375       rack
376     rack-test (1.1.0)
377       rack (>= 1.0, < 3)
378     rack-uri_sanitizer (0.0.2)
379     rails (7.0.3)
380       actioncable (= 7.0.3)
381       actionmailbox (= 7.0.3)
382       actionmailer (= 7.0.3)
383       actionpack (= 7.0.3)
384       actiontext (= 7.0.3)
385       actionview (= 7.0.3)
386       activejob (= 7.0.3)
387       activemodel (= 7.0.3)
388       activerecord (= 7.0.3)
389       activestorage (= 7.0.3)
390       activesupport (= 7.0.3)
391       bundler (>= 1.15.0)
392       railties (= 7.0.3)
393     rails-controller-testing (1.0.5)
394       actionpack (>= 5.0.1.rc1)
395       actionview (>= 5.0.1.rc1)
396       activesupport (>= 5.0.1.rc1)
397     rails-dom-testing (2.0.3)
398       activesupport (>= 4.2.0)
399       nokogiri (>= 1.6)
400     rails-html-sanitizer (1.4.2)
401       loofah (~> 2.3)
402     rails-i18n (7.0.3)
403       i18n (>= 0.7, < 2)
404       railties (>= 6.0.0, < 8)
405     railties (7.0.3)
406       actionpack (= 7.0.3)
407       activesupport (= 7.0.3)
408       method_source
409       rake (>= 12.2)
410       thor (~> 1.0)
411       zeitwerk (~> 2.5)
412     rainbow (3.1.1)
413     rake (13.0.6)
414     rb-fsevent (0.11.1)
415     rb-inotify (0.10.1)
416       ffi (~> 1.0)
417     regexp_parser (2.4.0)
418     request_store (1.5.1)
419       rack (>= 1.4)
420     rexml (3.2.5)
421     rinku (2.0.6)
422     rotp (6.2.0)
423     rubocop (1.29.1)
424       parallel (~> 1.10)
425       parser (>= 3.1.0.0)
426       rainbow (>= 2.2.2, < 4.0)
427       regexp_parser (>= 1.8, < 3.0)
428       rexml (>= 3.2.5, < 4.0)
429       rubocop-ast (>= 1.17.0, < 2.0)
430       ruby-progressbar (~> 1.7)
431       unicode-display_width (>= 1.4.0, < 3.0)
432     rubocop-ast (1.18.0)
433       parser (>= 3.1.1.0)
434     rubocop-minitest (0.19.1)
435       rubocop (>= 0.90, < 2.0)
436     rubocop-performance (1.13.3)
437       rubocop (>= 1.7.0, < 2.0)
438       rubocop-ast (>= 0.4.0)
439     rubocop-rails (2.14.2)
440       activesupport (>= 4.2.0)
441       rack (>= 1.1)
442       rubocop (>= 1.7.0, < 2.0)
443     rubocop-rake (0.6.0)
444       rubocop (~> 1.0)
445     ruby-openid (2.9.2)
446     ruby-progressbar (1.11.0)
447     ruby-vips (2.1.4)
448       ffi (~> 1.12)
449     ruby2_keywords (0.0.5)
450     rubyzip (2.3.2)
451     sanitize (6.0.0)
452       crass (~> 1.0.2)
453       nokogiri (>= 1.12.0)
454     sassc (2.4.0)
455       ffi (~> 1.9)
456     sassc-rails (2.1.2)
457       railties (>= 4.0.0)
458       sassc (>= 2.0)
459       sprockets (> 3.0)
460       sprockets-rails
461       tilt
462     secure_headers (6.3.3)
463     selenium-webdriver (4.1.0)
464       childprocess (>= 0.5, < 5.0)
465       rexml (~> 3.2, >= 3.2.5)
466       rubyzip (>= 1.2.2)
467     simplecov (0.21.2)
468       docile (~> 1.1)
469       simplecov-html (~> 0.11)
470       simplecov_json_formatter (~> 0.1)
471     simplecov-html (0.12.3)
472     simplecov-lcov (0.8.0)
473     simplecov_json_formatter (0.1.4)
474     smart_properties (1.17.0)
475     sprockets (4.0.3)
476       concurrent-ruby (~> 1.0)
477       rack (> 1, < 3)
478     sprockets-rails (3.4.2)
479       actionpack (>= 5.2)
480       activesupport (>= 5.2)
481       sprockets (>= 3.0.0)
482     strong_migrations (1.0.0)
483       activerecord (>= 5.2)
484     strscan (3.0.3)
485     terser (1.1.9)
486       execjs (>= 0.3.0, < 3)
487     thor (1.2.1)
488     tilt (2.0.10)
489     timeout (0.2.0)
490     tzinfo (2.0.4)
491       concurrent-ruby (~> 1.0)
492     unicode-display_width (2.1.0)
493     validates_email_format_of (1.6.3)
494       i18n
495     vendorer (0.2.0)
496     webmock (3.14.0)
497       addressable (>= 2.8.0)
498       crack (>= 0.3.2)
499       hashdiff (>= 0.4.0, < 2.0.0)
500     websocket-driver (0.7.5)
501       websocket-extensions (>= 0.1.0)
502     websocket-extensions (0.1.5)
503     xpath (3.2.0)
504       nokogiri (~> 1.8)
505     zeitwerk (2.5.4)
506
507 PLATFORMS
508   ruby
509
510 DEPENDENCIES
511   aasm
512   actionpack-page_caching (>= 1.2.0)
513   active_record_union
514   activerecord-import
515   annotate
516   argon2
517   autoprefixer-rails
518   aws-sdk-s3
519   better_errors
520   binding_of_caller
521   bootsnap (>= 1.4.2)
522   bootstrap (~> 4.5.0)
523   bootstrap_form (~> 4.0)
524   brakeman
525   browser
526   bzip2-ffi
527   cancancan
528   canonical-rails
529   capybara (>= 2.15)
530   composite_primary_keys (~> 14.0.0)
531   config
532   connection_pool
533   dalli
534   debug_inspector
535   delayed_job_active_record
536   doorkeeper
537   doorkeeper-i18n
538   erb_lint
539   factory_bot_rails
540   faraday
541   ffi-libarchive
542   gd2-ffij (>= 0.4.0)
543   htmlentities
544   http_accept_language (~> 2.1.1)
545   i18n-js (>= 3.0.0)
546   image_optim_rails
547   image_processing
548   jbuilder (~> 2.7)
549   jquery-rails
550   json
551   kgio
552   kramdown
553   libxml-ruby (>= 2.0.5)
554   listen
555   logstasher
556   marcel
557   maxminddb
558   minitest (~> 5.1)
559   oauth-plugin (>= 0.5.1)
560   omniauth (~> 2.0.2)
561   omniauth-facebook
562   omniauth-github
563   omniauth-google-oauth2 (>= 0.6.0)
564   omniauth-mediawiki (>= 0.0.4)
565   omniauth-openid
566   omniauth-rails_csrf_protection (~> 1.0)
567   omniauth-windowslive
568   openstreetmap-deadlock_retry (>= 1.3.1)
569   pg
570   puma (~> 5.6)
571   quad_tile (~> 1.0.1)
572   r2 (~> 0.2.7)
573   rack-cors
574   rack-uri_sanitizer
575   rails (= 7.0.3)
576   rails-controller-testing
577   rails-i18n (~> 7.0.0)
578   rinku (>= 2.0.6)
579   rotp
580   rubocop
581   rubocop-minitest
582   rubocop-performance
583   rubocop-rails
584   rubocop-rake
585   sanitize
586   sassc-rails
587   secure_headers
588   selenium-webdriver
589   simplecov
590   simplecov-lcov
591   strong_migrations
592   terser
593   validates_email_format_of (>= 1.5.1)
594   vendorer
595   webmock
596
597 BUNDLED WITH
598    2.3.7