Update notifiers to use new ActionMailer API
[rails.git] / app / models / old_node.rb
index badcd74a2cb7d9d1975e9306559c56fb9fbd3e60..5e3638347a642a55ec8e33ca180012532709233b 100644 (file)
@@ -4,10 +4,15 @@ class OldNode < ActiveRecord::Base
 
   set_table_name 'nodes'
   
+  # Should probably have the composite primary key set in the model
+  # however there are some weird bugs happening when you do
+  #set_primary_keys :id, :version
+  
   validates_presence_of :changeset_id, :timestamp
   validates_inclusion_of :visible, :in => [ true, false ]
   validates_numericality_of :latitude, :longitude
   validate :validate_position
+  validates_associated :changeset
 
   belongs_to :changeset