Localisation updates from https://translatewiki.net.
[rails.git] / Gemfile
diff --git a/Gemfile b/Gemfile
index 5db975f81600c3bbd4174400b5307a6da28de6e7..dfd87eb849ff2490b495e62669fa3cf8e7e8cb0c 100644 (file)
--- a/Gemfile
+++ b/Gemfile
@@ -1,10 +1,7 @@
 source "https://rubygems.org"
 
 # Require rails
-gem "rails", "4.2.1"
-
-# Sprockets 3 seems to be buggy, so stick with 2 for now
-gem "sprockets", "~> 2.12.3"
+gem "rails", "4.2.6"
 
 # Require things which have moved to gems in ruby 1.9
 gem "bigdecimal", "~> 1.1.0", :platforms => :ruby_19
@@ -40,6 +37,9 @@ gem "r2"
 # Use autoprefixer to generate CSS prefixes
 gem "autoprefixer-rails"
 
+# Use image_optim to optimise images
+gem "image_optim", ">= 0.22.0"
+
 # Load rails plugins
 gem "rails-i18n", "~> 4.0.0"
 gem "dynamic_form"
@@ -50,13 +50,19 @@ gem "composite_primary_keys", "~> 8.1.0"
 gem "http_accept_language", "~> 2.0.0"
 gem "paperclip", "~> 4.0"
 gem "deadlock_retry", ">= 1.2.0"
-gem "openstreetmap-i18n-js", ">= 3.0.0.rc5.3", :require => "i18n-js"
+gem "i18n-js", ">= 3.0.0.rc10"
 gem "rack-cors"
 gem "actionpack-page_caching"
 
+# Sanitise URIs
+gem "rack-uri_sanitizer"
+
 # Omniauth for authentication
 gem "omniauth"
 gem "omniauth-openid"
+gem "omniauth-google-oauth2", ">= 0.2.7"
+gem "omniauth-facebook"
+gem "omniauth-windowslive"
 
 # Markdown formatting support
 gem "redcarpet"
@@ -82,6 +88,9 @@ gem "soap4r-ruby1.9"
 gem "dalli"
 gem "kgio"
 
+# Used to generate logstash friendly log files
+gem "logstasher"
+
 # Gems useful for development
 group :development do
   gem "vendorer"