Fix rubocop warnings
[rails.git] / .rubocop.yml
index dce00b925c73bc246936644f51b653a3f9fc8bdc..975457d9572a6670386e154be340781a44913299 100644 (file)
@@ -1,18 +1,34 @@
 inherit_from: .rubocop_todo.yml
 
+AllCops:
+  Include:
+    - '**/*.builder'
+
+Rails:
+  Enabled: true
+
 Style/BracesAroundHashParameters:
   EnforcedStyle: context_dependent
 
+Style/ExtraSpacing:
+  AllowForAlignment: true
+
 Style/FileName:
   Exclude:
     - 'script/deliver-message'
     - 'script/locale/reload-languages'
     - 'script/update-spam-blocks'
 
+Style/IfInsideElse:
+  Enabled: false
+
 Style/GlobalVars:
   Exclude:
     - 'lib/quad_tile/extconf.rb'
-    
+
+Style/GuardClause:
+  Enabled: false
+
 Style/HashSyntax:
   EnforcedStyle: hash_rockets
   Exclude:
@@ -21,3 +37,6 @@ Style/HashSyntax:
 
 Style/StringLiterals:
   EnforcedStyle: double_quotes
+
+Rails/HttpPositionalArguments:
+  Enabled: false